View Issue Details

IDProjectCategoryView StatusLast Update
0015661MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-10-19 21:02
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015661: Auto-tag: status updates all at once instead of incrementally (regression)
DescriptionIn build 2174, upon using Auto-tag on 12 tracks, the status bar indicated that track 1/12 was being processed and MM appeared to be frozen. Then all of a sudden, all of the tracks were updated and the status bar indicated that track 12/12 was being processed!

I can understand if there are changes to updating the list that would result in the list being updated all at once (I guess this was done to prevent on the fly regrouping of tracks), but the status bar should indicate the tagging status in real-time--otherwise it appears as if MM is frozen.
TagsNo tags attached.
Fixed in build2265

Relationships

related to 0016826 closedpetr Audio CD: Auto-Tag Not working and is slow 
related to 0016879 closedpetr Auto-tag: MM appears frozen upon clicking 'Skip and continue' 
related to 0018120 closedpetr Auto-Tag file counts incorrect in Auto-Tag Title 

Activities

rusty

2019-05-10 18:15

administrator  

auto-tag_appears_stuck.7z (240,352 bytes)

petr

2019-05-10 20:36

developer   ~0053482

Added more info into progress. Will be in 2175

rusty

2019-05-10 23:57

administrator   ~0053484

Not fixed in 2175. It just shows:

"Processing 1/11 TrackName state changed to fingerprinting"
and after some time 'Processing 11/11...'

petr

2019-05-11 08:46

developer   ~0053485

Probably most of the tracks are from same album and are found instantly ?

petr

2019-05-16 12:56

developer   ~0053539

Fixed

rusty

2019-06-05 03:36

administrator   ~0053726

Verified 2179.

rusty

2019-06-12 16:03

administrator   ~0053801

Tested with 2181 and noticed that when Lyrics lookup is enabled, tagging status will get stuck at e.g. track # 43/100 while lyrics are looked up, and then jump to 100/100.

petr

2020-01-14 14:30

developer   ~0055841

Unable to reproduce in current sources ... please retest in next build.

peke

2020-01-15 01:23

developer   ~0055845

Verified 2220

Unable to replicate either.

Test note: If you have 16 CPUs enabled then on lower number of tracks it can jump in steps 12+ depending on file size. Switching to 1 shows progress correctly

rusty

2020-08-10 22:20

administrator   ~0059314

Tested 2262. Although there's no longer a big jump, the status display is now incorrect:
MM shows File 100/100 processed, BUT it's not actually complete (Lyric lookups continue)!!
i.e. now the status bar continues to steadily advance as lookups continue, but the status indicator is incorrect (it shows 100/100 even though it's not yet close to being complete).

Repro steps are straightforward:
0 Ensure that Lyrics lookup is enabled for auto-tagging
1 Select 115 tracks and initiate auto-tag
--> Status indicator shows 100/100 tracks processed even though they're not. Meanwhile, status bar correctly shows that the lookup status is only 50% complete.

rusty

2020-08-10 22:25

administrator  

auto-tag_status-issues.jpg (51,418 bytes)   
auto-tag_status-issues.jpg (51,418 bytes)   

petr

2020-08-11 12:01

developer   ~0059325

Fixed

rusty

2020-08-13 17:47

administrator   ~0059388

Last edited: 2020-08-13 17:49

View 2 revisions

Tested 2263 and the issue remains. Note that I tested with only 100 files this time (rather than > 100). Once 100/100 files are 'processed' Lyric and Artwork lookups continue for some time.

i.e. a file should only be considered as 'processed' after all lookups associated with the file have been completed.

rusty

2020-08-13 17:48

administrator  

auto-tag_status-issues_2263.jpg (47,282 bytes)   
auto-tag_status-issues_2263.jpg (47,282 bytes)   

petr

2020-08-27 21:29

developer   ~0059496

Fixed

peke

2020-08-28 10:59

developer   ~0059502

Reminder sent to: rusty

Verified 2265

Can you please confirm if this works for you this way but I think it can further improved as the more cores CPU have it is more jumpy eg. I would leave just percentage and maybe additional progress bar to show status of processing threads, but that is for new bug?

peke

2020-12-18 01:55

developer   ~0060902

re Verified 2286

I do not see any regressions, it still works and processed shows only when all searches are done.