View Issue Details

IDProjectCategoryView StatusLast Update
0015465MediaMonkey 5Generalpublic2019-07-18 16:38
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015465: Album Art Cache anomalies for tracks with no Album assigned
DescriptionBuild 2159 is having some strange issues on my machine wrt cached album art for tracks that have no album assigned:

1 after deleting album art from files
--> the Artwork lookup button doesn't appear in the A&D dialog!
EDIT: this isn't a bug--it occurs when the Album field is empty!

2 check the properties dialog to see if there's artwork
--> nothing appears there
-->A) the Artwork lookup link re-appears in the A&D window!
EDIT: this _is_ a bug (it should either always display in such cases or always be hidden. It might be useful to always display it--see B) below)

3 Click the Artwork Lookup button
--> B) Artwork doesn't get looked up!
EDIT: if the user attempts to lookup artwork (e.g. here or in Properties) and there's no album field, mm should indicate a message "<fieldname> is missing!" (in this case 'Album').
--> C) Cached artwork (a very fuzzy image of a circle) appears in the full-screen artwork dialog
4 Auto-tag several tracks, but cancel out after the lookup
--> D) The looked up artwork isn't cached!
EDIT: this isn't a bug--it isn't cached because there's no album assigned!

Summary: it seems that some strange fuzzy image is cached for all files and that it somehow interferes with normal image caching
 
Screencast: https://www.screencast.com/t/OAUqq1xC
TagsNo tags attached.
Fixed in build2170

Relationships

related to 0015649 closedpetr Removal of images from album art cache has no effect 

Activities

rusty

2019-02-15 16:45

administrator   ~0052642

On further testing, the issue is related to the fact that I was testing with tracks that had no Album assigned. I've updated the bug accordingly and lowered the priority.

michal

2019-03-21 08:12

developer   ~0053041

Fixed in build 2167.

peke

2019-03-23 00:01

developer   ~0053087

Verified 2167

Test Note: Occasionally I was observing that some strange fuzzy image is synced for all files to MMA if no album is set on tracks. I guess that this fix also fixed that as I was not observing that behavior anymore.

rusty

2019-03-26 23:15

administrator   ~0053107

Case 3) fails in some cases and/or freezes

0 Navigate to Artist > ArtistName (browser view)
1 Select a track that only has Title / Artist (tested with Right Here Right Now - Richard Marx
2 Click Properties > Artwork > Lookup Image... and save an image (to tag), and click OK
3 Refresh the view (e.g. Back > Forward)
4 Select the track and right-click Properties
--> Album Art isn't saved!
5 Repeat the above --> MM freezes after step 2 (must be force-terminated)!

I believe that this is related to the fact that my library has hundreds of tracks that don't have an Album assigned, and by default, at step 3, [x] Apply to all files in the Album/Series is checked off (which I guess triggered hundreds of tracks to be updated).

In cases where an album isn't assigned, it would probably make more sense for the '[x] Apply to all selected files' option to appear to prevent this from occurring (though we may want a more generic solution to this issue in case it can be triggered in other ways).

michal

2019-03-29 13:03

developer   ~0053129

Last edited: 2019-03-29 13:04

View 2 revisions

Fixed in 2168. Option "Apply to all files in the Album/Series" hidden, when album is empty/not known. It is related only to editing one track so "Apply to all selected files" does not make sense there too.
I cannot reproduce problem with not saving or freezing even with tagging several tens of files, in case you repeat it, hopefully with ELF, send it, thanks.

rusty

2019-04-12 14:09

administrator   ~0053196

Verified 2168. The only remaining issue is that the error should appear transiently (i.e. as a toast, like many other similar messages in MM5).

michal

2019-04-12 14:25

developer   ~0053197

Fixed in build 2170.

rusty

2019-04-16 19:44

administrator   ~0053258

Tested 2170 to verify the error message re "<fieldname> is missing!", but MM doesn't seem to generate this message when looking up album art for tracks that only contain Artist+Title. Is this intentional (maybe due to another bug) ?

michal

2019-04-17 06:38

developer   ~0053279

For me it works, displays "Album is missing!". Could you analyze it more and be more specific? Maybe it is related to some specific situation, missing Album is not enough.

rusty

2019-07-18 16:38

administrator   ~0054163

Unable to replicate.

rusty

2019-07-18 16:38

administrator   ~0054164

Verified 2186.