View Issue Details

IDProjectCategoryView StatusLast Update
0015346MediaMonkey 5Properties/Auto-Toolspublic2019-02-14 05:43
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015346: Auto-Tag: Sometimes looks up incorrect Title
DescriptionSome tracks are being given bad title recommendations even though the actual title is contained within the filename. For example:

1) Nsync Bye Bye Bye gets looked up as 'If you don't know me by now' by 'Simply Red'. This doesn't make any sense at all--the tracks are completely unlike one another.

2) Anastacia - I'm Outta love gets looked up as Left Outside Alone !

3) The Five Satins - In the still of the night' gets changed to 'In a cool cool evening' for some reason?!
 See video at https://www.screencast.com/t/3qEZJWhO8 .
 
4) With or Without You and The Safety Dance initial lookup finds an incorrect version of the track (it's postfix is '(video version)'. If there is a version of a track without this postfix, it should be preferred.

5) Do You Really want to hurt me: initial lookup changes to 'Love Twist', not sure why. This is despite the fact that the track metadata contains the correct name (though it's not an exact match).
 
6) Thriller by Michael Jackson. Furthermore, changing the Title fails to lookup the correct Album!
TagsNo tags attached.
Fixed in build2159

Relationships

related to 0015389 closedpetr Auto-tag: when existing metadata doesn't match lookup, MM recommends incorrect Title/Artist tags 
related to 0015348 closedrusty Auto-tag: Year fields appear to get mixed up 

Activities

petr

2019-01-21 17:52

developer   ~0052151

Fixed

rusty

2019-01-22 02:56

administrator   ~0052164

Last edited: 2019-01-25 18:34

View 2 revisions

Verified all of the above cases in build 2150. I did, however, discover another case in which MM recommends a variant of the correct track:

7) Help me Rhonda - The Beach Boys. Recommends Title:'Help me Ronda' (an earlier version of the song) instead of 'Help me Rhonda'. Upon changing the Title to 'Help me Rhonda', the Album is correctly updated to Summer Days (And Summer Nights!!) .

petr

2019-01-22 22:12

developer   ~0052188

Fixed

rusty

2019-01-25 18:41

administrator   ~0052240

Last edited: 2019-01-25 18:41

View 2 revisions

I found a few more issues with 2151:

6) Hawaii-Five-O - Hawaii Five-0 - The Ventures: looks up the title incorrectly (because of 0 instead of O in Hawaii 5-0). But when the user tries to find more titles, Hawaii Five-O isn't found!

16) No More (Baby I'ma Do Right) - 3LW. MM incorrectly identifies the track as No More (Instrumental) instead of No More (Baby I'ma Do Right). Moved to 0015346 (incorrectly looked up Title)

21) Don't Tell Me - Avril Lavigne. MM recommends changing the title to 'Don't Tell me (live acoustic version)', and therefore recommends the wrong album! Also, for some reason suggestions include two identical titles of 'Don't Tell Me' (one of them being the version from the Various Artists album 'malhação international 2004' (the real album is 'Under My Skin' which is another suggestion). Moving this to 0015346 (incorrectly looked up title).

rusty

2019-01-25 21:26

administrator   ~0052245

Last edited: 2019-01-25 21:28

View 2 revisions

22) He's so fine - The Chiffons: If all metadata except for the title is deleted, and auto-tag is run, then it suggests a version of the track by Dana Valery. I'm not sure why. Moreover, as with case 21) there are multiple identical titles (see attached)?!



petr

2019-01-26 00:01

developer   ~0052249

Fixed.
re 22) look same, but isn't same ... different char sizes and apostrophes. Probably they use so much different apostrophes in MB :-/.

peke

2019-01-26 01:31

developer   ~0052261

Verified 2152

rusty

2019-01-27 02:01

administrator   ~0052270

Last edited: 2019-01-27 02:35

View 3 revisions

All previous issues seem to be resolved in 2152, but I found a few new ones:
23) Ebony and Ivory - Paul McCartney. If the user deletes all metadata except for the title and then uses auto-tag
--> MM initially recommends Ebony and Ivory (solo vocal) rather than just Ebony and Ivory

24) Travellin' Man - Ricky Nelson. The problem with this track is that the spelling is slightly off--it should be 'Travelin' Man', and consequently auto-tag can't find the real album. However, when the user tries to 'find more titles', MM can't seem to find any even though it exists in MusicBrainz at https://musicbrainz.org/release/f481049b-b941-4ed6-8e03-e487f9f0fca8

25) Miss Perfect - Abs. This track originally had issues regarding incorrect Album Artist ( 0015373 ) which have been fixed in 2152, however, when the user changes the Album from 'Miss Perfect' to 'Abstract Theory' --> Title changes to 'Miss Perfect (Problem Kid Latin Vox) for no obvious reason. (In fact, according to #14224 fii), Title shouldn't even change in response to a change in Album--do we need to discuss this?).

petr

2019-01-27 10:18

developer   ~0052275

Last edited: 2019-01-27 13:22

View 2 revisions

Fixed

rusty

2019-01-28 18:07

administrator   ~0052305

Another case (only tested with 2152):
26) Papas Got a Brand New Bag - James Brown. MM initially recommends 'Papa's Got a Brand New Bag (instrumental)' instead of the normal version.

petr

2019-01-28 19:41

developer   ~0052308

Fixed

rusty

2019-01-29 03:01

administrator   ~0052312

Last edited: 2019-01-29 05:46

View 4 revisions

Tested 2153, and:
26) is still occurring.
27) Train - Drops of Jupiter fails to look up at all!
28) Kim Wilde - You keep me hangin on. Delete all but the title. Auto tag --> it get's tagged correctly with Album: Another Step (1986). After it's tagged, run Auto-tag again --> this time the title and year are changed to: You Keep Me Hangin On (W.C.H. mix). Could it be that this is the same issue as 26), and that both of these are the same as 0015348:0052313 (in 0015348 ). I'm guessing that in all 4 cases MM is finding a more recent Release from within the same Release Group instead of keeping the original Release.

petr

2019-01-29 17:15

developer   ~0052326

Last edited: 2019-01-29 18:59

View 3 revisions

re 26) for me it reccomends 'Papa's Got a Brand New Bag, Pt. 2' (track length better fits). There are 5 recordings in year 1965 for this track:
"James Brown Plays James Brown: Yesterday and Today" Album
Papa's Got a Brand New Bag, Pt. 1
Papa's Got a Brand New Bag, Pt. 2

"James Brown at the Organ" Album
Papa's Got a Brand New Bag (instrumental)

"Papa's Got a Brand New Bag" Single
Papa's Got a Brand New Bag Part I (vocal)
Papa's Got a Brand New Bag Part II (mostly instrumental)

re 27, 28) fixed

rusty

2019-01-29 19:32

administrator   ~0052327

Verified with test build:

26) Agreed--nothing to do.
27) This is an incomplete track so the fact that it's even identified is great! Question: When it's identified as TrackName (excerpt) is that because it's identified as such OR did MediaMonkey 'realize' that it's incomplete and add '(excerpt)' to the title?
28) Verified.

petr

2019-01-29 21:40

developer   ~0052334

We make a fingerprint for first minute of the track so it was enough probably.

rusty

2019-02-06 21:10

administrator   ~0052447

29) This was originally fixed in 0015345 item 2) however, in build 2155, Love Potion Number Nine - The Clovers fails to look up the correctly--that's not a problem since the reason for this is that it's tagged with the wrong title. The bug is that when the user initiates a fingerprint lookup, MM fails to find 'Love Potion Number 9' or 'Love Potion #9' and so no correct Album can be found.

petr

2019-02-06 22:15

developer   ~0052450

Regression fixed

rusty

2019-02-07 03:30

administrator   ~0052456

30) In 2155, Julie London - Summertime. MM recommends 'When Snowflakes fall in the Summer' from 'The Wonderful World of Julie London' even though the time of Summertime is only 2 seconds off!
(It's possible that the fix to issue 29) already resolved this?)

petr

2019-02-07 10:17

developer   ~0052458

Fixed

rusty

2019-02-08 07:46

administrator   ~0052498

Tested 2156:
29) MM finds Title 'Love Potion # 9' and therefore finds the Single,
BUT, it doesn't find 'Love Potion #9' (without a space) and therefore doesn't find the Album. Moreover, 'Lookup via fingerprint...' doesn't expand the range of options.
Can we do anything about this (so matches need not be perfectly exact)?

30) Verified

petr

2019-02-08 09:55

developer   ~0052502

Fixed

rusty

2019-02-10 04:50

administrator   ~0052522

Verified 2157.

rusty

2019-02-10 17:17

administrator   ~0052538

31) Love You Like a Love Song - Selena Gomez: MM recommends the (radio instrumental) version instead of the original 'Love You Like a Love Song' (it's not an instrumental version)!

petr

2019-02-11 12:09

developer   ~0052545

Fixed

rusty

2019-02-12 02:04

administrator   ~0052590

Last edited: 2019-02-12 02:17

View 2 revisions

Tested 2158, and Issue 31 still occurs :-(

Similarly:
31b) Coldplay - Paradise: MM always recommends 'Paradise (radio edit)' even though the regular version is a better fit from a timing perspective than the radio edit.
c) LMFAO - Party Rock Anthem: MM always recommends 'Party Rock Anthem (Alesso remix) even though the timing of the regular version pretty much matches (it's off by a second, but the ripping process can account for +/- 2s).

rusty

2019-02-13 18:43

administrator   ~0052610

Last edited: 2019-02-13 18:46

View 2 revisions

32) When looking up tracks for an album David Bowie - Best of Bowie (disc two)
--> all tracks are misidentified even though there's pre-existing valid metadata

note: this only occurs when tagging all the tracks at once

petr

2019-02-13 21:20

developer   ~0052611

Fixed

rusty

2019-02-14 05:43

administrator   ~0052622

Verified 2159.