View Issue Details

IDProjectCategoryView StatusLast Update
0015328MediaMonkey 5Codecspublic2020-09-17 19:06
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015328: VP8/VP9 should be supported codecs for MKV container
DescriptionIf the user attempts to encode/auto-convert video to MKV, the only codec options are H264/MP4. Considering that VP8/VP9 within an MKV container are supported on Android (see https://developer.android.com/guide/topics/media/media-formats ), users should allow the user to set those codecs for that container.

In addition, we may even want to set VP9 as the default codec since it's included with MM5 and supported on Android.
TagsNo tags attached.
Fixed in build

Relationships

related to 0015327 closedrusty MediaMonkey 5 AV1 Video codec support (decoder only) 
related to 0007353 closedmichal MediaMonkey 5 WebM Support 

Activities

michal

2019-01-15 16:25

developer   ~0052086

Haali MKV muxer we use does not support Vorbis/Opus audio, so we cannot mux to file format supported by Android.
But it should be already covered by WEBM conversion, is MKV really needed? WEBM(VP8/9,Vorbis) should already work and should be usable on Android too.

rusty

2019-11-08 07:37

administrator   ~0055263

Last edited: 2019-11-08 07:38

View 2 revisions

We'll consider this resolved since vp8/vp9 are implemented with webm, and although mkv is supported on Android, I haven't seen any such files yet using vp8/vp9.