View Issue Details

IDProjectCategoryView StatusLast Update
0015293MediaMonkey 5Main Panel: Toolbars & Menuspublic2020-10-25 13:10
Reporterpeke Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0 
Summary0015293: Mouse (lasso) Selection fails in several cases
DescriptionIn most views/nodes Mouse lasso selection do not work or it needs to be clicked/started in specific places which works occasionally:
- Location
- Album
- Artist
- Outside the list of tracks (below track listing White space)
- Browser to select icons

Expected to work very similar if not same like in MMW where click and drag on non text starts mouse selection mode.

This behavior is more consistent with Touch Mode rather than Desktop app

Video Is uploaded to FTP
Steps To ReproduceEasiest way to replicate is to use List views
Additional InformationAnother feedback:

- When dragging a rectangle from list view up to column filter, if I release my mouse in the column filter, then mouse down back to the list view, the drag-to-select mode is still active. I have to click again, which deselects the group of songs that was selected.
- When dragging up quickly, the top few tracks are missed (because the mouse moves off the list view before , so the selection is left incomplete
- If you are scrolled toward the bottom, then select a song, then scroll up, then begin drag-to-select, the scroll bar snaps back to the bottom and selects a bunch of songs; and the selection is all wacky and useless. https://puu.sh/G3DU3/8d4e5904a0.mp4 (You can't see when I have the mouse down or up in the video. You'd have to try it yourself to see what I mean.)
- Drag-to-select doesn't work when the initial click is below the lastmost song (when it's a small list that doesn't take up the whole screen) https://puu.sh/G3DXg/13e9f2394d.mp4 (I was clicking and dragging below, the list, but again, it's hard to convey it via video)
- When selecting several songs, the list of selected songs often flash for a few frames, which is very distracting and makes the experience feel less robust
- When dragging close to the top/bottom edges of the list view, to scroll up/down: Sometimes it doesn't work, sometimes it stops and starts randomly, and often it feels too fast. (I see that you accelerate it faster the closer you get to the edge, which is very good; Maybe the *initial* speed could be a bit lower to make it feel smoother.

https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97161
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97249
TagsNo tags attached.
Fixed in build2267

Relationships

related to 0017029 newpetr Grid view: Mouse (lasso) selection missing due the UI design 
has duplicate 0015759 closedpetr Mouse can't be used for multiple file selection of track lists 
has duplicate 0013685 closedpetr Lasso selection missing 

Activities

rusty

2020-02-07 19:40

administrator   ~0056576

Last edited: 2020-02-24 19:44

View 4 revisions

To summarize (tested 2226), using the mouse to lasso multiple tracks works for regular tracklists, but not for:

2) In a regular tracklist when starting selection below the tracks
3/4) In a view that view that has a simple tracklist
5) Grid views (e.g. to select multiple videos/TV Series)
6) In List (by album) views e.g. Music > Albums [List (by album)]

Raising to 'Urgent' -- ideally this should be fixed for 5.0.

petr

2020-07-03 11:36

developer   ~0058752

lasso in grids: with grids it's a problem of missing or very tiny space between items so user have no space where to start selection (can conflict with D&D)

petr

2020-09-17 12:55

developer   ~0059595

Last edited: 2020-09-24 14:40

View 3 revisions

items 2,3, 4 and 6 fixed

lowering priority and target to 5.0.1 as currently lasso is a bit problematic in grid views (no empty space between items where to start dragging etc.) and tracklist/simple tracklist are supported

rusty

2020-10-14 05:18

administrator   ~0059854

Tagging as resolved (in 2267) in order to trigger testing since almost all issues have been fixed. If it turns out that all items are in fact fixed, then whoever verifies the bug should open a new bug covering Lasso selection for Grid views so we don't lose track of that.

peke

2020-10-25 13:10

developer   ~0059974

Verified 2271

I have not found any regressions and mouse (lasso) selection works. Grid future enhancement are added to 0017029