View Issue Details

IDProjectCategoryView StatusLast Update
0015042MediaMonkey 5Main Panelpublic2018-10-12 15:43
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015042: Art & Details: Clicking artwork should bring artwork in separate window
DescriptionClicking artwork should bring artwork in separate window (like in MM4).

Currently it works only in 'Artwork only' layout and not in the other layouts.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=30&t=90845
TagsNo tags attached.
Fixed in build2127

Activities

Ludek

2018-08-21 15:35

developer   ~0050951

Fixed in 2121

peke

2018-09-14 02:47

developer   ~0051107

Verified 2121

Ludek

2018-09-24 17:28

developer   ~0051205

Re-opened:
This doesn't always work in 'Side by side' layout, actually it works only on first track after restart.

Ludek

2018-09-24 17:35

developer   ~0051206

Fixed in 2125

Ludek

2018-09-24 18:11

developer   ~0051207

Last edited: 2018-09-24 18:48

View 3 revisions

I also added artwork showing on double-clicking the properties layer and also on clicking the properties layer when non in the 'Edit mode'
This covers the cases when artwork is fully overlayed by lyrics:
http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=91222

Fixed in 2125

peke

2018-10-04 23:30

developer   ~0051263

Verified 2125

peke

2018-10-06 01:40

developer   ~0051279

Reopen due the https://www.mediamonkey.com/forum/viewtopic.php?p=450275#p450275

Ludek

2018-10-08 17:48

developer   ~0051283

Last edited: 2018-10-08 17:51

View 3 revisions

Finally found the steps to replicate.

You need to start playback of a track to replicate and then click to the artwork area in the 'Advanced' or 'Basic' layouts (not to the properties area).
The issue is caused by prepareWindowModeSwitching(); that is called from artWindow.onPlaybackState
There is element called 'videoContent' that is transparent, but catches the 'click' event that isn't propagated to the propsBase element then.
Assigned to Michal for a fix (as he added the code there recently - probably because of video playback)

michal

2018-10-09 07:19

developer   ~0051285

Fixed in build 2127.

peke

2018-10-12 15:43

developer   ~0051317

Verified 2127