View Issue Details

IDProjectCategoryView StatusLast Update
0014089MediaMonkey 5Track Browserpublic2021-01-18 22:19
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014089: Breadcrumbs truncated suboptimally for small screens
DescriptionIf the screen size is not wide enough to display all of the breadcrumbs, MM takes the approach of removing the Collection, and presumably items to the right of it. e.g.

Home > Music > Genres > Classic Rock
becomes
Home > Genres > Classic Rock

MM shouldn't truncate the Collection first, since it:
a) Is regularly used by users to switch back
b) Is more informational than 'Genres'
TagsNo tags attached.
Fixed in build2296

Relationships

related to 0014575 closedpetr Difficult to navigate 'up' a directory level (or node) when paths are truncated 
related to 0016163 feedbackLudek Shrinked breadcrumb should have a tooltip expanding the full path 
related to 0017053 closedmichal Breadcrumb 'tooltip' disappears too easily 
related to 0017404 newLudek Breadcrumbs: navigation improvements for when the breadcrumb is truncated 

Activities

jiri

2017-03-09 08:21

administrator   ~0047449

How do you think the order of removal should be? In the example, should it be

3 2 1 4

(where 1 means removed first)? I suppose that 'Classic Rock' should stay as long as possible and also 'Home' should be there for long.

rusty

2017-03-14 14:02

administrator   ~0047485

Yes--exactly as you wrote.

Ludek

2017-03-14 14:36

developer   ~0047487

Related to http://forum.mediamonkey.com/viewtopic.php?f=30&t=87340
where user is confused why some items are missing, I guess there should be something like:
Home > ... > Genres > Classic Rock
to eliminate the confusion why some items are missing.
Or maybe use a fadeout shadow ?

petr

2017-03-23 15:50

developer   ~0047605

Fixed

peke

2017-03-28 23:29

developer   ~0047654

Verified 2064

rusty

2018-09-18 19:34

administrator   ~0051150

I didn't test breadcrumbs in all views, but noticed that in the Music > Locations view that '...' appears often at the beginning of a directory name even when the directory isn't being truncated. e.g.

Music > Location > D: > My Documents > Temp > ... dl >
In this case no directories are hidden or truncated, yet '...' still appears. Note, however, that it doesn't always appear; it appears when navigating deeper into the directory structure, but not when navigating back up.

Music > Location > ... dl > ... Queens of the stone age >
In this case, several directories are truncated (between /Location and /dl), so it should be listed as Music > Location > ... > dl (i.e. note the additional '>')
and Queens of the stone age isn't truncated, so it shouldn't be prefaced with ...
 i.e. it should appear as Music > Location > ... > dl > Queens of the stone age >

petr

2018-09-19 19:51

developer   ~0051165

Fixed

peke

2018-09-21 23:50

developer   ~0051181

Verified 2124

rusty

2020-01-16 06:58

administrator   ~0055892

I noticed in 2220 that this issue isn't totally fixed. If the user enables 'Display folder content recursively' then the breadcrumb directories don't display according to the new scheme.

petr

2020-01-16 09:46

developer   ~0055903

I'm not sure i understand ... when 'Display folder content recursively' is enabled, last path part is always visible in breadcrumbs.

rusty

2020-01-16 16:04

administrator   ~0055910

Hopefully this clarifies:
https://www.screencast.com/t/OH7zzrWdxUZ7

petr

2020-01-16 17:06

developer   ~0055912

FIxed

rusty

2020-01-17 16:14

administrator   ~0055960

Verified 2221.

rusty

2021-01-07 17:02

administrator   ~0061192

There's a regression in this functionality that makes it quite difficult to navigate 'Up' a level, as MM no longer displays the last two nodes in the breadcrumbs--whether recursive view is enabled or not). This is most annoying in Folder/Locations nodes. This was fixed previously at 0014575 and 0014089:0055912 (for recursive mode). See the regression in the current build (tested 2291) here:
https://www.screencast.com/t/LltZ9E4m

MM should display the last 2 entries as in earlier builds. Additionally, it would make sense that clicking the '...' in the breadcrumb can navigate to one level up.

petr

2021-01-07 18:57

developer   ~0061195

Fixed

lowlander

2021-01-08 19:45

developer   ~0061246

On 2293:
1) ... is placed to high, not in line with other text
2) Clicking ... opens a menu with the sub-nodes for the parent node (not sure if this is intended based on Rusty's feedback)
3) The Toast showing full Path could be used as clickable navigation (not urgent, for 5.0.1)
image.png (4,451 bytes)   
image.png (4,451 bytes)   

rusty

2021-01-16 23:34

administrator   ~0061395

Triaging back to 5.0 since the breadcrumb content is incorrect--it shows the break in the path at the wrong location. See the attached image.

Ludek

2021-01-17 17:57

developer   ~0061403

Fixed in 2296

rusty

2021-01-18 22:19

administrator   ~0061427

Verified the problematic formating + issue 1 in 2296. Remaining issues 2/3 moved to 0017404