View Issue Details

IDProjectCategoryView StatusLast Update
0013962MediaMonkey 5Extensionspublic2019-12-13 16:32
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Fixed in Version5.0 
Summary0013962: Addon to show album/artist/genre subnodes in the media tree
DescriptionThere is a request for script adding all genres as Home > Music > Genre > subnodes (like in MM4)

Additional Informationhttp://forum.mediamonkey.com/viewtopic.php?f=30&t=87018
http://forum.mediamonkey.com/viewtopic.php?f=30&t=86861
TagsNo tags attached.
Fixed in build2181

Relationships

related to 0014042 feedbackjiri Facilitate installation of popular extensions for certain functionality that isn't included by default 
related to 0015724 closedLudek Addon for per node sort columns persistence like in MM4 (not per collection like in MM5) 
related to 0015783 closedLudek Find More from Same doesn't expand Tree with Show All Node Extension 
related to 0015056 closedLudek Media tree: Genres node shouldn't have subnodes when showAllNodes script is not installed 

Activities

Ludek

2017-01-30 17:52

developer   ~0047114

'showAllNodes' sample MMIP added in build 2060

peke

2017-01-31 22:54

developer   ~0047154

Verified 2060

Ludek

2017-03-06 10:49

developer   ~0047401

Some users are requesting to have this script pre-installed:
http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=87229#p433288

Probably there isn't a downside of having it pre-installed?

Ludek

2017-03-06 10:56

developer   ~0047402

Made it pre-installed in 2062.

jiri

2017-03-06 12:38

administrator   ~0047408

We probably can make it pre-installed in the alphas, but I'd rather remove it then, since I don't see any big value of this script except for long time MM4 users who are used to it.

Ludek

2017-10-11 10:46

developer   ~0048931

Last edited: 2017-10-11 10:46

View 2 revisions

Re-opened to move this script to SampleScripts per Jiri's suggestion.

Ludek

2017-10-11 10:51

developer   ~0048932

Last edited: 2017-10-11 10:52

View 2 revisions

Moved to samples in 2081.

peke

2017-10-20 00:18

developer   ~0049005

Verified 2081

Ludek

2019-02-25 12:15

developer   ~0052792

Re-opened to evaluate whether this script should be pre-installed per feedback at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93931#p456097

jiri

2019-02-25 13:18

administrator   ~0052793

I still believe that it doesn't need to be pre-installed, but assigning to Rusty for his feedback.

peke

2019-02-25 14:44

developer   ~0052798

I also agree that it should not be pre-installed.

rusty

2019-03-15 20:50

administrator   ~0052979

I agree that this doesn't need to be installed by default, however, it's very important that users who do want this be able to install the functionality easily as per 0014042.

rusty

2019-03-20 13:19

administrator   ~0053032

Closing. Remaining issues are covered at 0014042.

Ludek

2019-06-06 19:45

developer   ~0053755

Last edited: 2019-06-06 20:47

View 2 revisions

Re-opened: Genre node have no further artists/albums subnodes (like in MM4), which is an issue as described here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94552

=> added in 2181

peke

2019-06-07 21:34

developer   ~0053780

Verified 2181

I have not even realized how that Genre -> Artist subnodes are useful sometimes till I tested this.