View Issue Details

IDProjectCategoryView StatusLast Update
0013277MediaMonkey 5UPnP / Castingpublic2020-04-08 21:02
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version5.0Fixed in Version5.0 
Summary0013277: Add auto-conversion profile for Chromecast (adjust for ALAC)
DescriptionSupported audio/video formats on Chromecast are quite limited, e.g. WMA isn't supported and from the video only the MP4 video seems to be supported (in addition not all MP4s)

We should add pre-configured auto-convert profile, a problem is that we currently cannot do on-the-fly video conversion for MP4, but only for WMV (that is unsupported by Chromecast).
Additional Informationhttps://developers.google.com/cast/docs/media#image-formats
http://www.free-codecs.com/download/webm_directshow_filters.htm
TagsNo tags attached.
Fixed in build2240

Relationships

related to 0014530 closedmartin MediaMonkey 5 Chromecast support in MM5 and MMA, including Video 
related to 0013249 closedLudek MediaMonkey (current) Auto Convert: Apple devices lossless conversion profile 
related to 0016349 closedLudek MediaMonkey 5 Wording changes re media sharing (because of Google Cast support) 

Activities

jiri

2017-09-13 08:01

administrator   ~0048734

Assigning to Michal to review WebM/VP8-9 implementation for this purpose.

michal

2017-11-29 19:38

developer   ~0049310

Conversion to WebM/VP8-9 prepared, Ludek will test using it for Chromecast.

Ludek

2017-11-30 14:09

developer   ~0049317

Last edited: 2017-11-30 14:10

View 3 revisions

Default profile for Chromecast added in 2086 and tested on various videos.

Seems to work well except:
1) DefaultProfileWEBM value needs to be adjusted, currently it has Audio Quality -1 (45 kbps) which fails to encode on my machine, as discussed offline the default Audio Quality should be 3 (112 kbps)

2) Conversion to WebM has distorted sound for some video files (with 8-bit audio sound), sample file sent over Skype

michal

2017-11-30 18:16

developer   ~0049319

Default values fixed.
I cannot reproduce distorted sound with current sources, please retest.

Ludek

2017-12-04 15:02

developer   ~0049330

Last edited: 2017-12-04 15:28

View 3 revisions

1) Verified

2) I am still seeing the issue, screenshot + debug log + original AVI + resulted WebM are all uploaded to /forMichal/fromLudek/WebM issue/

michal

2017-12-05 12:34

developer   ~0049333

A have analyzed it more, the problem is in our version of LAV splitter, it has some bug, it splits this kind of file (with PCM 8KHz mono audio) wrongly. We need to use newer version od LAV splitter, our is obsolete.

michal

2017-12-06 15:27

developer   ~0049336

Fixed by upgrading LAV splitter we use to the latest version.

peke

2017-12-08 03:00

developer   ~0049355

Verified 2086

Ludek

2018-02-18 22:23

developer   ~0049636

Last edited: 2018-02-18 22:39

View 4 revisions

Re-opened: the default profile needs to be adjusted, it coverts 5.1 audio sound (MKV) to 2 channels (webm) and in addition wrong channels are selected making the sound unusable. Solution is to change the rule for channels from '2 channels' into 'original'


Fixed in 2090

peke

2018-03-06 23:02

developer   ~0049678

Verified 2090

Ludek

2020-04-06 20:00

developer   ~0057500

Last edited: 2020-04-06 21:13

View 5 revisions

Re-opened: ALAC is not supported on Chromecasts ( related to https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95807 )
The default rules should be adjusted accordingly.

I guess we could add a new rule ALAC > FLAC, similarly like we added FLAC > ALAC for iPods ( 0013249 ),
But the problem is that the alac file in question has M4A extension and currently we can set up only a rule for all M4A files (be it ALAC or not).

So the easier solution could be to set ALAC as unsupported format for the Chromecast auto-convert profile, but again -- this does not seem to be doable currently.

Per IM discussion, assigned to Michal to look into it (i.e. to have a way to differenciate ALAC from HE-AAC/LC-AAC in the M4A container when configuring supported formats)

peke

2020-04-06 21:24

developer   ~0057503

As talked on IM the short term solution would be to setup M4A profile for >384/512Kbps Compression bitrate to always convert to FLAC as from my tests 100% M4A Quality is <320kbps.

Ludek

2020-04-07 09:09

developer   ~0057505

Last edited: 2020-04-07 09:43

View 4 revisions

I think that ALAC > FLAC wouldn't work well when casting, because currently we cannot covert to FLAC on-the-fly.
So I guess that ALAC > MP3 would work better, but the issue is that currently there is no possibility to set a rule only for certain M4A types, this needs to be added.

So the only workaround now is to set up convert-rule for _all_ M4A files -- be it HE-AAC/LC-AAC (supported by Chromecast) or ALAC (unsupported by Chromecast).

As for the Peke's workround to try to set M4A rule only for M4A with certain bitrate (> 512Kbps) sounds interesting -- sounds like usable workaround for 5.0

Ludek

2020-04-07 11:45

developer   ~0057510

Last edited: 2020-04-07 12:07

View 3 revisions

Per IM discussion with Michal/Peke - added this new rule to the default Chromecast profile:
[M4A, Above 528 kbps -> MP3] which resolves the ALAC issue

=> Fixed in 2240

peke

2020-04-08 21:02

developer   ~0057564

Verified 2240

Tested using clean install to Google Nexus build in chromecast.