View Issue Details

IDProjectCategoryView StatusLast Update
0011068MediaMonkey (current)Synchronizationpublic2020-12-30 18:26
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.2.5 
Target Version4.1Fixed in Version4.1 
Summary0011068: Speed up playlist USB syncing for general MTP devices
DescriptionPlaylist syncing for MTP connected devices is mostly slow. And because MediaMonkey re-creates all playlists on every auto-sync then playlist syncing can be super slow for some users/devices and takes up most of the syncing time.

The solution would be to re-upload only those playlists/auto-playlists that were modified from the last sync.

The problem is that user can delete a track directly in device and such a track gets deleted from a device playlist too.

Therefore MM should reupload a playlist once one of these conditions is true:
1) 'Last Modified' timestamp of the playlist is newer than timestamp of the last auto-sync
2) Number of tracks of the device playlist differs from the number of tracks within library playlist
Additional InformationDWQ-846663
http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=71608#p369554
VZG-155268
TagsNo tags attached.
Fixed in build1671

Relationships

related to 0011009 closedmarek MediaMonkey for Android Auto-sync: playlists fail to update with added tracks (regression) 
related to 0012033 closedLudek MediaMonkey (current) iPod/iPhone sync: optimize sync time of playlists 
related to 0017057 closedLudek MediaMonkey 5 Sony A55 sync: When full sync is done no playlists are created on device 

Activities

Ludek

2013-07-17 14:59

developer   ~0036889

Last edited: 2013-07-17 15:01

View 2 revisions

Finally I used slightly different approach, at first I found whether the playlist with the same path already exists on the device, then whether amount of its tracks is same and then I compare actual tracks paths in order. This method is fast enough and safe.

Test note: This must be tested with MTP playlists like 'PLA', this check is not performed for simple M3U, because M3U re-creation is fast enough. There is a room for further optimization in case of need.

peke

2013-07-22 00:38

developer   ~0036947

Verified 1650 and Sony W880i in MTP mode

peke

2013-07-24 00:03

developer   ~0036961

Speed increase on MTP devices that utilize PLA are aproximately 35% which should be faster on newer devices.

Ludek

2013-10-04 08:47

developer   ~0037750

Last edited: 2013-10-04 08:50

View 3 revisions

Re-opened, it seems that we should done this also for M3U playlists. Based on some tests M3U transferring can be slow for some Android devices connected over MTP: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=73862#p375205

Ludek

2013-10-04 09:52

developer   ~0037752

Last edited: 2013-10-05 02:58

View 3 revisions

Fixed in build 1662.

i.e. if the same M3U with the same content already exists on the device, then the file is not re-copied needlessly.

peke

2013-10-05 02:59

developer   ~0037777

Verified 1662 and Sony W880i in MSC mode which support M3Us (Relative only)

peke

2013-10-15 23:57

developer   ~0037911

Verified 1664 on generic Player in MSC mode

Ludek

2013-11-14 11:26

developer   ~0038281

Re-opened, based on this forum thread: http://www.mediamonkey.com/forum/viewtopic.php?p=376518#p376518
and mainly findings in ticket VZG-155268 it still wasn't fully fixed.

Ludek

2013-11-14 11:36

developer   ~0038282

Fixed in build 1671.

peke

2013-12-22 21:16

developer   ~0038982

Verified 1682