View Issue Details

IDProjectCategoryView StatusLast Update
0011034MediaMonkey (current)Burning / Disc Handlingpublic2019-07-22 15:47
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version4.1 
Summary0011034: UPnP playback fills the NP list incorrectly
DescriptionUpon start of playback of autoplaylists with random sort order in MMA, NP list contains tracks in incorrect order and some even duplicated.
TagsNo tags attached.
Fixed in build1645

Relationships

related to 0010021 closedLudek MediaMonkey for Android UPnP playback fills the NP list incorrectly 
related to 0015837 closedLudek MediaMonkey (current) Wi-Fi sync may not work correctly when another UPnP/DLNA client on the network is accessing MMW server at the same time 

Activities

rusty

2013-07-03 20:30

administrator   ~0036720

2013-06-20 11:18

    Tested build 143, and noticed that when playing auto-playlists with sort order=random from MMW, the clicked track plays, but:
- The tracks in the NP list aren't in the order that was displayed when the user browsed the auto-playlist
- The first track played often (but not always) appears as the last track in the NP list)

My guess is that this is happening because the AutoPlaylist is loaded once when it is browsed, and then a second time when it is played. This shouldn't happen; i.e. the initially loaded version of the auto-playlist should be used.

I expect that the first track appears last in the NP list when the second version of the auto-playlist that's loaded doesn't contain the track at all.

rusty

2013-07-03 20:32

administrator   ~0036721

Fixed by Ludek via server side caching of such playlists.

rusty

2013-07-03 20:33

administrator   ~0036723

Verified in build 1645.