View Issue Details

IDProjectCategoryView StatusLast Update
0010021MediaMonkey for AndroidUPnP / Castingpublic2019-07-22 15:46
Reporterjiri 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.0.1Fixed in Version1.0.1 
Summary0010021: UPnP playback fills the NP list incorrectly
DescriptionUpon start of playback of any album, NP list contains tracks in incorrect order and some even duplicated.
TagsNo tags attached.
Fixed in build63

Relationships

related to 0010998 closedmartin MediaMonkey for Android Current track occurs in bad position or twice in Now playing list. 
related to 0011034 closedLudek MediaMonkey (current) UPnP playback fills the NP list incorrectly 
related to 0011958 closedlowlander MediaMonkey (current) MMW client fails to play files in Now Playing from MMW server after client PC restart 
related to 0015837 closedLudek MediaMonkey (current) Wi-Fi sync may not work correctly when another UPnP/DLNA client on the network is accessing MMW server at the same time 

Activities

martin

2012-11-20 19:33

developer   ~0033240

Fixed in build 63.

peke

2012-11-22 13:35

developer   ~0033288

Verified 63

rusty

2013-06-20 15:18

administrator   ~0036576

Tested build 143, and noticed that when playing auto-playlists with sort order=random from MMW, the clicked track plays, but:
- The tracks in the NP list aren't in the order that was displayed when the user browsed the auto-playlist
- The first track played often (but not always) appears as the last track in the NP list)

My guess is that this is happening because the AutoPlaylist is loaded once when it is browsed, and then a second time when it is played. This shouldn't happen; i.e. the initially loaded version of the auto-playlist should be used.

I expect that the first track appears last in the NP list when the second version of the auto-playlist that's loaded doesn't contain the track at all.

peke

2013-06-26 23:18

developer   ~0036667

Reminder sent to: Ludek, rusty

Isn't this controlled by MMW and that Each time MMA asks for list content MMW refresh it?

I think it was made by design.

lowlander

2013-06-27 15:37

developer   ~0036669

I think many users would expect the displayed tracks for random Playlist to be the ones loaded into Now Playing and not another random subset.

jiri

2013-06-28 06:35

administrator   ~0036671

Seems to be for Martin...

martin

2013-07-01 09:50

developer   ~0036693

Per IM discussion with Marek, I'll assign this to him.

Ludek

2013-07-01 21:57

developer   ~0036704

Last edited: 2013-07-01 21:59

View 4 revisions

Fixed in MMW build 1645 (by caching the content on the server side)

rusty

2013-07-03 20:32

administrator   ~0036722

Moved the MMW issue to 0011034.