View Issue Details

IDProjectCategoryView StatusLast Update
0009775MediaMonkey 4DLNA/UPnPpublic2012-10-11 14:38
Reporterlowlander Assigned To 
PrioritynoneSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.0.7 
Summary0009775: Multi-Value fields not send correctly to DLNA/UPnP clients
DescriptionIt seems MediaMonkey doesn't send a multiple-value field (like Artist) correctly as clients only display the last value. Other servers are reported to not have this problem.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=20&t=68020
TagsNo tags attached.
Fixed in build

Relationships

related to 0008742 assignedrusty MediaMonkey Wishlist Customize Tag display over DLNA/UPnP 

Activities

Ludek

2012-10-11 09:47

developer   ~0032422

Last edited: 2012-10-11 09:48

View 3 revisions

MediaMonkey does it according to standard, upnp:artist is multi-value property, it means that it can appear more than once in the DIDL-Lite XML, see details here: http://upnp.org/specs/av/UPnP-av-ContentDirectory-v3-Service.pdf (pages 42, 177)

It means that MM presents Artist1;Artist2;Artist3 as

<upnp:artist role="Performer">Artist1</upnp:artist>
<upnp:artist role="Performer">Artist2</upnp:artist>
<upnp:artist role="Performer">Artist3</upnp:artist>

which is correct and the issue is with the BubbleUPnP client that cannot reads mutli-values and reads only the last artist (Artist3).

lowlander

2012-10-11 14:38

developer   ~0032434

Note that Sony and Samsung TV's also only display last value.