View Issue Details

IDProjectCategoryView StatusLast Update
0009311MediaMonkey (current)Framework: Taggingpublic2019-01-30 14:09
Reportermichal 
PrioritynoneSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0.3 
Target Version4.1Fixed in Version4.1 
Summary0009311: MM sometimes cannot read ID3 tags for some specific files, whereas Winamp or WMP can.
DescriptionUser has sent file for which MM4 cannot read any tag, but Winamp and WMP show tags normally. Mp3tag reports the file as !BAD ID3v2.
It is probably not correct ID3 tag, but in case it is simple, we could try to read it anyway.
Additional InformationTicket ID: FDT-646810 -- http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=17244

http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=65663



TagsNo tags attached.
Fixed in build1601

Relationships

related to 0011757 resolvedpeke MediaMonkey (current) Podcasts tagged by MM not shown in Subsonic 
related to 0012433 closedmichal MediaMonkey (current) ID3: In case that one of tags are too long MMW gets unresponsive 
related to 0015404 closedmichal MediaMonkey (current) MediaMonkey reads Title incorrectly 
related to 0015406 closedmichal MediaMonkey 5 Some specific MP3 file corruption in ID3 tags can lead to crash during reading tags 

Activities

michal

2012-05-02 08:38

developer   ~0030988

Fixed in build 1601. The problem was in files - ID3 tag was saved (by iTunes or some other software) in ID3 version 2.3, but frame names was taken from version 2.2 (i.e. TT2 instead of TIT2, etc.). I adjusted ID3 parser, so it reads these wrong tags too.

peke

2012-12-20 00:02

developer   ~0034040

Last edited: 2012-12-20 00:05

View 2 revisions

Verified 1615

EDIT: It is fairly simple to test just Change Tag type of MP3 file that have id3v2.2 in HEX editor to show 03 (4'th byte of MP3 file) and MM 4.0.7 do not read it but 1615 do.