View Issue Details

IDProjectCategoryView StatusLast Update
0009036MediaMonkey 5DLNA/UPnPpublic2019-02-08 02:30
ReporterLudek Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Fixed in Version5.0 
Summary0009036: Ability to control more remote players at once (from a single instance of MediaMonkey)
DescriptionIn version 4.1 we have introduced 0007090: Ability to control remote players via UPnP/DLNA. However, there are two additional feature requests:

1. WMP's "Play to..." allows to manage more players at once, see the third screenshot here: http://gizmodo.com/5146859/windows-7-windows-media-player-12-play-to-and-media-compatibility [^] where every remote player has its own Window with NP and virtual player. Something similar might be nice although I believe that simple "switch" would be enough (where multiple 'Now Playing' lists would be just stored in the memory).
Current workaround is to run multiple instances of MM at once, each for another remote player.

2. As Peke suggested in 0007090 it could be also handful to have "multi zone" playback feature where user could select any or all DLNA renderers and/or MediaMonkey Player to stream music to multiple locations at the same time.
The problem here is in synchronizing the renderers. Most probably they would be always desynchronized say half a second when streaming the same content (because of buffering, network traffic etc.)
TagsNo tags attached.
Fixed in build2073

Relationships

related to 0010087 assignedpetr MediaMonkey (current) Rollback config changes if UAC is cancelled 
child of 0007090 closedLudek MediaMonkey (current) Ability to control remote players via UPnP/DLNA 

Activities

Ludek

2016-04-27 11:54

developer   ~0044513

Last edited: 2016-04-27 11:57

View 4 revisions

Users are requesting item 2: http://forum.mediamonkey.com/viewtopic.php?f=20&t=84080

"multi zone" playback would be nice addition for MM5, e.g. people making garden party would appreciate it even if the output would be desyncronized slightly

Ludek

2016-07-26 11:15

developer   ~0045215

Note that item 2 will also replace Google Cast Groups : see 0013212:0045011

Ludek

2016-09-16 09:59

developer   ~0045672

Last edited: 2016-09-16 10:05

View 3 revisions

Re item 2:
Code for this has been already added (partially implemented) in build 5.0.0.2033

As for the UI:

Jiri prefers to leave current selection for "Play to" targets as radio buttons, but add a new target '<multiple>' > [targets list with checkboxes]

Alternativelly we could add just checkboxes to the targets list, but true is that this feature won't be probably used often so the Jiri's suggestion makes more sense.

Ludek

2016-09-19 10:01

developer   ~0045688

Last edited: 2016-09-19 10:44

View 2 revisions

New target 'Multi zone' > is added in 2033, it is shown only when more than one player is available.

Screenshots of both UI variants are attached (Multi zone.jpg, Checkboxes.jpg)

Assigned to Rusty to review which variant is preferred.
TODO: If we go with the "Multi zone" target variant then we need to somehow resolve it also in Options > Player > Streaming > 'Play to' dropdown

Ludek

2016-09-19 10:41

developer  

Multi zone.jpg (67,957 bytes)   
Multi zone.jpg (67,957 bytes)   

Ludek

2016-09-19 10:42

developer  

Checkboxes.jpg (53,620 bytes)   
Checkboxes.jpg (53,620 bytes)   

Ludek

2016-11-07 21:13

developer   ~0046113

Last edited: 2016-11-08 13:05

View 6 revisions

Some issues re multizone playback were reported by Rusty in #13212 (items i,j,k)

Items i&j seems regressions caused by recent code refactor.
=> Fixed in 2040

The process of synchronizing the audio works as follow:
- it keeps volume muted on all the devices until playback is started.
- once playback is started on all devices -- it sends seek request to position 0:00 and sets the volume.

jiri

2016-11-29 11:47

administrator   ~0046300

k) (from #13212) Based on testing, I'd prefer to change the current 'multizone' implementation from

[x] Multizone >

to

[x] Multizone [Setup icon/button]

where the icon would pop-up a dialog where user could check/uncheck playback targets (and possibly other options in the future).

l) Shouldn't the 'Internal player' be among the devices that can be chosen in the Multizone playback?

jiri

2017-03-29 09:43

administrator   ~0047667

Based on how we treated similar issues, I'm no longer sure about k). Assigning l) to Ludek.

Ludek

2017-03-29 10:36

developer   ~0047669

m) user reports that next track doesn't play to all Chomecast devices at once: http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=87413&p=434378#p434378

Ludek

2017-07-24 12:47

developer   ~0048396

Last edited: 2017-07-24 18:22

View 2 revisions

Items k,l,m) are fixed in 2073

peke

2019-02-08 02:30

developer   ~0052484

Verified 2155