View Issue Details

IDProjectCategoryView StatusLast Update
0008444MediaMonkey (current)Now Playingpublic2012-05-23 21:27
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0.5Fixed in Version4.0.5 
Summary0008444: Deleting currently playing track --> Now Playing list halts playback completely
DescriptionA regression introduced by the fix to 0008357 is that deleting tracks that are currently playing causes the Now Playing list to stop playing entirely (rather than just the currently playing track). This is a problem for certain cases (e.g. DJ or MM in use at a Party).

The solution discussed would be that on deletion, MM would remove the currently playing track and all other selected tracks from the playlist (exactly as if the user had removed tracks from a playlist), and then then delete the currently playing track from the Library and PC.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=61376
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=60970&p=313865
http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=62043&p=321663#p321663
http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=63539
TagsNo tags attached.
Fixed in build1492

Relationships

related to 0008357 closedLudek Deleting multiple tracks from now playing triggers endless warnings 

Activities

jiri

2011-09-29 14:37

administrator   ~0027993

Note that I don't think it really is a problem, since the result of this operation is interrupted audio in any case, i.e. it isn't acceptable for DJs or at a Party anyway. Let's wait for user's feedback, but my guess is that we can just dismiss this issue.

rusty

2012-01-31 20:44

administrator   ~0030170

Last edited: 2012-04-30 13:52

View 3 revisions

Many users have complained about this issue. Triaged to 'urgent' for 4.0.4, though it may have to be pushed if too risky.

jiri

2012-05-18 10:27

administrator   ~0031165

Fixed in build 1492.

peke

2012-05-23 21:27

developer   ~0031194

Verified 1492