View Issue Details

IDProjectCategoryView StatusLast Update
0008357MediaMonkey (current)Properties/Auto-Toolspublic2011-09-29 19:14
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0008357: Deleting multiple tracks from now playing triggers endless warnings
DescriptionIf the user deletes numerous tracks that are currently playing in the NP queue --> File XXX is now playing. Deleting it will interrupt playback. Are you sure you want to proceed? [Yes] [No]

Then the next file plays, and the error occurs again, and again, and again...

There should be [Yes] [Yes to all] [No] options. (or better yet, [Yes] should behave like [Yes to all]).
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59838
TagsNo tags attached.
Fixed in build1439

Relationships

related to 0008444 closedjiri Deleting currently playing track --> Now Playing list halts playback completely 

Activities

Ludek

2011-09-12 10:55

developer   ~0027597

Fixed in build 1431.

rusty

2011-09-13 17:48

administrator   ~0027679

The issue is partially fixed in 1431. All the selected tracks are deleted as expected, but the Now Playing list stops playing!

It should continue playing with the track that follows those selected for deletion.

Ludek

2011-09-13 18:44

developer   ~0027681

Why it should continue playing if the message says that "Deleting it will interrupt playback" ?

rusty

2011-09-13 20:06

administrator   ~0027684

It's referring to the fact that it'll interrupt playback of the currently playing track (and not of the entire Now Playing list).

Ludek

2011-09-13 21:06

developer   ~0027687

Last edited: 2011-09-13 21:14

View 3 revisions

Fixed in build 1432 (although I think it is odd if MM is continually trying to play a file that is going to be deleted over and over, for me the behaviour in 1431 is better).

peke

2011-09-27 01:41

developer   ~0027944

Verified 1436

I also Agree with Ludek that behavior was better in 1431

rusty

2011-09-28 13:14

administrator   ~0027983

Sorry, I think there was some confusion re. comment http://www.ventismedia.com/mantis/view.php?id=8357#c27679. It definitely shouldn't continue trying to play each track.

What I meant is that if there's a Now Playing list containing the following tracks:
A1
A2
A3
A4
B1
B2
B3
B4

...and the user selects tracks A1, A2, A3, A4 for deletion, then once the user accepts the warning prompt, tracks A1-A4 should be deleted (without MM trying to successively play each of those tracks), and playback should continue beginning with B1.

Also, in build 1437, there's occasionally a bug with this functionality:
i) sometimes an AV occurs
ii) sometimes there's a warning about MM being unable to delete the track because it's in use (fixing the successively playing each track issue will probably solve this)

Video below and debug log attached:
http://screencast.com/t/QYRHH2SPv

rusty

2011-09-28 13:15

administrator  

AV_on_deletion_of_multiple_tracks.zip (12,528 bytes)

jiri

2011-09-28 14:24

administrator   ~0027986

Assigning to Rusty for a new review, as I wrote over IM:

  16:03 Jirka: Well, maybe the biggest problem is the app logic, I have been trying to find out the best implementation, but so far unsuccesfully. For example, you try to delete tracks 1, ..., 1000 for a My Computer node. However, track 1 is currently playing and the next one in NP queue is track 1000. So, what currently happens is that playback of 1 is terminated and track 1000 starts. However, in few seconds, when the deletion gets to track 1000, its playback is terminated as well. It's probably a little non-standard example, but I guess that you get the idea.
  16:22 Jirka: Every solution I can think of has some side effects... Maybe you are right that users wouldn't expect playback to be stopped, but on the other hand the whole idea of deleting tracks that are currently playing means that user is doing something nonstandard (and possibly errorneous), so I'd say that it doesn't matter much which solution we choose. For that reason, I'd prefer to return to the original fix from build 1431. You can enter a lower priority bug for a future fix, but for the reasons explained I'm not sure it makes much sense to lose any more time on the issue.

rusty

2011-09-28 14:54

administrator   ~0027987

OK so we can revert to the implementation of 1431 for now.

I'll enter a new bug to track the fact that playback stops unexpectedly. The solution discussed would be that on deletion, MM would remove the currently playing track and all other selected tracks from the playlist (exactly as if the user had removed tracks from a playlist), and then then delete the currently playing track from the Library and PC (Jiri was reluctant to make the change now given possible complications e.g. track is locked, inaccessible, or scripts callback prevent its deletion).

Ludek

2011-09-28 17:57

developer   ~0027988

Fixed in build 1439.

stephen_platt

2011-09-29 19:14

developer   ~0027994

verified in build 1439