View Issue Details

IDProjectCategoryView StatusLast Update
0008089MediaMonkey (current)Properties/Auto-Toolspublic2011-09-10 23:18
Reporterstephen_platt 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0008089: Can't paste art into art & details or into properties panel (regression)
Description1. Copy an image from internet browser
2. place mouse pointer on art & details, selected tab and right click on mouse.
3. select paste.
4. Dialog "add artwork" appears, but it does mot look as it used to, since there are no art visible, and if you press the OK-button anyway there will not be any real picture added, only a default note-sign.

Same issue pasting art with now playing tab selected, or pasting to track Properties artwork tab
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59125
TagsNo tags attached.
Fixed in build1407

Relationships

related to 0008108 closedmichal Upgrade to the latest NativeJPG library 
parent of 0008133 closedrusty Artwork can't be added to a Video with a thumbnail 
child of 0008063 closedLudek Reading of a specific JPEG file causes AV 

Activities

petr

2011-07-08 23:01

developer   ~0026663

Unable to reproduce in 1403

rusty

2011-07-10 02:34

administrator   ~0026674

Last edited: 2011-07-10 02:40

View 2 revisions

I just tested this in 1404 and the error seems to occur consistently.

It occurs when _Pasting_ art either into the Art&Details dialog, or into the Properties > Artwork dialog.

Testing by attempting to paste the image from:
http://www.amazon.com/Ghostbusters-Original-Soundtrack-Various-Artists/dp/B000002VCY/ref=sr_1_4?s=music&ie=UTF8&qid=1310265023&sr=1-4

Posted a debug log as well: see line 1100.

stephen_platt

2011-07-10 02:38

developer   ~0026675

I was just going to post the same thing - the problem still occurs regularly here. I can upload a video if it would help.

rusty

2011-07-10 02:39

administrator  

bug8089.LOG (128,944 bytes)

Ludek

2011-07-10 16:06

developer   ~0026682

This is another regression caused by 0008063. Note that it is only reproducable if you copy the image as bitmap and not as URL.

Ludek

2011-07-11 18:53

developer   ~0026719

Fixed in build 1405.

peke

2011-07-12 21:27

developer   ~0026743

Verified 1405

rusty

2011-07-13 17:49

administrator   ~0026770

Last edited: 2011-07-13 19:29

View 4 revisions

This issue doesn't seem to be fully resolved in 1406. When pasting images to a Video via Art&Details window, the image fails to update correctly (it shows a 'no image' image in Properties > Artwork tab. It occurs whether or not 'Apply to all..' is enabled.

the bug only manifests itself if the image is pasted _into the A&D window_right after a scan_. If an operation is performed on the file's artwork, and the artwork is subsequently modified, then the bug doesn't occur, nor does it occur when pasting artwork into Properties > Artwork tab.

See the video below:
http://screencast.com/t/RjMOyKgyqxp

peke

2011-07-13 19:25

developer   ~0026771

Note that Drag & Drop works.

Ludek

2011-07-13 21:35

developer   ~0026778

Fixed in build 1407.

peke

2011-09-10 23:18

developer   ~0027571

Verified 1430