View Issue Details

IDProjectCategoryView StatusLast Update
0007643MediaMonkey (current)Install/Configpublic2011-05-15 02:57
Reportergege 
PriorityimmediateSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version4.0 
Target VersionFixed in Version4.0 
Summary0007643: UX: MM first run is not a pleasant experience
DescriptionCurrently, MM's first run is a terrible sequence of dialogs, pop-ups and message boxes throwing at user's face. For a new user, this leads to a poor first impression IMO. And, you know, first impressions count!

For each click, user may think "OK, just one more click and I'll get in". But then... another window/dialog/msgBox appears. Then again and again...
This feeling gets worse given the fact each message/window has a different size or shape. The whole process lacks uniformity.

What I suggest is to create a First Run Wizard, which would group all those dialogs in an unified interface.
This way, John Doe would know he's going through an initial setup process and would know exactly WHEN his app is ready to open.
Additional Informationhttp://en.wikipedia.org/wiki/User_experience
http://www.mediamonkey.com/forum/viewtopic.php?f=4&t=57013
TagsNo tags attached.
Fixed in build1373

Relationships

related to 0007246 closedpetr Various Options panels have graphic artifacts (off by 2 pixels) 
related to 0007842 closedLudek Registration form says 'invalid code' BEFORE inserting the license key in first run wizard 

Activities

jiri

2011-04-08 08:33

administrator   ~0024121

Good point, assigning to Rusty for further discussion re. how to proceed.

rusty

2011-04-08 16:24

administrator   ~0024128

I love Gege's proposal. In the interest of implementing this quickly and without adding a bunch of new strings, Jiri and I discussed the following deviations from the spec:
-We rely almost exclusively on existing strings [new strings indicated in square brackets]. I'm not sure whether this is possible (specifically for items 3) and 4) below, since the strings currently in use have not been split up.
-Modify the existing dialogs so that they can be used within the wizard or within the options dialog

1) Titlebar of Wizard: Welcome to MediaMonkey!


2) Steps in the left-hand pane:

[Steps]:
-------
1. [Welcome]
2. Registration
3. OS Integration
4. [Scan Media]


3) Welcome:

Welcome to MediaMonkey!\n
\n
Since this is the first time you've run MediaMonkey, your drives will be scanned for media files. Once scanning is complete, you'll be able to use MediaMonkey to organize and play your media.\n
\n
MediaMonkey is free, however, you can upgrade to MediaMonkey Gold to get additional features:\n
-Auto-conversion converts files as they are synced so that they can play on any device.\n
-Custom Collections allow sub-libraries to be created.\n
-Advanced Auto-Playlists quickly generate a mix to suit your mood.\n
-Improved performance on multi-core systems, and faster CD/DVD burning!\n
-AccurateRip for bit-perfect CD Rips.\n
-Plus Virtual CD, Sleep timer, etc.\n
\n
Thank you, and enjoy MediaMonkey!

-->

Welcome to MediaMonkey! (note: this string already exists as a standalone string)

[This wizard will help you get started by setting a few options and scanning your drive for media files.\n ]
\n
Thank you, and enjoy MediaMonkey!


4) Registration Dialog / Panel in the Wizard

Welcome to MediaMonkey!\n
\n
Since this is the first time you've run MediaMonkey, your drives will be scanned for media files. Once scanning is complete, you'll be able to use MediaMonkey to organize and play your media.\n
\n
MediaMonkey is free, however, you can upgrade to MediaMonkey Gold to get additional features:\n
-Auto-conversion converts files as they are synced so that they can play on any device.\n
-Custom Collections allow sub-libraries to be created.\n
-Advanced Auto-Playlists quickly generate a mix to suit your mood.\n
-Improved performance on multi-core systems, and faster CD/DVD burning!\n
-AccurateRip for bit-perfect CD Rips.\n
-Plus Virtual CD, Sleep timer, etc.\n
\n
Thank you, and enjoy MediaMonkey!

-->


MediaMonkey is free, however, you can upgrade to MediaMonkey Gold to get additional features:\n
-Auto-conversion converts files as they are synced so that they can play on any device.\n
-Custom Collections allow sub-libraries to be created.\n
-Advanced Auto-Playlists quickly generate a mix to suit your mood.\n
-Improved performance on multi-core systems, and faster CD/DVD burning!\n
-AccurateRip for bit-perfect CD Rips.\n
-Plus Virtual CD, Sleep timer, etc.\n

To unlock all features, please enter registration information below:

Username: ___________________________
License Key: ________________________

If you don't have a license key, you can get one by purchasing MediaMonkey Gold at:
http://register.mediamonkey.com


5) OS Integration Wizard / Options Panel
No changes required

6) Scan Media Wizard panel / Add/Rescan Folders dialog

Select folders to scan now
-->
[Select the folders you want to scan for media files.]


6a) Add/change the following tooltips / context help:

i - Scan continuously:
[Folders set to scan continuously will be monitored so that any changes within them will be immediately reflected in the MediaMonkey Library.]

ii - Scan at startup:
When enabled, any changes that occured in the Monitored Folder while MediaMonkey wasn't running will be detected at startup. This is useful in case changes are made using other applications or devices made while MediaMonkey isn't running.
-->
[Folders set to scan on startup will be checked for changes each time MediaMonkey is run, so that any changes made by other applications or device when MediaMonkey isn't running will be reflected in the MediaMonkey Library.]


7) Buttons:
Back/Next/Cancel is probably sufficient (Finish for last dialog).

gege

2011-04-08 17:01

reporter   ~0024129

I couldn't imagine this would make it for a 4.0 release, so I didn't mind adding new strings or modifying existing ones...

But I think rusty's spec is a good compromise: it achieves my original intent with minimum string modification.

peke

2011-04-08 22:06

developer   ~0024142

NOTE: Small point that is Interesting for users, but Unfortunately includes adding one string that needs to be translated.

While MM is Scanning files (Imagine scanning 50k of Audio and Video files) there should be way to "Continue Scan in Background and start using MediaMonkey now" Apron Scan complete Welcome to MediaMonkey Wizard would continue.

Teknojunky

2011-04-08 22:44

updater   ~0024143

Last edited: 2011-04-08 22:47

View 2 revisions

why should the wizard stop/resume after scanning, simply let MM scan in the background just like a normal startup scan.

I can't speak for everyone, but I could care less about the initial scan summary... but I suppose there should be a way to bring up the summary at any point after a scan (even after normal scans).

Even better would be, when clicking on the background scan status/progress bar, that it would bring up the summary/current status as shown on gege's mockup.

In other words, don't tie it only to the 'first run' wizard.

peke

2011-04-08 23:42

developer   ~0024144

I agree, if I got you correctly it should be something like Double Click on Progress Bar to bring Summary?

gege

2011-04-09 03:05

reporter   ~0024145

I completely agree with peke's concerns about the '50k scanning'. Continuing in background is a good solution. I'd go even further by sending the process to background automatically after folder selection, so no need for new 'Send to background...' string.
When scan finishes, the rest of wizard, with scan summary is displayed. How about this?

jiri

2011-04-11 08:33

administrator   ~0024198

Assigning to Ludek as Immediate, so that string changes are reflected asap.

Note the suggested solution expects that after the last Finish button scanning starts in background (normally, as it currently does). Then also the Import from [iTunes, WMP and Winamp] dialog appears as it previously did.

Ludek

2011-04-12 15:20

developer   ~0024249

Fixed in build 1364.

rusty

2011-04-14 04:51

administrator   ~0024305

Tested 1364 and it generally looks very good. A few minor points to resolve:
1) The dialog is significantly wider than the text contained within it (it's too wide by 0000020:0000025%)

2) There should be some sort of feedback in response to entering the registration information (the following strings can be used--they already exist):
a) Thank you for purchasing MediaMonkey Gold! You may now use all of its advanced features!
b) The code you entered is invalid (%s).

The best approach would be to show the message within the registration panel of the wizard dialog (i.e. no need to open a new dialog).

3) If the user has already run a prior version of MM previously, the OS integration dialog appears post-install. It shouldn't.

Ludek

2011-04-14 11:35

developer   ~0024312

Fixed in build 1365.

gege

2011-04-14 11:57

reporter   ~0024315

Last edited: 2011-04-14 11:58

View 3 revisions

@rusty: I completely agree on the window size issue. As a matter of comparison, my mockups are 720x500px, while implemented wizard is 889x600px (taking Aero frame into account).

I propose another tweak:

4) In step #4, the 'File types...' button is redundant and should be hidden, because there's 'OS integration' in step #3 already.

Ludek

2011-04-14 13:13

developer   ~0024319

Last edited: 2011-04-14 13:14

View 2 revisions

Note that 'File types...' button is not redundant, because set of file types to scan can be different from the set of file types to associate.

rusty

2011-04-18 18:06

administrator   ~0024364

Tested 1365.
1) Dialog is still too wide. See attached.

rusty

2011-04-18 18:06

administrator  

wizard_too_wide.jpg (53,025 bytes)
wizard_too_wide.jpg (53,025 bytes)

Ludek

2011-04-18 20:52

developer   ~0024367

Last edited: 2011-04-18 20:54

View 3 revisions

It was because of the "Scan Media" sheet that otherwise wouldn't be wide enough.

It is fixed in build 1366 when width is adjusted dynamically.

stephen_platt

2011-04-27 19:58

developer   ~0024535

Looks good but I noticed some artifacts:
http://i.imgur.com/A5aF8.png

Ludek

2011-04-27 21:07

developer   ~0024543

Last edited: 2011-04-27 21:37

View 5 revisions

Tested build 1367 on Win XP Skinned, Win XP Skinnless, Win 7 Skinnless, Win 7 Skinned, but I cannot reproduce the artifacts with neither of these versions.

Do you use some special steps?

rusty

2011-04-27 22:09

administrator   ~0024545

I'm able to reproduce the artifacts t hat Stephen described just by doing a clean install on Win7 x64. The artifacts occur at different places, depending on the position of the Wizard relative to the rest of the window. This bug is probably caused by the same issue as 0007246.

A second issue is that when the user enters a correct license key, the text from the resulting message doesn't wrap, and is consequently truncated. i.e. the following appears "Thank you for purchasing MediaMonkey Gold! You may now use all of it advance" ("d features." is missing on the next row).

Ludek

2011-04-28 10:28

developer   ~0024555

Last edited: 2011-04-28 10:29

View 2 revisions

The second issue with word wrap fixed in build 1368.

The artifact issues not reproduced at all, tested both skinned and skinless and three versions of Windows (XP 32 bit, Vista 32 bit, Windows7 32 bit). Mabe it is related just to 64-bit Windows OS.

peke

2011-04-28 11:58

developer   ~0024556

Rusty, in past I noticed artifacts in some cases but as soon as close and reopen same dialog artifacts are gone. Mostly was observed within Scripts.

stephen_platt

2011-05-01 21:56

developer   ~0024702

verified 1368. The artifacts do not appear in my latest skin update (not included in 1368, has to be manually replaced).

jiri

2011-05-11 08:48

administrator   ~0025069

Last edited: 2011-05-11 12:42

View 2 revisions

There's a regression caused by this issue - whenever user enters Options dialog, his Gold registration key is deleted from memory for the rest of the session and so no Gold features can be used.

Ludek

2011-05-11 10:06

developer   ~0025075

Fixed in build 1373.

stephen_platt

2011-05-15 02:57

developer   ~0025249

verified 1375