View Issue Details

IDProjectCategoryView StatusLast Update
0007489MediaMonkey (current)DLNA/UPnPpublic2013-12-22 19:52
Reporterjiri 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version4.0 
Target VersionFixed in Version4.0 
Summary0007489: SonyTV UPnP problems
DescriptionThere are two different SonyTV UPnP problems reported in the forum:

http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=56210
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=56209

They both contain a debug log, so hopefully it will be possible to figure out what's up.
TagsNo tags attached.
Fixed in build1401

Relationships

related to 0007659 closedLudek UPnP/DLNA: Album art is shown only for audio/video items, not for album items 
related to 0007676 resolvedLudek Thumbnails and Album Art not visible on some DLNA enabled devices 
related to 0007170 closedLudek Media server doesn't work with PS3 
related to 0007726 closedLudek SamsungTV UPnP problems (regression) 
related to 0010775 closedLudek Bitrate, SampleRate, BitsPerSample are served incorrecly over UPnP/DLNA for auto-converted tracks 

Activities

Ludek

2011-03-14 11:01

developer  

1351 UPnP skipping.LOG (84,857 bytes)

Ludek

2011-03-20 21:34

developer   ~0023803

Last edited: 2011-03-20 21:34

View 2 revisions

I haven't been able to reproduce the problem with any of my UPnP/DLNA clients.
Nevertheless from the attached log the problem obviously appears when on-the-fly auto-conversion from FLAC -> MP3 is being performed.

Improved debug messaging in build 1356 so that log would tell me more then.

Ludek

2011-03-29 12:35

developer   ~0023960

Last edited: 2011-03-29 12:36

View 2 revisions

I found a possible reason for this occasional skipping and fixed it in build 1359.

If it didn't help then generated debug log with 1359, thx.

stephen_platt

2011-05-01 19:25

developer   ~0024697

New log at http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=11523&departmentid=2&ticketstatusid=5

Ludek

2011-05-02 14:21

developer   ~0024725

Last edited: 2011-05-03 10:27

View 3 revisions

1. Fixed the problems related to a specific album (it shows the songs from another album) in build 1369.
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=11524

2. The FLAC skipping problem fixed in 1369 too. It was caused by reporting estimated (inaccurate) convert size and thus Sony TV could cut off the end of the song by several seconds (because of bad estimation).

lowlander

2011-05-04 04:39

developer   ~0024801

Unfortunately issue 2 (converted songs cutoff) still persists on 1369.

Ludek

2011-05-04 13:48

developer   ~0024812

I was finally able to reproduce the issue with iPhone's m-connect client and fixed in build 1370. I believe it is the same fix as for the Sony TV.

lowlander

2011-05-04 14:47

developer   ~0024814

Issue 1 is confirmed fixed in 1369 on forum.

lowlander

2011-05-09 18:31

developer   ~0024978

Sony TV will no longer play FLAC files with Auto-Conversion to MP3 at all (unsupported format error). Samsung TV and Roku Soundbridge Radio still play these files.

Ludek

2011-05-11 08:52

developer   ~0025071

Last edited: 2011-05-11 10:09

View 2 revisions

Fixed in build 1373.

Confirmed by Anubis here: http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=11523&offset=10
by testing http://happymonkeying.com/beta/Sony/Round1/MediaMonkey.exe

lowlander

2011-05-12 17:18

developer   ~0025128

Verified in 1373. Change conversion rules to CBR MP3 and 1373 fixed the problem.

lowlander

2011-07-01 00:00

developer   ~0026477

On 1398 Sony is back skipping with server unavailable on some tracks.

Ludek

2011-07-01 10:50

developer   ~0026481

Last edited: 2011-07-01 10:51

View 2 revisions

From the log it seems that Sony aborts connections for the already converted tracks, but immediatelly initiates new connection and the file plays fine. Can you confirm?
The files that are converted on-the-fly seems to be transfered fine, can you confirm?
So if you delete the pre-converted (cached) tracks, does it work?
Are you sure it is a regression, there hasn't been any change in this area except build 1398, so could you please test also build 1397 to ensure it could be a regression introduced while fixing 0007994 ?

lowlander

2011-07-05 00:40

developer   ~0026528

1397 doesn't suffer the same way.

Ludek

2011-07-05 08:57

developer   ~0026529

Fixed in build 1401.

lowlander

2011-07-06 19:20

developer   ~0026588

Verified in 1401.

lowlander

2011-10-26 19:59

developer   ~0028466

On many builds up until the latest (1449) the Sony TV will occasionally fail to play the file through. This might be caused by Sony needing to know the full file size.

Ludek

2011-10-26 21:11

developer   ~0028470

Last edited: 2011-10-26 21:20

View 7 revisions

I don't see much from the log, but I noticed that there is a lot of "Waiting for file conversion:" messages. This indicates that Sony requires file data that has not been converted yet. Maybe Sony is sensitive in such a cases (when file auto-conversion is too slow). To confirm my speculation please try to set conversion rules so that conversion is as slow as possible and give a try.

Also try to find whether it is always reproducable on the particular file or whether the issue is rather random? If it is random then it could be a network problem like discussed here: http://www.ventismedia.com/mantis/view.php?id=8528#c28298

Another reason could be (as you indicated) that Sony needs to know exact file size beforehand which is possible to estimate only for CBR conversion, but your conversion was CBR (constant bitrate), isn't it?

lowlander

2011-10-28 05:33

developer   ~0028500

Quick response:
It seems random, the same file was played twice in a row by Sony and it fails the first time, not the second time (probably because it now is in cache).

All files are being converted to CBR MP3 precisely as conversion to VBR can cause problems as discovered previously.

lowlander

2011-11-22 17:01

developer   ~0029038

Disabling MP3 to MP3 conversion and lowering the Encoding Quality seemed to have really helped resolving the playback interruptions on the Sony.
The underlying problem seems the occasional slow conversion and might be causing problems for others as well:
http://www.mediamonkey.com/forum/viewtopic.php?f=4&t=61991
http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=62035

peke

2013-12-07 05:05

developer   ~0038575

Verified 1675

peke

2013-12-22 19:51

developer   ~0038974

Last edited: 2013-12-22 19:52

View 2 revisions

Verified 1682 all DLNA Functionality on two Sony TVs KDL-42W807A and KDL-42W654A