View Issue Details

IDProjectCategoryView StatusLast Update
0006370MediaMonkey (current)Main Panel/Toolbars/Menuspublic2010-10-11 01:18
Reporterpeke 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.2.1 
Target Version4.0Fixed in Version4.0 
Summary0006370: Filters: Do not work correctly in some cases
DescriptionIn acse I want to add additional Genre to some track and get bookmarking.

1. Open Track properties
2. add "Audiobook" as additional Genre(eg. "Rock; Audiobook")
3. Select Filter Audiobooks. Audiobook filter is set to Status -> "Is Audiobook" in criteria and just in case I added Genre -> Contain -> Book Criteria.
 
I do not get that newly edited track listed Under Location Tree node.

Image uploaded to FTP.
TagsNo tags attached.
Fixed in build1308

Relationships

related to 0005045 closedLudek Improve performance of default filters 
related to 0005710 closedrusty MP3 files get classified as Podcasts 

Activities

peke

2010-05-25 03:03

developer   ~0020181

Reminder sent to: stephen_platt

Sent reminder regarding test you have done

petr

2010-05-25 11:16

developer   ~0020183

Tried on clean 3.2 installation and can't reproduce.
Can you try to reproduce on clean install as well ?

stephen_platt

2010-05-25 14:25

developer   ~0020184

I can reproduce it but only if the original track is a Podcast, regular tracks (i.e. music) do appear in the audiobooks filter.

Ludek

2010-05-27 10:01

developer   ~0020190

Assigning to me in order to look into it.

Ludek

2010-05-27 12:26

developer   ~0020192

Last edited: 2010-05-27 12:36

The problem is that currently track can have only one status assigned according to the algorithm designed in 0005045
So the track can be neither Podcast or Audiobook, not both.

Peke, can you confirm it was a podcast track and thus it is the same issue as 0005710 ?

peke

2010-05-29 03:06

developer   ~0020194

Last edited: 2010-05-29 03:13

No it was not podcast track, but maybe it was an issue with my MM.DB as Complete DB maintain fixed all (took it almost an hour to finish).

It was a DJ session track lasting over 8 hours and 15 minutes that I want to set as Audiobook to not hunting where I left of.

Ludek

2010-06-22 22:22

developer   ~0020277

Last edited: 2010-06-22 22:31

This has been completely re-designed in MM 4.0, and in addition:
1. Also other types have been added, see:
http://www.mediamonkey.com/wiki/index.php/ISDBSongData::TrackType
2. It is no longer hardcoded, but can be changed in Track Properties

Fixed in build 1308.

peke

2010-10-11 01:18

developer   ~0020719

Verified 1315