View Issue Details

IDProjectCategoryView StatusLast Update
0005710MediaMonkey (current)Otherpublic2010-10-26 12:31
Reporterrusty 
PriorityurgentSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.1 
Target VersionFixed in Version4.0 
Summary0005710: MP3 files get classified as Podcasts
DescriptionI have six tracks recently added to my library that have somehow been classified as Podcasts. i.e. the Album Name appears sub to a greyed out podcasts node with the tracks contained within.

Note that the tracks have genre=audiobook;children , and nothing (that I can see) that would cause them to be in the Podcast node. Also, when I remove the tracks from the library and rescan them, they don't get added as podcasts.
Additional InformationSimilar user report at:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=39913
TagsNo tags attached.
Fixed in build1308

Relationships

related to 0005045 closedLudek Improve performance of default filters 
related to 0005324 closedLudek Queries/Filters: 'Status is Podcast' doesn't work correctly for some users 
related to 0006370 closedLudek Filters: Do not work correctly in some cases 

Activities

jiri

2009-06-04 11:36

administrator   ~0018127

Not sure how could this happen, any idea Ludek?

Ludek

2009-06-04 18:12

developer   ~0018136

There was a similar issue 0005324 which I fixed three months ago, there was bug in a SQL trigger (SVN revision 7294)

Ludek

2009-06-04 22:16

developer   ~0018145

Rusty, do you still have such a tracks in your library?
If yes, could you send me your DB to analyze?

Thx.

rusty

2009-06-05 02:47

administrator   ~0018151

Ludek, I've uploaded mm.db to the ftp server, but I don't think you'll need it. The files that triggered the problem were from the following site:
http://storynory.com/

What I did is I downloaded them, edited them (e.g. changed the genres to Audiobook, album names, titles, etc) since most were lacking metadata, and then synced them to an iPod.

I just re-examined them and it seems that the tracks in question originally had genre=Podcast. When I renamed them to Audiobook, it seems that MM still considered the tracks to be podcasts even though they never were.

I would have expected that if a user changes the Genre from Podcast to something else, that MM would automatically remove it from the Podcast subscriptions node. A similar case could occur if a user downloaded music from a Podcast subscription and then wanted to incorporate it into his/her library.

Thoughts?

Note: any change we make here can probably be deferred beyond 3.1.

Ludek

2009-06-05 10:18

developer   ~0018168

I don't think it is a good idea.
Imagine this situation:
I subscribed the http://feeds.feedburner.com/storynory
I edited genre from 'Podcast' to 'Stories'
or I edited genre from 'Podcast' to 'Podcast stories'
then I wouldn't expect the episode to be removed from the Podcast Subscriptions.

Nevertheless the way to remove it should be to unsubscribe and/or rescan the tracks with changed genre, but this is not very intuitive way I agree.
So maybe we could add a new editable field that would indicate to which podcast the track belongs?

Ludek

2010-06-22 22:24

developer   ~0020278

Last edited: 2010-06-22 22:31

This has been completely re-designed in MM 4.0, and in addition:
1. Also other types have been added, see:
http://www.mediamonkey.com/wiki/index.php/ISDBSongData::TrackType
2. It is no longer hardcoded, but can be changed in Track Properties.

Fixed in build 1308.

stephen_platt

2010-10-26 12:31

developer   ~0020988

verified 1318