View Issue Details

IDProjectCategoryView StatusLast Update
0006324MediaMonkey (current)Synchronizationpublic2011-07-14 23:03
Reporterjiri 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.2.1 
Target Version4.0Fixed in Version4.0 
Summary0006324: Some devices don't show after connection in MM
DescriptionDevices that defer connection of SD card as a mass storage device aren't notified by MM, until MM is restarted. Namely, this happens with Blackberry devices and with Google Nexus One phone. This happens on Windows 7 and Vista, but not on XP. The problem isn't caused by MM, the same issue happens to WMP - i.e. it's apparent that it's a problem down in WMDM/WPD layers.

The exact problem happens as follows:
1. MM (or WMP) is started.
2. A device is connected.
3. It creates a drive letter, but the drive isn't fully working yet (read error).
4. Later, the drive is fully mounted, Windows shows its auto-start dialog, the drive becomes readable, but the change isn't noticed by WMDM and the device still isn't listed in its internal list of devices.

Potential fixes:
1. Restart WMDM internally in d_WMDM plug-in. However, there are many potential problems.
2. Use normal filesystem routines for mass storage devices in d_WMDM plug-in. However, it means quite a lot of work, changes and duplicities. It would hopefully all work fine then?
3. MS fixes the problem. This would certainly be the best, but probably won't occur.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=12&t=49793&p=256599
http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=51684&p=264848#p264846
TagsNo tags attached.
Fixed in build1368

Relationships

related to 0004823 closedjiri Synch to Android phones 
related to 0009977 closedLudek Certain android devices aren't recognized over MTP but are by WMP 
related to 0011587 closedLudek Android device can't be browsed if it's unlocked while connected 

Activities

jiri

2010-12-11 22:06

administrator   ~0021745

Fixed in build 1334.
 - Fixed using method 1., it seems to be implemented properly and without and negative side effects.

Ludek

2011-04-29 10:17

developer   ~0024569

Re-opened, because in recent builds the problem occurs for me, if I connect My ZEN (when MM is running) it shows the device for a second in Media Tree and then immediatelly disappers.

Ludek

2011-04-29 10:37

developer  

6324.LOG (60,599 bytes)

Ludek

2011-04-29 12:42

developer   ~0024570

Fixed in build 1368.

Ludek

2011-04-29 14:22

developer   ~0024571

Discussed with Jiri over IM and the fix is revised by him for regressions.

peke

2011-07-14 23:03

developer   ~0026838

No new reports after fix