View Issue Details

IDProjectCategoryView StatusLast Update
0006219MediaMonkey (current)Synchronizationpublic2013-12-07 21:47
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0006219: Synchronization errors should be logged
DescriptionDue to number of silently failed sync operations it would make sense to log _all_ sync errors and show an error log after the sync process by using the advanced error handling and logging mechanism we used in 0004412, 0000051 and 0005884
TagsNo tags attached.
Fixed in build1668

Relationships

related to 0000051 closedLudek Errors interrupt Caching/Normalization/Conversion/Synchronization Operations 
related to 0004412 closedLudek Fixed failed rips should generate a single error message after rip operation 
parent of 0005884 closedLudek Scanning errors should be logged 
parent of 0011378 closedLudek Files with same metadata are skipped during synchronization 
related to 0011961 closedLudek Duplicate tracks are missing from playlists 

Activities

Ludek

2009-12-15 15:35

developer   ~0019846

Fixed in build 1301.

At the end of synchronization process there is shown one log (on the assumption that there was a problem).

New strings are:

'There was a problem synchronizing the following item(s):'
'File %s is inaccessible'
'File %s is not supported by the device'
'Conversion of file %s failed'
'Problem while copying file %s to %s'

peke

2010-10-20 03:47

developer   ~0020872

Verified 1317

Ludek

2011-05-03 13:23

developer   ~0024768

Last edited: 2011-05-03 13:24

View 2 revisions

Re-opened due to report here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=56670
and here:
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=11502

If a path/filename becomes to long it will throw an error dialog up while syncing - stopping the sync process until it is cleared. This should get logged and continue the sync process and then be displayed at the end of the sync process.

Ludek

2011-05-03 14:39

developer   ~0024772

Fixed in build 1369.

peke

2011-06-11 01:19

developer   ~0026043

Verified 1387

Ludek

2013-10-09 09:25

developer   ~0037812

Last edited: 2013-10-09 09:50

View 2 revisions

Re-opened, this hasn't been fully fixed:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=73882&start=15#p375557

These two
'File %s is inaccessible'
'File %s is not supported by the device'
are logged only when user uses Send to -> Device, but are not logged when using Auto-sync!

I also added one more new error string to cover the case described in issue 0011321 :
'File %s was skipped, because it points to the same device location (%s) as file %s'

Ludek

2013-10-09 09:51

developer   ~0037813

Last edited: 2013-10-09 09:57

View 3 revisions

Fixed in build 1663.

Hopefully the log after every auto-sync won't be too irritating for users that have deadlinks on sync-list or unsupported files.

We may consider adding '[x] Don't show this again' checkbox to the sync log.

Ludek

2013-10-23 23:16

developer   ~0038025

Last edited: 2013-10-23 23:22

View 4 revisions

It seems that the "error"
'File %s was skipped, because it points to the same device location (%s) as file %s'
is quite common and irritating. More info: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=74149
Leaving it only as debug message when generating debug logs.

Fixed in build 1668.

peke

2013-12-07 21:47

developer   ~0038583

Verified 1675