View Issue Details

IDProjectCategoryView StatusLast Update
0005826MediaMonkey (current)Install/Configpublic2010-02-08 22:44
Reporterpeke 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version 
Target Version3.1.2Fixed in Version3.1.2 
Summary0005826: Installer not working correctly on Windows 7 x64
DescriptionI was not able to replicate this issue until I made Clean install oF Win 7 x64 RC

Thing is that if you regularly start installer Automatization Server registry entries are not Created Correctly unless you Start MediaMonkey Installer in Win XP Compatibility Mode.

Note MediaMonkey works without issues when it is started but can't be used in programming environments due the fact that MediaMonkey.exe is not registered Automatization server. It looks that compatibility mode puts 32Bit Virtualization of Windows XP and apron exit properly import created Registry entries.
Additional InformationTicket:
WWN-322186

Forum:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=38801
TagsNo tags attached.
Fixed in build1271

Relationships

related to 0005913 closedpetr Upgrade to InnoSetup 5.4 
related to 0004912 closedLudek Non-Admin users can't install scripts 

Activities

jiri

2009-08-13 08:35

administrator   ~0018635

Petr, any idea how to easily apply the fix specified in http://support.microsoft.com/kb/899965 directly in MM?

petr

2009-08-25 14:40

developer   ~0018683

Peke, we're already having permission granting routine in MM (Vista or newer system). Isn't that any already fixed internal Windows 7 bug (as you've mentioned, this issue is related to clear installation) ? I'm using Windows 7 x64 since first beta and never had problem like this.

peke

2009-08-25 21:31

developer   ~0018688

I never had issues with permitions either, but I was able to replicate Issue when I installed clean Win 7 x64 RC.

The thing I noticed that MEDIAMONKEY.EXE have enough permitions to write to Registry CLASSID noted in MS Spec I wonder if we can apron startup re-register all CLASSIDS or Make an small APP that will do that after MM setup is done and started in raised Permitions.

My guess is that Digital Signature is counted also.

peke

2009-08-25 21:40

developer   ~0018689

Additionally I've found that same thing happen if I deny access to MM Setup in ZoneAlarm. But Again MediaMonkey.exe do not report that problem.

I Uploaded Pictures to FTP

peke

2009-08-28 03:30

developer   ~0018703

I've done more tests and definitely app that have enough Registry access (Apps that have verified Digital Signature) can create ClassID without problem which means that MM setup do not have it.

That can be confirmed if Win 7 is put in in Test/Dev Mode where Win 7 do not verify digital signatures Setup is working.

Maybe Newer setup version will fix that. or maybe x64 version if exist.

jiri

2009-08-28 09:06

administrator   ~0018704

Ok, please check out how it works with the latest installer.

petr

2009-09-04 20:03

developer   ~0018733

Will be fixed in 1265 (using new version of InnoSetup).

peke

2009-09-11 23:58

developer   ~0018782

Last edited: 2009-09-12 00:13

Still not fixed but I've found way how to determine where is the problem and what Compatibility Solution should be applied.

When in Windows 7 x64 you right click on MediaMonkey_3.1.2.1266_Debug.exe you will get Compatibility Troubleshooting option. In case you chose that Windows 7 tries to show and execute MediaMonkey_3.1.2.1266_Debug.exe with recommended settings InooSetup is detected as Windows XP (SP2) Application.

EDIT: Note that in case it is not run in Compatibility Mode Task bar player is not registered correctly and can't be selected

petr

2009-10-05 14:49

developer   ~0019065

Added internal /ELEVATE parameter so this issue should be fixed in 1271. Feel free to reopen when this issue appear again.

peke

2009-10-06 02:48

developer   ~0019081

Will Retest when Win 7 gets fully out, I'm switching two PC-s in network to Win 7.

peke

2009-11-01 01:31

developer   ~0019436

Verified 1282

peke

2009-12-28 23:02

developer   ~0019890

Reopen based on http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=45530

Close if no changes needed.

petr

2010-01-23 19:11

developer   ~0019974

Last edited: 2010-01-23 19:12

I've just installed MM to clean Windows 7 x64 installation without any problem.
Also server registration is processed together with extensions association (near installer finish).

peke

2010-02-08 22:44

developer   ~0019998

Verified 1294