View Issue Details

IDProjectCategoryView StatusLast Update
0005565MediaMonkey 5Playlist / Searchpublic2017-01-15 05:51
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0005565: Full-text search only finds prefixes (gives poor results in Oriental languages)
DescriptionDue to the design of sqlite full-text-search, MM is currently limited to finding word segments _only_ when they are at the beginning of a word.

e.g. Typing 'Mad' will locate "Madonna" or "Child and Madonna", however typing 'donna' will not locate these.

This is problematic for foreign languages which don't use the 'space' as a delimiter between first and last names. This means that MediaMonkey's search bar cannot be used to find Artist first names in Japanese, Korean, Chinese.
Additional InformationReported at http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=39122
TagsNo tags attached.
Fixed in build2013

Relationships

related to 0005186 closedLudek MediaMonkey (current) Quick Search with "" (quoted strings) doesn't work as expected 
has duplicate 0013040 closedLudek MediaMonkey (current) Quick Search: Always work as STARTS WITH instead of CONTAINS 
has duplicate 0013144 closedLudek MediaMonkey 5 Search fails to find results when entering end of word (Quick Search/All Text Fields) 
child of 0003040 closedLudek MediaMonkey (current) Implement proper full-text search 

Activities

jiri

2009-05-22 13:47

administrator   ~0017965

I'm not sure what to do about this, it seems to be the correct behavior in most cases. We can possibly add an option for future versions that would control whether also searching in middle of words is possible, but for now I don't think any change is necessary.

rusty

2009-05-22 17:06

administrator   ~0017971

Possible approach for 3.1 is to add a config setting to .ini file for such languages.

Better long term solutions that wouldn't require user configuration of these settings are:
1) switch the behavior so that it searches in the middle of words always. I don't think that this is such a bad option, if the performance implications are minimal.

2) change the behavior based on the language installed.

rusty

2009-05-22 17:31

administrator   ~0017975

deferring post 3.1. Too much risk associated with adding this functionality.

jiri

2009-06-22 11:34

administrator   ~0018464

Decreasing priority, since I don't see any reasonable shorter or longer term solution. The performance is problem here, FTS in SQLite can't be currently used this way.

rusty

2009-10-15 14:24

administrator   ~0019152

Last edited: 2009-10-15 14:24

I've gotten some more feedback from Reika about this:

> how is MM 3.1.x working for you / Japanese users (given the search problem)?
 
I use 'search box', 'basic search', and 'advanced search' properly if necessary.
Because the result that I expected is not provided, I often re-search by another method.

In Japanese BBS, I did a question same in other users.
For reasons of the deterioration of the search functionality, there are considerably the people who do not yet update from 3.0.
There are even the people who downdate MM from 3.1 to 3.0.

Any strings can be found by the search functionality of specific field in 'Basic' or 'Advanced' search. Why is it impossible only by the search from the whole tag?
----------------------------------------------------------
I think we need to revisit this for 4.0.

Ludek

2009-10-15 16:08

developer   ~0019153

Last edited: 2009-10-15 16:21

Rusty, in the search bar it is impossible because we added new SQLite's full text search engine in version 3.1 (SQLite FTS3). The engine indexes all particular text fields/attributes of all songs and increased DB size, because the text data are indexed in the table SongsText. And the engine allows us to search prefix or full word (not infix, not postfix).
The advantage of the engine is mainly performance of the search.

My guess is that for oriental languages (japanese, chinese) we could automatically switch to the old approach we used to use in MM 3.0.

We could decide whether to use the new engine or not according to the MS Window's locale?

rusty

2009-10-20 20:13

administrator   ~0019254

Last edited: 2009-10-20 20:20

Perhaps an option such as:

[ ] Search middle of words via the searchbar (reduces performance)

Tooltip: Enable for Japanese or other languages in which words or names may not be separated by a space.

It would be enabled by default for Japanese, and other languages that exhibit this problem.

Note: this should modify the tooltips that appear under the search bar. i.e. if enabled no search tooltip would be shown.

Ludek

2009-11-02 14:26

developer   ~0019469

Also we should consider the discussion here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=43901

We have always searched via Search dialog (Artist->mel torme) is diacritical sensitive via LIKE on Artists.
i.e. not using SQLite's FTS3.

But Search bar "artist:mel torme" is diacritical insensitive MATCH on SongsText (using FTS3)

As I now japanese users uses search dialog, because they can search also middle of the words ('donna' finds 'maddona')
and the others uses Search bar "artist:mel torme", because it is diacritical insensitive.

We should probably somehow unify this once this issue is resolved.

Ludek

2016-01-04 11:54

developer   ~0043774

Last edited: 2016-01-04 12:27

View 3 revisions

User from the ticket UJR-193-58189 complaints about this issue being ignored since 2009, increasing priority to urgent and targeted to be included in MM5

User is saying that it DOES NOT only effect Japanese, Korean and Chinese languages and that it DOES effect ALL languages. His words:
"when I work with my music I run into numberous situations where I want to search for a PART of a description/word e.g. a CD number DBCD12345 where 12345 is not found! Or anything behind any other sign as /test "test, etc. "

With this in mind also item 1) here 0012521:0043400 should be re-evaluated , noted there 0012521:0043775

Ludek

2016-01-21 12:35

developer   ~0043929

Last edited: 2016-01-21 12:38

View 3 revisions

Solution is described at 0012521:0043916

i.e adding the following config in Options -> Search panel:

Search mode: [Ignore diacritics / search word prefix (fastest), respect diacritics / search word infix]

- enabled only when '[ ] Search whole words only' is unchecked (by default)

Ludek

2016-01-21 13:49

developer   ~0043933

Last edited: 2016-01-22 09:08

View 2 revisions

Fixed in build 5.0.0.2013