View Issue Details

IDProjectCategoryView StatusLast Update
0005130MediaMonkey (current)Properties/Auto-Toolspublic2010-12-17 01:03
ReporterBex 
PriorityurgentSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.1 
Target VersionFixed in Version4.0 
Summary0005130: The <Extension> mask evaluates to cda when ripping
DescriptionIn this particular case it should evaluate to the selected rip-format. Perhaps it's easier to implement a new mask to do this?
Additional InformationReported here:
http://www.mediamonkey.com/forum/viewtopic.php?f=4&t=35608
TagsNo tags attached.
Fixed in build1300

Relationships

related to 0005107 closedLudek Feature Request: add <type> or <filetype> to auto-organize masks 
related to 0005096 closedrusty Not all masks are documented in the Help file 

Activities

jiri

2009-01-06 17:31

administrator   ~0016019

For compatibility reasons I would suggest introducing a new mask 'TargetExtension' that would contain target file type in case of format conversions (including ripping).

Technical: Data could be supplied by a global variable, that would be set to target format in case Conversion dialog is open and to '' in case such dialog isn't open.

Assigning to Rusty for a review.

rusty

2009-01-06 19:51

administrator   ~0016020

Is there really a need for a new type of mask? It seems to me that the intended use of <extension> is _always_ the target extension, and we simply didn't recognize that.

i.e. if a user is ripping/converting to a new format and uses <extension>, they would always intend to be using the Target Extension rather than the source extension.

Teknojunky

2009-01-06 20:10

updater   ~0016021

agree with rusty. In the case of simple auto-organize, there is no conversion thus the target = current anyway.

jiri

2009-01-06 20:17

administrator   ~0016022

I agree, I was just afraid that someone could depend on the current state, even though I can hardly imagine how could it be useful.

Bex

2009-01-06 21:26

updater   ~0016026

Last edited: 2009-01-09 14:06

Actually, there is a scenario when it's desired that <Extension> really means current extension and that is when converting tracks.
It can be useful to know what format you converted from and users may have such masks in use.

E.g. Convert "Abba - Waterloo.flac" to mp3
a) If <Extension> isn't changed:
Mask: <Extension> - <Artist> - <Title>
Result: "flac - Abba - Waterloo.mp3"

b) If <Extension> is changed:
Mask: <Extension> - <Artist> - <Title>
Result: "mp3 - Abba - Waterloo.mp3"


Looks like a new mask isn't a bad idea after all.

What about, <Type> and <ToType> instead of <Extension> and <TargetExtension>?

Ludek

2009-01-15 21:52

developer   ~0016251

Last edited: 2009-01-15 21:53

Rusty, I fixed 0005107, so the <Extension> was renamed to <Type>.

How should be named the <TargetExtension> ?
<ToType> as suggested by Bex or <TargetType> ??

Teknojunky

2009-01-15 22:35

updater   ~0016254

maybe <source type> & leave <type> as destination, although I really think bex's described scenario while possible is very unlikely due to <extension> being undocumented until very recently.

rusty

2009-01-20 18:26

administrator   ~0016309

I agree with tekno here i.e.:
<Type> - Extension
<Source Type> - Source file extension

The only issue I have is that 'Type' was chosen to represent 'Filetype' in the Tracklist because it doesn't take up much space. In the future, though, we may want to use 'Type' to represent something else (e.g. Audio / Video).

Bex

2009-01-20 19:48

updater   ~0016312

I'm not so sure. Reflect over this.

Current situation:
Source Type - <Type> (previously <Extension>, was renamed to be consistent with main window)
Target Type - Not Implemented

Your suggestion:
Source Type - <Source Type> (previously <Extension> and <Type>)
Target Type - <Type>

It means that existing masks containing <Extension>/<Type> will automatically be renamed to <Source Type> which isn't consistent with main window.

Due to this isn't it better to do like this:
Source Type - <Type> (previously <Extension>)
Target Type - <Target Type> (new mask)

Everyone who has tried <Extension>/<Type> in ripping and converting knows it doesn't work so giving them a new mask makes more sense to me. Existing masks containing <Extension>/<Type> will be renamed to <Type> which is consistent with main window.

rusty

2009-01-20 21:35

administrator   ~0016321

Set to 'urgent' (i.e. deferring to post 3.1) due to required string changes.

jiri

2009-06-23 13:10

administrator   ~0018497

Assigning Bex's suggestion to Ludek, i.e.:

Source Type - <Type> (previously <Extension>)
Target Type - <Target Type> (new mask)

Ludek

2009-06-29 17:54

developer   ~0018525

Added the <Target Type> mask in build 1300.

peke

2010-12-17 01:03

developer   ~0021875

Verified 1335