View Issue Details

IDProjectCategoryView StatusLast Update
0002242MediaMonkey (current)Burning / Disc Handlingpublic2010-10-13 23:25
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0002242: Data CD Burning: Warnings when path / file length exceeds specified parameters
DescriptionI'm not sure whether this is a problem or not, but currently, we don't do any checks or tructations based on path/filename lengths that exceed a certain number of characters.

This is something we need to investigate in the future.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?t=6232

ISO9660
Discs with ISO9660 as the file system can be read on all operating systems.

ISO9660 supports filenames in 8.3 format in Level 1 (8 characters for the filename and 3 for the extension) and directory names 8 characters long. Only characters A-Z, 0-9 and the underscore (_) are allowed. The maximum interleaf depth is restricted to 8 levels (including root directory).

A total of 31 characters are allowed in Level 2 and can be read by Windows 95 and higher, whereas DOS and Windows 3.1 usually have trouble handling the long filenames.

ISO9660:1999
ISO9660 is a file system that was designed with the aim of creating a file system that is as system-independent and so as compatible as possible. The advantages of this file system lie in the length of possible file names (the ISO9660:1999 file system supports file names with a length of up to 207 characters) and the fact that restrictions on directory depth have been lifted.

UDF
The UDF file system was developed when it became increasingly obvious that the ISO9660 file system used on CDs was no longer meeting the needs of rewritable media and DVDs. It was optimized mainly to accommodate large data volumes and to make it easy to modify an existing file system.

There are 2 UDF modes: UDF and so-called 'UDF Bridge CDs', which contain both a UDF and an ISO9660 file system. The UDF file system can be read by Windows 98 and Windows 2000 with no special drivers. In case of doubt, Windows 2000 and Windows 98 also read the UDF file system if both an ISO9660 and a UDF file system are detected on the medium. Writing in UDF format is particularly important when burning DVDs because UDF is the preferred operating system for these media.

References:
http://en.wikipedia.org/wiki/ISO_9660
http://en.wikipedia.org/wiki/Universal_Disk_Format
Tagsdoc_help, todoc
Fixed in build1315

Relationships

related to 0005786 closedLudek Burn: Provide option to choose 'Image type' 

Activities

Ludek

2006-04-08 19:43

developer   ~0007132

Added functionality which can be enabled by
Options|Confirmations| [x]Confirm rename operations that exceed 64 character CD limit

rusty

2006-04-09 02:12

administrator   ~0007133

Re-opening because I'm not clear on what the new functionality is (does it warn users? does it automatically truncate paths? does it automatically truncate filenames? Once I understand I can recommend clearer text), and because I suspect that it should be in the CD burning dialog (assuming the functionality applies exclusively to CD Burning operations and not to Auto-Rename operations.

Please clarify. Thx.

Ludek

2006-04-10 17:57

developer   ~0007134

Last edited: 2006-04-10 18:08

The implementation is very similar to Auto-Organize Confirmation when file name exceeds 64 chars. Difference is that in case of burning the confirmation and challenge to edit files appear while you edit Disc Format on Confirm Disc Format page of the Disc Burning Wizard. Whereas Auto-Organize performs this challenge after OK button clicking.

So there is no need for localize the strings, cause these dialogs exists.
Check the build for clarification.

Btw: I don't think that it should be in the CD burning dialog - I believe that Confirmations page in Options is very good place for this due to similarity of cases (Auto-Organize/Rename and burning).

rusty

2006-06-22 05:31

administrator   ~0007366

With the 2.5.3 release, some users have also complained that burns sometimes complete only partially.

After some investigation, it seems that if a burn is attempted and more than 0000122:0000240 files are copied to the root directory, then everything else is ignored.

Currently MM appears to successfully burn such a CD/DVD, but in actuality, it silently fails.

What I think we need to do for this issue is determine what scenarios contravene CD/DVD burning standards, and then warn the user (always) before the CD is burnt so that they can alter the mask or other configurations accordingly.

Ludek

2006-07-14 19:14

developer   ~0007506

I cannot reproduce it, I have burned 270 files into root directory, but I found that if burned tracks aren't in the library (must coming as pre-selected), duplicates are eliminated without warning, it could be your case and this was fixed in 0002551.

rusty

2006-07-17 17:23

administrator   ~0007528

ok, I tested this again, making sure that no duplicates existed, and successfully burnt 342 files. Thus I'm no longer certain what caused the original problem (perhaps it was a result of a filename > 207 characters).

That said, can you clarify:
What format does the engine use for CDs?
What format does the engine use for DVDs?
If MM uses ISO9660, what happens when the filename is > 31 characters or directory structure > 8 folders deep?
If MM uses ISO9660|1999, what happens when the filename > 207 characters?

Ludek

2006-07-19 00:13

developer   ~0007542

We use Joliet Image every time.

rusty

2006-07-19 15:17

administrator   ~0007545

According to what I see at:
http://www.controlledvocabulary.com/imagedatabases/filename_limits.html
http://www.portfoliofaq.com/pfaq/FAQ00352.htm

Joliet imposes a filename limitation of 64 characters (where filename=length of path + filename). If that's the case, wouldn't we need error handling for cases where the path > 64 characters? I'm guessing that this isn't the case, but if it isn't what format is MM actually burning to?

Ludek

2006-07-20 00:34

developer   ~0007553

Yes, we use Joliet which should be restricted by 64 chars limit, but we both with Jiri tried lots longer filenames with very high deep and all was burned/read correctly.

We could have Joliet/ISO9660/... configurable, but we consider it as useless with Jiri.

rusty

2006-07-20 01:08

administrator   ~0007554

Thanks for the clarification. Resolving -- Not a Bug.

Ludek

2010-09-16 09:28

developer   ~0020527

Last edited: 2010-09-16 09:36

View 2 revisions

Re-opened, because coming with issue 0005786 we allow users to choose image type [Joliet, ISO9660, UDF, UDF - ISO9660, UDF - Joliet] in MM 4.0

Therefore we need to warn user whenever the path depth or filename length exceed parameters specified for the selected image.

Possible alternatives:

1) A warning that gives the user the choice of a) correcting the error by going back to the previous step of the wizard b) automatically correct the error for the user

2) Move 'Image Type' checkbox from 'Burn Settings' page to the 'Choose Disc Format' page according to attached screenshot

Ludek

2010-09-16 09:30

developer  

Burning issue.jpg (70,938 bytes)
Burning issue.jpg (70,938 bytes)

rusty

2010-09-16 13:20

administrator   ~0020534

Last edited: 2010-09-16 13:21

View 2 revisions

Peke posted an image of a potential solution (burning_issue.jpg) that seems to work well.

If we end up changing the burn dialog so that it appear within a tab, then we'll be able to further optimize the arrangement of the config options (while retaining the existing strings).

Note: the only problem is that this introduces a UI discrepancy between the Data CD and Audio CD dialogs (but again, I think that this can be resolved when we migrate the config to a tab).

Ludek

2010-09-16 14:25

developer   ~0020536

Last edited: 2010-09-16 14:25

View 2 revisions

The 'File System:' combo box is presented only for data CD/DVD burning, so the Peke's screenshot could work fine (without affecting Audio CD burning).

peke

2010-09-16 21:06

developer   ~0020538

I would suggest one more thing:
While there is ERRORS/RED or WARNINGS/YELLOW the NEXT button should be unavailable.

Ludek

2010-09-18 23:06

developer   ~0020552

Fixed in build 1313 according to Peke's suggestion.

Note that for IS09660 I used strict Level 2, i.e. A-Z, 0-9 and the underscore (_) are allowed. The maximum interleaf depth is restricted to 8 levels (including root directory), but filenames are restricted by 31 chars (unlike Level 1 that is in 8.3 DOS format). I used Level 2, because it is supported by most of devices and Level 1 restriction would be hard to edit (to have all filenames in 8.3 form).

peke

2010-10-07 23:13

developer   ~0020669

Last edited: 2010-10-07 23:15

View 2 revisions

Verified 1314 using http://en.wikipedia.org/wiki/Comparison_of_file_systems

Can you please list exact Format type MM uses for each setting (Eg are we supporting using ISO9660:1999 or ISO9660:1988 Level3 or Level2 or ...?

We should spec it for TODOC tag.

Ludek

2010-10-08 11:10

developer   ~0020672

Last edited: 2010-10-08 13:15

View 3 revisions

As I wrote, for the IS09660 I used is strict Level 2, i.e. A-Z, 0-9 and the underscore (_) are allowed. The maximum interleaf depth is restricted to 8 levels (including root directory), but filenames length are restricted by 31 chars.

Note that by filename length is meant the string length between two backslashes,
i.e. for path like this:
DIR1/DIR2/FILENAME.mp3
neither of DIR1, DIR2, FILENAME is longer than specified length.

For Joliet the allowed filename length is 64 characters.

Nevertheless I noticed that in the link supplied by Peke there is also restriction for UDF images (filename length restricted to 255 chars, path len restricted to 1023 chars). So I fixed it also for UDF in build 1315.

peke

2010-10-13 23:25

developer   ~0020759

Verified 1315