View Issue Details

IDProjectCategoryView StatusLast Update
0001765MediaMonkey (current)Properties/Auto-Toolspublic2010-10-16 01:15
Reporterpeke 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2.3 
Target VersionFixed in Version4.0 
Summary0001765: Auto-Tag from Amazon: generates incorrect Artist info for Various Artist CDs
DescriptionWhen Auto-Tag from Amazon successfully finds a match for a Various Artists CD, it tags:
Artist as: Various Artists
Title as: <Artist> - <Title>

I don't know if there's any way around this since this is how Amazon returns the information, however, it seriously limits the utility of the feature for compilation albums.

MM should somehow be smart enough to realize that if all tracks on an Album are of the form Artist - Title, then it's a various Artists album, and:
-the Artist field should appear as Album Artist
-the Title field should appear as [ ] Titles - [ ] Artists
TagsNo tags attached.
Fixed in build1301

Relationships

related to 0006176 closedLudek Auto-Tag from Web: Ability to tag Title without tagging Track# 

Activities

rusty

2006-08-09 21:13

administrator   ~0007709

Item 2 at: http://www.mediamonkey.com/forum/viewtopic.php?t=10522 describes some related information: whenever a Title contains a '-', the portion after the '-' isn't included.

jiri

2006-12-08 19:23

administrator   ~0008251

Since Amazon returns track information as only single string, it's impossible to parse it properly in all cases. I.e. I think we have to keep it as is.

jiri

2006-12-08 19:50

administrator   ~0008254

Based on IM discussion with Rusty, it would probably be possible to implement it this way:
 1. By default '-' won't terminate track title (as it currently does and because of this some title are incomplete).
 2. If _all_ track titles returned from Amazon contain ' - ', it will be considered as mutli-artist album and as such:
  2a. 'Artist(s):' string will be changed to 'Album Artist(s):'.
  2b. Instead of '[ ] Tracks:', there will be '[ ] Tracks - [ ] Artists:' shown.
  2c. On Auto-tag, the strings will be properly parsed (based on ' - ') and tagged to correct fields (i.e. Artist, Album artist and Title).

Assigning to Rusty for a review, please assign to Ludek then.

rusty

2006-12-11 19:22

administrator   ~0008275

Sounds reasonable.

Ludek

2007-10-09 10:18

developer   ~0011240

Last edited: 2009-11-25 15:09

I'm re-opening it, because of some usability issues.
I have just tagged about 200 albums from amazon and in many cases there are multi-artist albums/compilations where all tracks are in the form <Title> -<Artist> except one or two and then it is annoying that such a albums are not considered as multi-artists albums although they should.

To prevent this I suggest to change the implementation slightly:
2. If > 50 % tracks titles returned from Amazon contain ' - ', it will be considered as mutli-artist album.

Ludek

2009-03-31 23:33

developer   ~0017252

Last edited: 2009-03-31 23:34

Rusty,
Peke has uploaded video related to this, see:
FTP /forLudek/Auto-tag from web issue/1230_Auto_Tag_From_WEB_Bug.wmv

1. What I wrote in the note 11240 can be seen when you seek the video to 2:50

There seem to be two other issues in addition to what I wrote in the note 11240

2. Searches with Diacritics do not work
3. In case of comilations like this with VA we should not use artist name (it is "VA" or "Various Artists"), but rather album name when initializing search automatically

peke

2009-03-31 23:46

developer   ~0017254

Last edited: 2009-04-01 00:08

3. That should also be used in Album is same for all tracks that initiated Auto Tag from Web (with exception where Album value is missing as that will be mostly the case when user selected bunch of tracks with no valid tags in try to do mass Auto tag from web) even Artists/Album Artist are not same.
Example:
Album field: Café del Mar, Vol. 5
Artist/Album Artist field on tracks:
01: Salt Tank
02: Floyd, Doc
03: Mertens, Wim

in this Example there is almost certainly all tracks are from same album even Album Artist is not VA (that is known issue we fix with "create Multi-Artist Albums..." option in Maintain Library) so in this case auto-tag should recognize it as Compilation.

Ludek

2009-11-25 14:56

developer   ~0019771

As discussed over IM, assigning to me to fix 1, 2, 3 as suggested.

Ludek

2009-11-25 16:54

developer   ~0019772

Fixed in build 1301.

It works much better for VA albums now.

peke

2010-10-16 01:15

developer   ~0020788

Verified 1316