View Issue Details

IDProjectCategoryView StatusLast Update
0015000MediaMonkey (current)Synchronizationpublic2019-04-14 19:05
Reporterpeke 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version 
Target Version4.1.22Fixed in Version4.1.22 
Summary0015000: Sync: Device scan do not find MMW server
DescriptionIn past few days I've been witness to one strange behavior of MMW UPnP/Sync Server which seams unrelated to firewall settings.
Steps To ReproduceIf device do not see MMW server repeat these steps

1. Start Sync setup/UPnP in MMA (Usually on new devices or ones that got new IP assigned from Routed DHCP)
2. Confirm that MMW server is not found
3. Start Scan For Sync Server again
4. while MMA is still scanning restart MMW
5. in 80% of cases (8/10) On MMW restart Server gets recognized
6. continue and finish Sync
7. Leave MMW started for some time (few hours)
8. Try to sync again and if fail repeat from step 3 and Sync will complete

NOTE: Restarting MMW Server from Within MMW options help in 1/10 cases to get MMW server recognized.

P.S. After some time repeating the steps MMW starts to get recognized without problems
Additional InformationGAW-656-22949
KTT-159-76825
TagsNo tags attached.
Fixed in build1876

Relationships

related to 0011531 closedLudek MediaMonkey (current) Server is not seen after resume from computer sleep for some users/client apps 
related to 0014906 assignedmartin MediaMonkey for Android UPnP: Several Major tweaks Missing in UPnP browser 
related to 0011138 closedmartin MediaMonkey for Android UPnP discovering is sometimes too slow, manual option is needed 
related to 0011780 assignedmarek MediaMonkey for Android WiFi Sync Settings: Each SSID should have own settings 

Activities

peke

2018-08-01 21:58

developer   ~0050852

Last edited: 2018-08-03 02:37

View 3 revisions

It is very hard to replicate once MMW server gets recognized by device and MMW restarts are no more needed.

Sometimes it happens after 3-5 restarts/syncs and sometimes after 10, but eventually something on user affected networks recognize MMW as UPnP/DLNA Server and do not block it anymore and MMW Multicast packets are passed. I have not found any new entries in Firewall and few users also complain on Twonky and MiniDLNA servers behave same.

martin

2018-08-20 09:24

developer   ~0050942

I.
MMW 4.1.21.1875 on my laptop - this kind of issue never appeared.
II.
second sever on my older PC, MMW 4.1.21.1865
1) launch MMW
2) visible on all my phones
3) wait approximately minute - no server found also as no UPnP server
4) restart MMW - MMW visible on my phones
5) I waited around 10minutes and MMW disappear again
- tested also with BubbleUPnP and also not visible there- So the issue is not on MMA side.
III.
I have reinstall MMW on PC with latest MMW 4.1.21.1875 debug version(previously non-debug version)
- MMW is running more than an hour and still visible on all my phones.
- I will ask Ludek whether is possible that the issue is fixed in the newest version.

martin

2018-08-20 13:33

developer   ~0050945

Last edited: 2018-08-20 13:43

View 2 revisions

Replicate it again, but with MMW on laptop. MMW is running, but not visible, also not visible from BubbleUPnP.
I have tried it also with my second phone and there MMW was visible, then it appeared also on my first phone.
Any Idea?

Ludek

2018-08-21 14:54

developer   ~0050950

Last edited: 2018-08-21 16:41

View 4 revisions

Debugging offline and commited a fix (for 4.1.22.1876).
Martin and the user from ticket GAW-656-22949 are testing/confirming the fix... (testing stuff sent to them)

Ludek

2018-08-23 10:17

developer   ~0050966

Martin indicated that issue remains when computer is wake up from the sleep, i.e. it is rather instance of 0011531, solving...

Ludek

2018-08-23 12:40

developer   ~0050970

Last edited: 2018-08-24 09:12

View 6 revisions

I have also reproduced the issue today on Windows 10 machine.

It seems that to reproduce the issue there must be the latest Windows 10 update and you need to wake up the computer from the sleep mode.
After that any server from the Win10 PC isn't visible in MMA (tested Plex, WMP, MMW). Restarting MMW is a temporal workaround to show at least the MMW server (because it notifies itself on start), but subsequent restarting MMA causes that any server isn't visible again.
I run Wireshark on both PCs (Win10 and Win7) and on the Win7 PC I saw the SSDP M-SEARCH request from MMA/Phone (192.168.1.101 -> 239.255.255.250:1900), but on the Win10 PC the request was missing!! Something on the Win10 has to drop the M-SEARCH request packets. I tried to disable Windows Defender's firewall and Real Time protection, tried restarting SSDP Discovery service, but nothing helped to see the M-SEARCH in Wireshark. The only workaround is PC restart.
So this isn't something that can be fixed in MMW, but there may be a way how to configure Win10 to not behave like that, to be found how. For now only "not using sleep mode" is the workaround.

martin

2018-08-24 07:58

developer   ~0050978

Little different behavior on my side. When computer(Win 10) with MMW server wakes up, then MMA always see other Media Servers (Plex, WMP) immediately.
MMW also appears but usually with 30minutes delay and then after same time disappear again.
When MMW is restarted, then is visible all day without issue.

Ludek

2018-08-24 10:27

developer   ~0050979

Last edited: 2018-09-03 11:22

View 4 revisions

Test note: Petr, Michal and Peke are also seeing the Martin's behaviour

Actually we are already auto-restarting the UPnP/server after PC wake up (because of 0011531 ), but we probably makes it too early after PC wake up which is probably causing the issues somehow, I've tried to postpone the restart (to 5 seconds after wake up).
Petr, Michal, Martin and Peke confirmed that it does the trick.

Fixed in 4.1.22.1876 and merged to 5.0.0.2121

peke

2018-08-27 14:24

developer   ~0050992

Verified 1876

peke

2018-12-28 23:12

developer   ~0051892

Reopen it looks like it still happens for some users and confirmed steps work 100%

I wonder would INI setting to restart Server in Minutes unless there is access would help?

Ludek

2019-01-02 09:55

developer   ~0051900

Last edited: 2019-01-02 10:32

View 4 revisions

Peke indicated that this started again after newest Windows 10 update for some users. It seems that 5 seconds in 0015000:0050979 is still not enough.
We could try to increase it to 30 seconds + add INI switch as suggested by Peke.

@Peke: Could you please add some references here? The only reference seems KTT-159-76825 which I think is not the issue, because user:
a) don't use sleep/wake up in the tests
b) indicates that any MMA restart causes the server to disappear (until MMW is restarted)

peke

2019-01-02 20:30

developer   ~0051912

Ip Isolation is common issue on ISP Routers and usually enabled by default on most newer routers
it is common issue https://support.google.com/chromecast/answer/3213084?hl=en

IP isolation means that every Wireless device have access only to Internet thru gateway and can't access other Wireless devices. Althrough they can access LAN devices.
https://static.tp-link.com/image001_1518167280287s.jpg

https://www.howtogeek.com/179089/lock-down-your-wi-fi-network-with-your-routers-wireless-isolation-option/

In users case it is very possible that combination of Router and Vipre blocks Multicast/Unicast packets after some time.

As pointed in Ticket.
It is a hole in IP Isolation where briefly Multicast packets pass thru network before they gets filtered eg. device that gets authorized to access other IP server then it works for that time until Idle or accessing app is restarted on wiFi Device. cause Multicast address range is reserved https://www.iana.org/assignments/multicast-addresses/multicast-addresses.xhtml and outside normal LAN/WLAN network enviroment.

Ludek

2019-01-03 14:40

developer   ~0051923

Last edited: 2019-01-03 20:59

View 5 revisions

To clarify:
MMW server announces itself
a) on start (restart)
b) as a response to multicast SSDP M-SEARCH request from MMA/Phone (like 192.168.1.101 -> 239.255.255.250:1900)

The issue observed by Peke/user from KTT-159-76825 is not the same issue as the (already fixed) issue observed by Martin B. , Petr and Michal in 0015000:0050979 , because the step of sleep/wake up is missing -- so increasing the "restart after wake up" timeout is not a solution here.
There are just workarounds like restarting MMW server (to make it announce), but we can hardly do this somehow periodically (I doubt that any other app does this). Another workaround could be for MMA to "remember" the MMW server (IP+port) and try to ping it after restart (if it fails to auto-discover).

It is possible that in case of KTT-159-76825 it is the IP isolation issue.
@Peke: maybe a remote session could shed some light on this? And then probably a KB article should summarize the findings.

Some tips to try:
https://merabheja.com/how-to-fix-network-discovery-in-windows-10/
https://www.ghacks.net/2018/04/17/fix-pcs-no-longer-recognized-in-network-after-windows-10-version-1803-upgrade/
Namely changing the “SSDP Discovery” service from "Manual" to "Automatic"

peke

2019-01-03 23:10

developer   ~0051929

As talked offline
as MMA already have saved settings for Sync Server it should be easy to access XML file directly first instead of SSDP M-SEARCH request to check Server availability and save time.
Resolving 0011780 would also help so that MMA Knows what server to ping/query depending on SSID.

To correct Dynamic IP changes (very rare now days, as for most router lease IP time is 2 days) Maybe after failed direct IP or even after SSDP M-SEARCH request connect to http://<SERVER_IP:PORT/Request Sync/ With header parameters Restart Server or like you pointed resolving 0014906. Similar to solution you use in chromecast discovery fails.

Also if there is no Sync/UPnP server found (first time sync/ UPNPBrowse) it could be useful to both MM5 and MMS (browser) that MMA is able to scan QR code #13912 as pointed in BUG MMA registers own Push protocol that can be used in any camera app to call MMA with settings parameter and do a quick configuration/access authorization and even Auto LOG sending.

peke

2019-01-03 23:11

developer   ~0051930

Reminder sent to: martin

Sent reminder to Martin due teh work needed in MMA.

Ludek

2019-01-04 18:51

developer   ~0051936

Last edited: 2019-01-04 19:20

View 5 revisions

Testing on my wife's Win10 machine now (1803 creators update) and I have still the same issue (I previously described it in 0015000:0050970). i.e. I am not seeing MMW server until I restart it while MMA searches for servers.
It isn't MM issue as I am not seeing any server from that Win10 machine.
Unfortunately the tips to set the related services to 'Automatic' start type (0015000:0051923) does not help. I haven't found anything useful yet, but looking further...
The strange is that I can see the Win10 server on Win7 PC, but don't see it in MMA
I talked to Martin via IM, he is going to implement the server "remembering" in MMA

peke

2019-01-04 18:53

developer   ~0051937

As talked offline when the SSDP M-SEARCH request fails to get response from server, entering http://IP:port/DeviceDescription.xml to address bar of Chrome always work. i.e. it is only the discovery issue as direct connection works?

Guess bit tweaking on MM side so that MM knows Discovery is down (custom header?) and resolving 0014906 on MMA side would help.

Ludek

2019-01-04 21:15

developer   ~0051940

Last edited: 2019-01-05 00:08

View 4 revisions

OK, I got it finally!

This is what worked for me:
1) Network reset: https://www.howtogeek.com/265870/how-to-reset-your-entire-network-in-windows-10-and-start-from-scratch/
2) Restart of PC
3) Upon connecting to my WiFi network it asked me whether I want to allow my PC to be discoverable by others PCs and devices, I clicked [Yes]
=> everything works as expected

My suspicious is that my wife clicked [No] in the past (when she was logging into our WiFi network)

peke

2019-01-05 03:34

developer   ~0051942

Last edited: 2019-01-05 03:42

View 2 revisions

Unfortunately Nothing changed for me.

QNAP is not listed in Network Only IP UNC path works and MMA can't find MMW Server unless MMW is restarted during Searching in MMA.

Note that I use Static IP Assignment.

Ludek

2019-01-07 10:29

developer   ~0051964

ok, did it ask you to allow your PC to be discoverable by others PCs and devices and you clicked [Yes]?
I suppose you have the network discovery ON on this screen: https://www.isunshare.com/images/article/windows-10/turn-on-or-off-network-discovery-in-windows-10/turn-on-or-off-network-discovery.png ?

Could you please add my "fix" with the network reset to the corresponding KB article(s) (as it solved my issue) ?
I also asked the user from KTT-159-76825 to try the "network reset" tip, so we will see whether it is going to help him.

Ludek

2019-01-11 16:10

developer   ~0052039

FYI: "Turn on network discovery" solution worked for the user from KTT-159-76825, while "Network reset" solution worked for me.
Could you please add both solutions to the corresponding KB articles?

peke

2019-01-25 01:51

developer   ~0052222

For me neither "Turn on network discovery" or "Network reset" solution worked for me. Attached Image of My settings.

bug15000.jpg (310,488 bytes)

peke

2019-04-14 19:05

developer   ~0053215

Partially improved/Fixed and rest is not fixable due teh Microsoft removed many NAME Services as of Windows 1101803 version.

More detailed description is at https://www.mediamonkey.com/forum/viewtopic.php?p=457630#p457630