View Issue Details

IDProjectCategoryView StatusLast Update
0014152MediaMonkey for AndroidPlaybackpublic2017-06-15 08:36
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.0 
Target Version1.3.1 
Summary0014152: Crossfading doesn't work
DescriptionAs reported at http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=87405 , crossfading doesn't work on an S7. Debug log at the forum report (but I've replicated the issue as well).

I've also found that crossfading doesn't work on a Nexus 5x running Android 7.1, or on an S5 mini running Android 6. In most cases it just has no effect, but in some casses (as with this log) the first track stutters just before it terminates, and then the next track begins.

Debug log: JBZAXQQ6KH

Note: the problem occurs whether using the external speakers or a headphone

Note: the bug doesn't occur on an honor 5x / huawei y6
TagsNo tags attached.
Fixed in build

Relationships

related to 0014033 closedmartin Playing 2 tracks at the same time (Crossfade) 
related to 0012889 closedmartin Playback sometimes gets into a state where crossfading doesn't work / MMA crashes  
related to 0013346 closedmartin Crossfading: Crossfading issues 
related to 0011907 assignedmartin Replace equalizer with 10-band equalizer 

Activities

martin

2017-04-12 17:20

developer   ~0047780

1)I can replicate it on my devices, S5 mini included.
a) I saw when crossfade starts then UI is refreshed with 1s delay - improved to build 691. Also added some debug logs.
b) Isn't it depending on track? I mean when track has silent on the end, then crossfade seems like not working by sound, but if track skips 5s before end, then it works.
If it really doesn't work, please generate new debug log with build 691, note track title and if you can, provide the track over FTP.

3)Re stuttering - Never happened to me, but maybe system is busy during track switching. If the issue persists, then try new option in Developer options "Disable debug logs". Let me know whether it helps.

rusty

2017-06-08 20:17

administrator   ~0048103

Re. stuttering, it doesn't appear to be helped by disabling debug logs:
Played '01_Why' on S5 mini --> stutter on transition to '05_Love and money'.
Debug log: S9S24W8RNH

Based on further testing, the issue seems related to file type:
M4A --> M4A : works
M4A --> flac: works
flac --> m4a: works
flac --> Mp3: works
MP3 --> MP3: fails
MP3 --> flac: fails
MP3 --> m4a: works

I've uploaded a couple of MP3 files that exhibit the problem to the ftp server, but as far as I can tell it occurs with all of my MP3 files.

martin

2017-06-14 15:17

developer   ~0048138

3) Does it stutter always on transition between '01_Why' on S5 mini --> '05_Love and money' or it happened just once?

1)Also can you send me debug log when crossfade fails and note track titles.
I am still not able to replicate it.

rusty

2017-06-14 17:20

administrator   ~0048139

3) Yes--it _always_ does a 'stutter'. By 'stutter' I mean
-5s track 1 plays
-4s track 2 plays
-3.5s track 1 plays for .5s
-3s track 2 continues playing

1) On the Nexus 5x the failure mode is slightly different. What happens is:
-5s track 1 plays
-4s track 1 suddenly stops and track 2 plays
i.e. the issue is that track 1 doesn't fade out and track 2 doesn't fade in

Debug log: 7NIU8GY5SM
note: Track 1 is '01_Why', Track 2 is '05_Love and money'.

martin

2017-06-15 08:35

developer   ~0048143

1)Re Nexus 5x - yes crossfade doesn't work on nexus, from log I can see onCompletion event is fired when next player starts in this case.
Some discussion about it
https://stackoverflow.com/questions/21894094/multiple-mediaplayers-do-not-work-on-nexus-5
This can be also cause of stuttering on other devices.
We talk about it long time ago in 0001666:0012889:c43100 , this issue cannot be fixed until we switch to an alternate player engine (feature 0011907)
This is why we marked crossfade feature as Beta.

The issue is device specific, because your provided mp3 tracks work on my devices.

Postponed until we realize 0011907.