View Issue Details

IDProjectCategoryView StatusLast Update
0013643MediaMonkey for AndroidPlaybackpublic2017-05-23 10:05
Reportermartin 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.0 
Target Version1.3.1Fixed in Version1.3.1 
Summary0013643: Provide more nodes via MediaBrowserServiceCompat (re. Android Auto)
DescriptionDue to 0013319 was implemented MediaBrowserServiceCompat in PlaybackService to provide tracks from "Now Playing" accessible from Android wear.
Same access has Android Auto app.
It would be useful provide other library nodes like "Playlists", "Albums", "Tracks" and others.
TagsNo tags attached.
Fixed in build700

Relationships

related to 0013575 closedmartin Support for Android Auto 
related to 0013319 resolvedmartin Android wear - NP list browser 
related to 0012102 closedmartin Compatibility with 'OK Google' Voice Music commands 
related to 0014201 resolvedmartin MMA stays active due to MediaBrowserServiceCompat 

Activities

martin

2016-11-15 09:37

developer   ~0046161

Improved to build 1.3.0.650
Added "Playlists" and "Now playing" nodes

rusty

2016-12-23 05:14

administrator   ~0046739

I think that's more than sufficient. What's more important in a car environment is that MM integrates well with the Google voice commands that are exposed via Android Auto.

martin

2017-01-04 18:25

developer   ~0046835

If there is no tracks in tracklist and no playlist, then some node to initiate playback would be useful. I have added "Play all shuffle" action to this list.
All Android music voice commands are supported by MMA.

Fixed in build 1.3.0.660

martin

2017-04-28 08:35

developer   ~0047863

Based on feedback at http://forum.mediamonkey.com/viewtopic.php?f=21&t=81866 along with features that are implemented on various other apps, we may want to implement the following improvements:

1) Support for browsing by additional Attributes.
a) Genre > GenreName >
All tracks
Artist1
Artist2
...

b) Artist (=Artist and Album Artist) > ArtistName
All tracks
Album1
Album2
...

c) Album > AlbumName

d) The order of the items should be: Play all (shuffle), Playlists, Genres, Artists, Albums, Now Playing

e) Note that as per https://www.google.com/design/spec-auto/audio-apps/drawer.html , the maximum number of items scrollable is 6 (in the US). If this is actually the case, we may want to allow the user to configure which subset of Playlists, Genres, Artists, Albums should be displayed. e.g.
Config > Android Auto:
Display items: _All_ [All, Recent, Top]
Choose which items to display in Android Auto.

Display items:
(o) All
( ) Recent - Recently played items
( ) Top - Top played items

Depending on what the user chooses, items in Android Auto will be listed as either e.g.
Playlists, Recent Playlists, Top Playlists
Genres, Recent Genres, Top Genres
etc...

btw, another approach could be to avoid the use of the config entirely and just add Most Popular and Most recent to the tree. e.g.
Most popular > Playlists, Genres, Artists, etc...
Most recent > Playlists, Genres, Aritsts, etc...
Playlists
Genres
Artists
...

martin

2017-05-04 12:05

developer   ~0047910

Last edited: 2017-05-04 12:16

View 2 revisions

Fixed in build 1.3.1.698

Also added optimization, when Genre contains only one Artist or Artist contains only one Album, then tracks are displayed directly.

martin

2017-05-04 12:09

developer   ~0047911

Most popular and Most recent auto-playlists related to
http://www.ventismedia.com/mantis/view.php?id=9600
will be realized to 2.0.

rusty

2017-05-16 15:50

administrator   ~0047979

Last edited: 2017-05-22 02:04

View 3 revisions

Seems to be working well.

One more feature that would be useful: in any view containing only tracks, if there are > 2 tracks, the first entry should be 'Shuffle all'. See https://www.mediamonkey.com/forum/viewtopic.php?f=21&p=435811#p435811

martin

2017-05-16 21:32

developer   ~0047981

Fixed in build 1.3.1.700

peke

2017-05-22 02:03

developer   ~0048003

As rusty pointed about shuffle button in https://www.mediamonkey.com/forum/viewtopic.php?p=435883#p435883

Some apps have shuffle button under ... https://postimg.io/image/t86h0iwqf/
Taken from https://www.mediamonkey.com/forum/viewtopic.php?p=434298#p434298

martin

2017-05-22 11:13

developer   ~0048004

Last edited: 2017-05-22 11:14

View 2 revisions

We have also "shuffle" button as on picture. This action enables shuffle playing of current "Now playing list".
The views with > 2 tracks contain "Shuffle All" action, which replaces tracks in "Now playing list".

martin

2017-05-23 10:05

developer   ~0048010

Fixed browsing on AndroidWear devices
in 1.3.0.700