View Issue Details

IDProjectCategoryView StatusLast Update
0013575MediaMonkey for AndroidPlaybackpublic2017-08-05 00:29
Reporterrusty 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0 
Target Version1.3.1Fixed in Version1.3.1 
Summary0013575: Support for Android Auto
DescriptionMMA tracks should be available for playback via Android Auto:
https://developer.android.com/training/auto/index.html
TagsNo tags attached.
Fixed in build702

Relationships

related to 0013643 resolvedmartin Provide more nodes via MediaBrowserServiceCompat (re. Android Auto) 
related to 0014201 resolvedmartin MMA stays active due to MediaBrowserServiceCompat 

Activities

martin

2016-11-15 09:37

developer   ~0046162

Fixed in build 1.3.0.650

martin

2017-04-28 08:36

developer   ~0047864

2) Improved voice controls
Currently voice controls are limited to parsing title, album, artists, album artists. We should add support for parsing Playlists and Genres.

Note: ATM, attempts to "Play 'X'" triggers playback in Google Play Music, unless the user indicates "Play 'X' in MediaMonkey". Is there any way around this?


3) Additional functions in the main player
a) Shuffle
b) Rating
d) Continuous

Possible implementation:
Primary screen: Metadata + Artwork
Primary card: Back, Play/Pause, Next (i.e. no change)

Secondary screen: Rating
Secondary card: Shuffle, Rating down, Rating up, Continuous

Note:
- This would only work if Android Auto can display the 5-star ratings on the secondary screen.
- For a track with no rating, first tap on Rating Up/Down would start at 3 stars

Another idea:
Primary screen: Metadata + Artwork
Primary card: Shuffle, Back, Play/Pause, Next, Continuous

Secondary screen: 5-stars (tappable for ratings)

martin

2017-05-10 13:24

developer   ~0047947

2) added Playlists and Genres
From my testing, user have to say "Play 'X' in MediaMonkey" for the first time, then also "Play 'X'" works.

3)
screen: Metadata + Artwork
main actions Back, Play/Pause, Next
additional actions: Rating up, Rating down, Shuffle, Continuous
we are not able to modify layout, so we can't show rating on screen

we can just define content(title, artist, albumArt) and specify actions.

So I implemented Rating Up/Down proprietary:

if (rating is not set) then
show UpRating(5) UpRating(3)
alse if (rating have 5 stars) then
show DownRating(3) DownRating(0)
else
show UpRating(+1) DownRating(-1)

Fixed in build 1.3.1.698

rusty

2017-05-11 13:06

administrator   ~0047952

I haven't tested all of the functionality, but there seem to be some regressions in build 698:

2) a) Play 'ArtistName'/'TitleName' in MediaMonkey works. Play 'AlbumName' no longer works. Play 'PlaylistName'/'GenreName' also doesn't seem to work.

b) Also, in cases in which it doesn't work, the the player controls stop working. e.g.
1 'Play TrackA in MediaMonkey' --> TrackA plays
2 'Play AlbumName in MediaMonkey' --> AlbumName doesn't play, but TrackA stops
3 Press the Play/Pause button to get TrackA to play --> Nothing happens!

3) a) Re. ratings: the functionality is a bit unclear. i.e. it's not clear what the current rating is nor what the left star does vs the right star; nor what the numbers mean. Suggestions:
- Is it possible to show the current rating in the background (e.g. superimposed on the Artwork?) and just have the icons without numbers, but with up/down arrows to indicate what they do? If that's not possible, then perhaps: indicate the current rating in both stars, but show an up arrow in the top right corner of one, and a down arrow in the bottom left corner of the other.
- Switch the functionality so that the right icon increases rating and the left icon reduces it (so that it's more consistent with how ratings work in MMA/MMW).

b) Re. the Shuffle/Continuous buttons, I think it would look cleaner (especially for the shuffle button), if there was no slash. i.e. use a Circle around the icon to indicate the active state.

4) Open MediaMonkey in AA > Click Playlists > PlaylistName
--> "MediaMonkey isn't working" error
--> User must exit AA in order to use MMA in AA

martin

2017-05-11 23:15

developer   ~0047958

Last edited: 2017-05-12 12:10

View 5 revisions

2)a)
At first it depends on android how understand your voice command, then it preprocess and assign "media focus" = {Album, artist, song, genre, playlist}
and values title, album, artist, genre, playlist (depends on focus)

Play 'AlbumName' - improved when Android evaluate query as SONG focus query, but no songs found, then searching in albums.

Play 'PlaylistName'
Play 'GenreName'
should work,
did you mean combination of 'PlaylistName' and 'GenreName' together?

If you have some missing combination or some voice command that doesn't work, send me your debug log. I will see how android evaluated query.


2)b) fixed;
3)fixed - stars with numbers and up/down arrows
4)fixed

Fixed in build 1.3.1.699

rusty

2017-05-16 15:22

administrator   ~0047978

Verified the following:
2b) Since 2a seems to be fixed, 2b is no longer replicable.
3a) Ratings seems better (still not pefect, but I can't think of a better alternative.
b) Verified.
4) Verified


The following is still open:
2a) Tried
i "Play 'Amelie' in MediaMonkey" --> "No track Emily found" (There is however an Album 'Amelie' that failed to play.
"Play 'All Rebel Rockers' in MediaMonkey" --> "No track All Rebel rockers found" (there is however an album 'All Rebel Rockers' that failed to play)

Debug log: XARK18FEBW

ii "Play 'Brothers in Arms' in Mediamonkey --> Track starts playing silently (surprising since the cases above both failed)! The silence problem is that MMA in Android Auto doesn't seem to have the logic to skip tracks in unsupported formats (the track is an APE track and skips in MMA)
Debug log T683LZKPNZ

iii "Play 'Mellow' in MediaMonkey" --> "No track Mellow found" (There is however a playlist 'Mellow' that failed to play.
"Play 'Mellow' playlist in MediaMonkey" --> "Not sure how to help with Play mellow playlist in MediaMonkey".
"Play playlist 'Mellow' in MediaMonkey" --> "Not sure how to help with Play playlist 'mellow' in MediaMonkey".

"Play 'Basketball game' in MediaMonkey" --> "No track 'Basketball game' found" (There is however a playlist 'Basketball game' that failed to play.
"Play 'Basketball game' playlist in MediaMonkey" --> "Not sure how to help with Play 'Basketball game' playlist in MediaMonkey".
"Play playlist 'Basketball game' in MediaMonkey" --> "Not sure how to help with Play playlist 'Basketball game' in MediaMonkey".

Debug log: S6R3913EYK

iv) "Play 'accoustic' in MediaMonkey --> "No track 'accoustic' found"
"Play 'accoustic music' in MediaMonkey --> "No track 'accoustic' found"
"Play genre 'accoustic' in MediaMonkey --> "No track 'genre accoustic' found"

Debug log: 3R95H4YJR7

5) Attempt to play something by voice control. e.g.
1 "Play 'accoustic' in MediaMonkey
2 Press 'Microphone button again' since no immediate response is forthcoming
--> Android auto appears with Voice control prompt
--> Android auto plays delayed "No track 'accoustic' found" from Step 1
--> Android auto attempts to interpret "No track 'accoustic' found" --> "I'm not sure how to help you with 'No track 'accoustic' found'"
I'm not sure if this is an MMA or Android Auto isssue.

martin

2017-05-22 16:50

developer   ~0048005

2
i) "Play 'Amelie' in MediaMonkey" --> yes, this is issue because Android heard "Emily", so MMA received "Emily" as query. We are not able to identify that you are not searching "Emily".

iii)
"Play 'All Rebel Rockers' in MediaMonkey"
"Play 'Mellow' in MediaMonkey"
"Play 'Basketball game' in MediaMonkey"
 --> improved to next build, queries in this cases have "in MediaMonkey" is added as suffix. I think that "in MediaMonkey" user have to say just for first time. MMA will trim it before searching in next build.

Re "Play xxx playlist in MediaMonkey" and response "Not sure how to help with Play playlist 'Basketball game' in MediaMonkey":

If you hear "Not sure how to help with...", it means that system does not recognized command and searching is not executed. It's quite device/system version specific how recognization is successful.

From my testing command 'Play "Favorite" playlist in MediaMonkey' was successful and searching was executed, but MMA received query "Favorite playlist" and focus was for "SONG". I have improved it on MMA side to remove "playlist" suffix/prefix of query and searhing in playlists has more priority than songs.

iv)
First two cases of genre searching were successfully identified by system as genre='Acoustic', mMediaFocus=SEARCH_GENRE, but tracks in MMA have genre=Accoustic (two 'c' letters), this is reason why no tracks were found.
Third genre searching was evaluated as query='genre acoustic in media monkey' and mMediaFocus=SEARCH_SONG
It seems to me that say command without "genre" has better results.
improved to trim query to "acoustic" in this case.


ii)Weird - I am testing it.

5)
"No track 'accoustic' found" is text defined on MMA side and played as Text To Speech
to notify user about unsuccessful search. I think it's good to have it.
The issue is on system side, that due to delay system accepts "voice output" as input.

martin

2017-05-22 17:19

developer   ~0048006

Last edited: 2017-05-22 17:20

View 3 revisions

Re 2 ii)Also from MMA alac m4a tracks plays silently no error to detect it.
Can re-test behavior on MMA side?

rusty

2017-06-11 17:25

administrator   ~0048116

Tested 701.

2)

a)i) Playing Albums generally seems to work in build 701. However:
'Play Chocolat Soundtrack' (an album that contains 2 tracks)
--> 'Here you go. Asking to play Chocolat Original Motion Picture Soundtrack'
--> Debug log NTBF6M2YPX
This occurs consistently with the Chocolat soundtrack, though playing it via the MMA:AA menu works fine.

ii) In build 701, 'Play Brothers in Arms in MediaMonkey' --> debug logs uploaded:
3BC72VCYI2

iii) Playing playlists works now.

iv) Play acoustic still fails (due to the spelling error), but 'Play <CorrectlySpelledGenre>' works.

5) This issue is no longer reproducible in 701.

6) Sometimes the player just switches to Google Play Music
e.g.
1 'Play the beatles in MediaMonkey'
--> Tracks by the beatles play in MMA

2 'Play the beatles'
--> Tracks by the beatles start playing in Google Music!!

Note this problem occurs with other third-party players as well, so I'm not sure if there's anything we can do about it. Any ideas?

6) Crash when using 'Shuffle all' with playlists
1 Click MediaMonkey > Menu > Playlists > New Downloads (a static playlist) > Play all shuffle
--> Debug logs have been uploaded!!
2 Click the MMA:AA menu button > Back (in order to go a level higher than the playlist)
--> The menu closes (instead of going up a level to the Playlists menu)! The only way to resolve this is by exiting MMA:AA and then restarting it.

7) Sometimes 'Now Playing' doesn't appear as an option in the menu list. e.g.
1 'Play ebony day in MediaMonkey' (ebony day is an artist with 3 tracks)
--> Tracks start playing
2 Click 'Menu' button in MMA:AA
--> Play all shuffle, Playlists, Genres, Artists, Albums appear. Now Playing is missing!!

8) Sometimes clicking an Artist or Playlist
--> 'Getting your selection'
--> after ~15 seconds 'Something went wrong'
Debug log: U4UUE6HR4X

martin

2017-06-13 13:05

developer   ~0048134

2)i) and ii) fixed
6)yes the issue on Android Auto side, nothing we can do.
7)Also this is issue on Android Auto side. "Now playing" node is added automatically (unlike the other nodes) when playback starts. Unfortunately there is some refreshing issue, because when you browse some node and return back the "Now playing" node appears.
8)improved

martin

2017-06-13 13:06

developer   ~0048135

Fixed in build 1.3.1.702

peke

2017-08-05 00:29

developer   ~0048471

Verified 720 Suzuki Vitara 2017