View Issue Details

IDProjectCategoryView StatusLast Update
0012927MediaMonkey for AndroidGeneralpublic2016-02-10 18:50
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.1.3 
Target Version1.1.3Fixed in Version1.1.3 
Summary0012927: 'Grant access' dialog is confusing and seems to be never ending
DescriptionThe Grant Access dialog currently displays:

Grant Access
MediaMonkey needs access to the following folders in order to sync or edit media content within:
SD card:
/directory 1/
/directory 2/
...

Without access to these folders, MediaMonkey will sync content to an application-specific folder on the SD card that will be deleted when MediaMonkey is uninstalled. It will also be unable to edit/sync any content in SD card folders such as /Music/ that are shared with other media applications.

[ignore] | [continue]
-------------------------------------------------------------------------------
After the user [selects] a folder/location in the system chooser dialog, then the grant access dialog again displays:

Grant Access
MediaMonkey needs access to the following folders in order to sync or edit media content within:
SD card:
/directory 1/
/directory 2/
...

Without access to these folders, MediaMonkey will sync content to an application-specific folder on the SD card that will be deleted when MediaMonkey is uninstalled. It will also be unable to edit/sync any content in SD card folders such as /Music/ that are shared with other media applications.

 [continue]
-------------------------------------------------------------------------------

The usability problem that many users are experiencing is that after they [select] a folder, and the dialog re-opens almost exactly as before it appears to them that the permissions change that they made did not successfully complete. This is because:
a) There's no visual feedback in the dialog indicating that a change in permissions occurred--in fact the re-appearance of the dialog _as is_ implies to the user that the action failed.
EDIT: In fact when permission is granted, the entry in question is removed. I need to retest why I didn't notice this.
 
b) There's no way to exit the dialog--the user is forced into a loop of repeatedly enabling access
EDIT: In fact the dialog does exit after all required permissions have been granted. I need to retest why I didn't notice this, and why users aren't successfully navigating this.

The following simple changes would solve this:

Grant Access
MediaMonkey needs access to the following folders in order to sync or edit media content within:
SD card:
/directory 1/ [access granted]
/directory 2/ [access needed]
...

Without access to these folders, MediaMonkey will sync content to an application-specific folder on the SD card that will be deleted when MediaMonkey is uninstalled. It will also be unable to edit/sync any content in SD card folders such as /Music/ that are shared with other media applications.

 [Grant new permission] [Done]
-------------------------------------------------------------------------------

By displaying status next to each folder, the user is made aware of whether action is required on his part.

By changing the 'Continue' button to 'Grant new permission' and 'Done', it becomes clear to the user how to complete the activity.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82699
TagsNo tags attached.
Fixed in build545

Relationships

related to 0012918 resolvedmarek SD Card access fails 
related to 0012299 resolvedmarek Improved external storage handling on Android L 
related to 0012828 resolvedpeke Warn user that Destination folder is not cleared for writing and that default location will be used 
related to 0012919 resolvedmarek Playlists are getting deleted on upgrade to 1.1.3 for some users 
related to 0012938 resolvedmarek SD Permissions should be granted during the sync configuration process 

Activities

rusty

2015-10-29 17:20

administrator   ~0043204

Last edited: 2015-10-30 15:08

View 3 revisions

Upon further discussion with marek, we came up with the following:

1)a) Change the dialog to:
Grant Access
MediaMonkey needs access to the following folders in order to sync or edit media content within:
<Storage location>:
/directory 1/ ['granted' or checkmark to indicate complete]
/directory 2/ ['access needed' or x to indicate incomplete]
/directory 3/ ['must be created' or x to indicate incomplete]
...

Please proceed by giving MediaMonkey access to <storage location>. Advanced users can create and grant access to the individual folders directly.

[Grant access...] [Skip]
------------------------------------------------

b) First time [Grant access...] is clicked: hint sheet appears (as is already the case)
. . - The hint sheet should be simplified so that it describes the simplest case of granting access to the SD Card (rather than individual directories within)
c) If access is granted to some required directories, then the above dialog re-appears, updated as appropriate
d) If access is granted to all required directories, then MMA goes directly to the home screen/previous screen (as is already the case--though some users are indicating that it is not the case, though I can't replicate).
. . - Once access is granted to required directories, MMA automatically creates any missing directories (??TBD??)
e) If the user clicks 'skip' (because he/she doesn't want to grant access to all directories at that time), the following dialog should appear:
"If access isn't granted to the requested folders:
- MediaMonkey won't be able to edit/sync content to those folders!
- Content will instead be synced to a MediaMonkey-specific folder, but it will be deleted when MediaMonkey is uninstalled!
- Content synced to a MediaMonkey-specific folder will not be editable by other music players!
[Grant access...] [OK]"

2) When the 'Grant Access' dialog appears following sync configuration, it would be preferable if:
a) it were to appear at the end of the configuration process (rather than upon synchronization
b) if it would prompt for permissions to all folders that appear in the sync profile so that the user doesn't have to reconfigure permissions depending on what has been synced

3) We should also make a simple change re. Choose library folders.
a) The hint should change from:
Choose which folders to include in the media library.
to
Choose and grant access to folders to include in the library.
b) If access has already been granted to the entire SD card, then the folder chooser should be the regular MMA version (rather than the Android system chooser).

marek

2015-10-30 20:35

developer   ~0043207

Fixed in build 494

1) a) I have added outlined "!" icon instead of "X" because it looked like close button.

rusty

2015-11-01 03:28

administrator   ~0043218

Tested build 494 and it's much improved. A few issues remain:

1a) Minor changes:
MediaMonkey needs access to the following folders in order to sync or edit media content within:
-->
MediaMonkey needs access to the following in order to sync or edit media content within:

Please proceed by giving MediaMonkey access to <storage location>. Advanced users can create and grant access to the individual folders directly.
-->
Please proceed by giving MediaMonkey access to '<storage location>'. Advanced users can create and grant access to the individual folders directly.

1)b)
i) Currently the hint screen is displayed _every_ time the user attempts to grant access, which is annoying if the user wants to enable 3 different directories. I would suggest that it should only appear once each time that dialog is opened.

ii)
x) On the hint screen
Tap 'SELECT' to entire SD Card
-->
Tap 'SELECT' to grant access

2) The 'Grant access' dialog doesn't appear after exiting the sync config process. What seems to occur is that after the sync config is complete and MMA is restarted, the Grant access dialog appears. Can you clarify how it's been implemented or how it's supposed to work?

marek

2015-11-02 22:56

developer   ~0043231

1)
a) fixed
b) fixed. The dialog is not displayed only when user successfully grants access to one of listed paths.
c) Toast message added when granted path is not listed.
d) On click on ungranted path -> show hints/dialog
e) On click on granted path -> show toast message, that it is already granted.

2) Grant access dialog is not shown during sync setup. It is shown when wifi sync is started and the permission is needed. It is also shown on application startup.

Maybe we can add it to sync wizard that is planned for 1.2.0. (0011982)

marek

2015-11-02 22:56

developer   ~0043232

Fixed in build 495

rusty

2015-11-03 03:57

administrator   ~0043234

Last edited: 2015-11-03 06:41

View 3 revisions

1) Verified 495.

2) Wouldn't it be easy to display the 'Grant access' dialog/workflow if the user clicks the Sync config / SD Card, when sync status=never ? If it's risky/too much work, then we can push it off, but it seems like a much more logical workflow and that it doesn't really need to be tied to a UI redesign.

e.g. user decides to sync to SD card --> if user has never synced and access to required folders is missing, then user is prompted to grant access, and after doing so, goes on to configure sync operations.

I'll track this in a new bug.

rusty

2016-02-10 03:33

administrator   ~0044102

I noticed a minor grammatical issue:
Please proceed by giving MediaMonkey access to <storage location>.
-->
Please proceed by giving MediaMonkey access to '<storage location>'.

marek

2016-02-10 11:51

developer   ~0044111

Fixed in build 545

rusty

2016-02-10 18:50

administrator   ~0044115

Verified 545.