View Issue Details

IDProjectCategoryView StatusLast Update
0012918MediaMonkey for AndroidDBpublic2015-11-16 10:23
Reporterlowlander Assigned To 
PriorityimmediateSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version1.1.3 
Target Version1.1.3Fixed in Version1.1.3 
Summary0012918: SD Card access fails
DescriptionUsers are reporting issues with granting access to SD card from MMA, and are consequently losing access to their music collections.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82699
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82740

ICS-605-23678
TagsNo tags attached.
Fixed in build502

Relationships

related to 0012919 resolvedmarek Playlists are getting deleted on upgrade to 1.1.3 for some users 
related to 0012927 closedmarek 'Grant access' dialog is confusing and seems to be never ending 

Activities

rusty

2015-10-28 17:47

administrator   ~0043200

Last edited: 2015-10-29 13:23

View 2 revisions

Note: it's unclear whether there's a functional problem here, or whether this bug is a combination of:

1) 0012927 : The 'grant' access dialog is confusing (doesn't give feedback re. whether permissions have been granted, makes it appear as if they haven't been granted, and puts the users into a loop of granting access repeatedly).

2) 0012924 : Device content fails to scan

I suggest fixing the above 2 issues and then we'll be able to see whether there's also a functional problem with the granting of access.

EDIT: Based on feedback at http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82699 , it appears that there _is_ a functional problem as well.

marek

2015-10-31 15:35

developer   ~0043208

Last edited: 2015-10-31 15:36

View 2 revisions

Fixed in build 494

It was caused by refresh method for refreshing folders that deleted all folders - and this triggered deletion of all media !!!

I will discuss it with Martin to replace this method with something else.

marek

2015-11-02 21:42

developer   ~0043230

Fixed in build 495

Hopefully ok. We should test the DB after permission is added. Folder hierarchy should be tested too - how refreshed.

Steps to reproduce:
1. Clean install, no permissions
2. Wifi sync
3. Add permission for e.g. Music

rusty

2015-11-03 05:28

administrator   ~0043235

Last edited: 2015-11-03 05:28

View 2 revisions

No regressions observed in build 495. Peke will touch base with Marek in the morning to better understand what exactly to verify.

rusty

2015-11-05 17:22

administrator   ~0043251

Apparently, this isn't completely resolved. See:
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82699&start=15#p415970

User in play store also indicated sync problems with the new build.

marek

2015-11-06 14:01

developer   ~0043252

Last edited: 2015-11-06 14:48

View 2 revisions

I have found one regression and I have added more logs for the case that were reported on forum.

Btw. this behaviour has to be retested:

Steps to reproduce:
1. Clean install, no permissions
2. Wifi sync
3. Add permission for e.g. Music

I have implemented completely new service for moving the media that is more robust. So it has to be well tested.

Fixed in build 497

marek

2015-11-06 21:44

developer   ~0043254

I know that this issue was verified but I had to completely replace the service that move files from app specific folder to sd card

e.g. from /Android/data/com.ventismedia.android.mediamonkey/files/Music/ to /Music/

1. When you do new install (after uninstall), mediamonkey doesn't have permission to write on sd card so it have to write to app specific folder. So start app and skip adding permission.

2. Start wifi sync. Skip permissions again. Sync anything. The content should be synced to app specific folder!

3. Now go to Options->Grant access and add some permission. You can try just /Music or whole sd card as various use-cases

Now the mentioned service for moving files is started on background and move all files from app specific folder to permitted folder. Also DB has to be updated.

There is a difference between implementation in 496 and 497. I had to rework it because 496 worked with all moved media in one batch and when one track failed to move, DB was not reverted for this track so it broke the links between DB and files on storage. Now each track and playlist is processed separately. It is much more robust.

After this service finishes:
 a. Tracks should be moved correctly - should be playable and visible in library
 b. Playlists should be moved correctly (if permitted)
 c. Artworks should be moved and visible (for both tracks and albums)

peke

2015-11-07 01:29

developer   ~0043255

Verified 497 Below steps worked

3x on Moto G LTE v5.1

1x on Nexus 7 v5.1.1 for regressions

marek

2015-11-07 23:29

developer   ~0043257

Last edited: 2015-11-07 23:32

View 2 revisions

In build 498:
It looks like we cannot obtain UUID of storages on some devices that is necessary for using SAF on lollipop. So I will try to find new way how to find the UUID.

In build 498 these devices will behave the same way as with Kitkat...i.e. no permission model, all content are stored to app specific folders on sd card.

Currently observed on:
HTC One M8 with Android 5.0.1

rusty

2015-11-10 03:24

administrator   ~0043271

Last edited: 2015-11-10 21:39

View 4 revisions

Users of the G4 confirmed that the fix worked, but for some other devices, the solution/workaround isn't working.
HTC One M8: Ticket RUB-786-43900 / http://www.mediamonkey.com/forum/viewtopic.php?f=26&t=82909
HTC One M8: http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82914
Samsung Note 3: http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82882

marek

2015-11-16 10:23

developer   ~0043313

Fixed in build 502

Fixed usb sync as 0012960