View Issue Details

IDProjectCategoryView StatusLast Update
0011564MediaMonkey (current)Synchronizationpublic2013-12-11 09:42
ReporterLudek 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1Fixed in Version4.1 
Summary0011564: Hierarchical playlist sync is broken over USB
DescriptionWhen syncing hierarchical playlists (A is subplaylist of B) from MMW -> MMA then they are synced on the same level.

This must be a regression.
TagsNo tags attached.
Fixed in build1678

Relationships

child of 0011016 closedLudek USB Sync: Renaming playlist yields strange confirmations 

Activities

Ludek

2013-12-09 16:08

developer   ~0038607

This looks like a problem on MMA side, what is the worse, it creates playlist where its _id = parent_id.

Such a playlist is not visible in MMA, but MMW still see it in database and sync fails because of this. The only way how to delete the playlist is to delete mmstore.db file re-install MMA !!

Ludek

2013-12-09 16:42

developer   ~0038611

In MMA build 194 was added DB constraints so the dummy playlist referencing itself as parent no loger exists, but all playlists are still on the same level although MMW writes the level info correctly.

Ludek

2013-12-09 16:47

developer   ~0038612

Last edited: 2013-12-09 16:50

View 2 revisions

Hmm, further testing shown that MMA was confused by a missing info.
MMW has not write playlist._data (M3U path) for the parent playlist and consequence was this issue.

MMW also fails to write tracks of the parent playlist.

Ludek

2013-12-09 17:03

developer   ~0038613

Fixed in build 1678.

peke

2013-12-11 09:42

developer   ~0038690

Verified 1680