View Issue Details

IDProjectCategoryView StatusLast Update
0011516MediaMonkey for AndroidTrack Browserpublic2014-10-02 02:11
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version1.0.4 
Target Version1.0.7Fixed in Version 
Summary0011516: Handling of upper/lower case isn't consistent with MMW
DescriptionHandling of capitalization is inconsistent between MMA/MMW:

1) In MMW, if the user edits the case of metadata, then the metada is modified, but the category to which it belongs remains unchanged (e.g. if for a single track Rock is changed to RocK, then the track still remains within Genre=Rock).

In contrast, if MMA has multiple tracks, some categorized as 'Rock' and others as 'RocK', then multiple categories result.

note: my preference is that Rock and RocK should be separate categories, so a possible fix would be to change the behavior in MMW.

The effect of this during synchronization is that tracks synched from MMA will sometimes end up displaying differently in MMA than in MMW since MMW hides case errors, whereas MMA doesn't.

I don't think that this is a really nasty bug, I've set it to 'urgent' for triage in case you can think of other deleterious side effects that I haven't observed (keep 0001412 in mind as well--MMW automatically changes capitalization of tracks added to the library in some cases, to match the capitalization of tracks already in the library).
Additional InformationReported at: http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=74488
TagsNo tags attached.
Fixed in build

Relationships

related to 0001412 feedbackjiri MediaMonkey (current) Changed capitalization not recognized in some cases and is inconsistent with MMA 

Activities

jiri

2013-11-27 08:53

administrator   ~0038395

Seems that leaving this as is in MMA makes sense and that MMW could be modified according to 0001412.

rusty

2013-12-18 07:45

administrator   ~0038813

Re-opening for review in 1.05.

rusty

2014-10-02 02:11

administrator   ~0040675

I agree--this should be fixed in MMW.