View Issue Details

IDProjectCategoryView StatusLast Update
0011446MediaMonkey (current)Properties/Auto-Toolspublic2013-12-22 21:17
Reporterpeke 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1Fixed in Version4.1 
Summary0011446: Metadata: MMW ignores info from ID3v1 even if ID3v2 is missing info for same Tag field
DescriptionIf Artist Metadata is missing in ID3v2 but it exists in ID3v1 MMW should Fill the missing data fom ID3v1 when scanning files.
Additional InformationDVM-718728
TagsNo tags attached.
Fixed in build1670

Relationships

related to 0011757 resolvedpeke Podcasts tagged by MM not shown in Subsonic 

Activities

peke

2013-11-04 01:37

developer   ~0038161

Sample File is in Support Ticket

michal

2013-11-04 13:29

developer   ~0038168

The problem is not in ignoring ID3v1, we read it, but there is something with the file, that is causing, that reading tags fails (the file contains ID3v2.3 with all the info, that should be read). Problem is somewhere in ID3lib, the same problem has MediaMonkey for WinRT. I will debug it.

peke

2013-11-04 23:37

developer   ~0038181

You are right all info after Album Art (APIC) is not added.

michal

2013-11-05 13:05

developer   ~0038185

Last edited: 2013-11-05 15:31

View 2 revisions

Fixed in build 1670. The file has non standard size of POPM frame and we did not use size from the frame header. Now we do.
I recommend more testing of MP3 tag reading, it was quite dangerous change.

peke

2013-11-08 13:53

developer   ~0038240

Verified 1670 on 21k+ of imported MP3 tracks and have not found any regressions. It should be closed after second verification due the nature of fix.

peke

2013-12-22 21:17

developer   ~0038983

Verified 1682