View Issue Details

IDProjectCategoryView StatusLast Update
0011331MediaMonkey for AndroidGeneralpublic2013-10-04 20:26
Reporterrusty Assigned To 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionduplicate 
Product Version1.0.4 
Target Version1.0.4 
Summary0011331: Album Artist field appears corrupted for tracks where Artist |= Album Artist
DescriptionIn build 167, all albums for which Artist =| Album Artist seem to be overwritten.

In most cases, the Artist has been assigned to the Album Artist field (e.g. Various is changed to The Bangles, if the Artist for the track is The Bangles), but in some cases, the Album Artist field for all tracks on an album are changed to the Artist of _one_ of the tracks on the Album (e.g. for the Album "Garden State" the Album Artist field is changed from Various to Simon & Garfunkel, who are the Artists for one of the tracks on the Album).

I'm not sure whether this is a sync bug, but I can confirm that:
- the Properties as verified in MMA have actually been modified, so it's not just a presentation bug of the Track Browser
- when syncing with bidi sync enabled, the incorrect Album Artist metadata isn't synced back to MMW, but neither is the correct metadata synced to MMA.

Test note: once fixed, verify that Artists/Albums/Tracks filter works correctly for albums that are a) missing either Artist or Album Artist b) have Artist |= Album Artist
TagsNo tags attached.
Fixed in build

Relationships

duplicate of 0011319 closedmarek Albums have "Unknown artist" as album artist after USB sync 
related to 0010756 closedmartin Missing album art for Various Artist / Compilation Albums 

Activities

marek

2013-10-03 19:23

developer   ~0037744

I cannot reproduce it. I have tested with 20 different albums synced over wifi and everything seems to be ok. I assume that you don't use USB sync because there was another issue with album artists (http://www.ventismedia.com/mantis/view.php?id=11319).

This will be probably sync bug. Could you please create a log. Please use as short synclist as possible (e.g. only one album will be synced with MMW) so I will see whole synclist messages in log. Thanks

rusty

2013-10-04 03:11

administrator   ~0037749

Actually, I tested by syncing first via USB, and subsequently via Wi-Fi.

When I sync only via Wi-Fi, the issue doesn't occur.

So this is most likely a dup of 0011319