View Issue Details

IDProjectCategoryView StatusLast Update
0009286MediaMonkey (current)Synchronizationpublic2012-06-06 17:55
Reporterlowlander 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0.5 
Target Version4.0.5Fixed in Version4.0.5 
Summary0009286: iPod Touch iOS5 sync fails for some tracks
DescriptionSync of files to iPod Touch seem to fail. Files don't play in MediaMonkey or iTunes, and the iPod itself still shows old removed files.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=65699
http://www.mediamonkey.com/forum/viewtopic.php?p=336955#p336955
http://www.mediamonkey.com/forum/viewtopic.php?p=336981#p336981
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=65656
TagsNo tags attached.
Fixed in build1486

Relationships

related to 0009301 closedLudek Newly synced tracks to iOS devices can't play in MediaMonkey until refresh 
related to 0009302 closedLudek iOS Synchronization starts and then stops after one or two songs for some users 
related to 0009308 closedLudek iOS5: Sync doesn't terminate when storage is full 

Activities

lowlander

2012-04-23 14:58

developer  

ipodsyncfail.zip (124,792 bytes)

lowlander

2012-04-23 21:14

developer  

ipodsyncfail2.zip (268,213 bytes)

lowlander

2012-04-23 21:15

developer   ~0030883

Last edited: 2012-04-23 21:41

View 2 revisions

ipodsyncfail2.zip another failed sync that froze iPod Touch on opening of Music App. iPod Touch is now stuck on loading icon (I guess it restarted), but has been there for 25 minutes now.

Ludek

2012-04-23 23:40

developer   ~0030889

Last edited: 2012-04-23 23:42

View 2 revisions

Martin, you wrote that MediaMonkey and iTunes can sync to this device on other PC, and that the failure occurs on Win2003 for which iTunes isn't support, so does it mean that iTunes sync does not work on the PC?

lowlander

2012-04-24 15:42

developer   ~0030901

I have had successful syncs to the iPod Touch on Windows Server 2003. This was with a single small playlist after I connected it to iTunes on Windows Server 2003.
The fact files were not working with some syncs could have been: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=65755

Can't verify as the device is still not working.

lowlander

2012-04-25 02:18

developer  

iPodTouchSynciOS5.1 Fail1.zip (1,018,197 bytes)

lowlander

2012-04-25 02:37

developer  

iPodTouchSynciOS5.1 Fail2.zip (469,130 bytes)

rusty

2012-04-25 17:11

administrator   ~0030915

Last edited: 2012-04-25 17:32

View 2 revisions

I'm testing with Win7 and am finding that most tracks sync correctly, though a small subset will sync and then not be able to play in either iTunes (on the device) or in MediaMonkey (when attempting to play from the device).

Interestingly, when I delete all tracks from the device via MM (via autosync of 0 tracks, with deletion enabled), the tracks that could not play don't get deleted--i.e. a bunch of useless entries remain on the iOS5 device. Syncing a single track via iTunes gets rid of all of these entries.

lowlander

2012-04-25 21:47

developer   ~0030918

Note that for me often no tracks are playable. They show in MediaMonkey/iTunes, but fail to play and normally fail to show on the iOS5 device altogether. Doing an iTunes sync (no media files) will show all files on device, but all show grey and none are playable.

Ludek

2012-04-25 22:06

developer   ~0030919

Last edited: 2012-04-25 22:07

View 2 revisions

I found some repro steps with 1483 and it seems to be a regression (1482 works).

The steps are:
Run 1483, select a files under iPhone->Music in MM interface and try to delete a file. The file is deleted, but subsequent sync operations don't work unless MM is restarted. If you don't delete anything then the sync works.

Ludek

2012-04-25 22:19

developer   ~0030920

Finally I was able to find the root of these problems, fixed in 1484.

rusty

2012-04-26 19:51

administrator   ~0030930

Numerous users have indicated that they're still experiencing problems with build 1484. In my testing with 1484, I've found that the vast majority of tracks do sync correctly (even those that appear not to when navigating the iPod Touch via MM), but a small percentage (e.g. 2%) will skip on the iPod Touch (i.e. the track appears in the DB, but is skipped on playback. The really strange thing is that pressing the 'back' button can sometimes get such tracks to play.

lowlander

2012-04-27 03:05

developer   ~0030950

On 1484 1452 songs are on device according to MediaMonkey, but only 293 according to the iPod Touch. Furthermore only some Playlists show on device. Some of the files that are shown show greyed on device. Debug log attached.

rusty

2012-04-27 04:07

administrator   ~0030952

Last edited: 2012-04-27 05:17

View 2 revisions

Another debug log with 1484 at http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=65799#p337166

Note also, as I've been testing I'm finding that in addition to not all tracks being synced and some that are synced not playing successfully, some Playlists are not synced.

Ludek

2012-04-27 21:24

developer   ~0030961

Fixed in build 1485.

Ludek

2012-04-27 21:44

developer   ~0030962

Last edited: 2012-04-27 22:42

View 5 revisions

Re-opening, there are still some issues for specific groups of tracks.

i.e. I have successfully synced 530 tracks, but another 640 has failed and the synchronization has been unexpectedly terminated.

Ludek

2012-04-27 22:16

developer   ~0030963

Last edited: 2012-04-27 22:48

View 2 revisions

Aha, that was for tracks with missing title.

Fixed in 1485.

lowlander

2012-04-29 21:56

developer   ~0030965

1485 is much improved. Playlists are there and a much higher percentage of songs are shown on the iPod Touch, but some are still missing. MediaMonkey reports 278 files on the Car Playlist whereas the iPod reports 213. Debug log available in above link.

rusty

2012-04-30 04:00

administrator   ~0030971

Last edited: 2012-04-30 04:08

View 2 revisions

As far as I can see 1485 works correctly _except_ that it fails to correct the iPhone's db for tracks that have been synced via early 4.0.5 builds.

e.g. sync with build 1483, then sync with 1485
--> some of the tracks that appear on the device via the MM interface, but not via the iTunes interface are those that were synced in build 1483.

The only way to get rid of such 'phantom' entries is to a) delete all tracks from the device in MM
--> The tracks appear to have disappeared from within MM, even though unplayable tracks/playlists remain on the the device (as evidenced via the device ui)
b) sync a single track via iTunes.
--> All the 'phantom' tracks/playlists from build 1483 are deleted from the device

Once the above steps are taken, all sync operations seem to work as expected. In other words, the main item remaining to be fixed (at least based on my testing) is for MM to properly update the device vis a vis tracks/playlists synced via earlier 4.0.5 builds.

Lowlander, can you confirm whether this is the case for you as well?

note: one other scenario I haven't yet tested is to sync with MM on a device that has previously been synced via iTunes with more than 1 track.

lowlander

2012-04-30 18:54

developer   ~0030976

Unfortunately not. I followed the instructions of removing files from device, sync single file in iTunes. The next sync in MediaMonkey shows 1513 files on device in MediaMonkey and 997 songs on device (1 file is video). Non of the Playlists show on device. Second log added.

rusty

2012-04-30 22:42

administrator   ~0030979

Note: with build 1485, after syncing 200 tracks + videos with iTunes, syncs with MM fail (i.e. many tracks synced with MM don't play, and #tracks in MM don't match to #tracks on the device). Strangely, the Songs category on the iPod Touch shows Downloading 2 of 3...--no idea why...

Ludek

2012-05-01 10:18

developer   ~0030980

Last edited: 2012-05-01 13:36

View 6 revisions

@Lowlander, where is the log added? I can't see it attached.

BTW. I have reproduced something like this if I wanted to sync tracks over the device capacity (if there was unsufficient space). iTouch reported that storage is almost full, but MediaMonkey still continued to copy tracks that finally didn't appear on device although in MediaMonkey they were visible. Was this your case?
Tracked as 0009308

@Rusty, could you also generate a debug log (as I was unable to reproduce) and ensure that it is not the 0009308? Also make sure that you didn't run iTunes and MediaMonkey simultaneously as MediaMonkey caches device database localy and can result in a conflict with iTunes.

lowlander

2012-05-01 16:16

developer   ~0030984

I'm not oversyncing the device and after sync the device report 15GB free space.

rusty

2012-05-01 17:40

administrator   ~0030986

Last edited: 2012-05-01 17:47

View 2 revisions

I'm no longer able to replicate this, but I suspect that you're right that it may have been caused by running MM and iTunes simultaneously--on one occasion while disconnecting the iPod Touch, it reconnected accidentally and for some reason, triggered iTunes to launch (it doesn't normally--the option is disabled in iTunes).

The real question, though, is why can't MediaMonkey get such a device out of that messed up state? Why must I delete all content in MM, then sync 1 track in iTunes to get the database into a state in which MM's rendering of the DB matches iTunes' (on the device)?

Ludek

2012-05-02 08:29

developer   ~0030987

Last edited: 2012-05-02 12:56

View 6 revisions

@Rusty, I have done something about it in the course of 0009310 , all tracks that are presented in MM, but are not physically on the device are deleted from the device database (and MM) during device scanning process in build 1486.

@Lowlander:
In the log I see that after one hour of syncing the device stopped communication with us and no longer comunicated, in the log it is line
iPhone: init_communication(): -1
and then
AMDeviceStopSession (thread 4784): Could not stop session with device: kAMDUndefinedError

I wonder why the init of communication fails, there are two possibilities
a) it was a random failure and maybe related to a 1 hour timeout?
b) it was related to a particular file (in previous communication we sent something that the device doesn't like)

In both cases I should implement (and implemented) a mechanism to restart the communication in case of such a failure (fixed in build 1486)

As for the b) - I see in the log that in that time it synced files like
\\lowlander01\Qmultimedia\Music\N\Nickelback\[2011] Here And Now\Nickelback - 03 - When We Stand Together.flac
\\lowlander01\Qmultimedia\Music\A\André Rieu\[2002] Love Around The World\André Rieu - 01 - The Old Castle.flac
converted from FLAC to M4A
Could you try to re-sync these files (in 1486) to see whether it could be somehow related to particular files? But it looks more like a)

lowlander

2012-05-04 04:02

developer   ~0031012

Last edited: 2012-05-04 04:35

View 2 revisions

1486 is nearly perfect. All Playlists are shown, most Playlist show same track count on device and MediaMonkey. 2 Playlists have a difference, Spanish has 49 on device, 50 in MediaMonkey and English & Other has 697 on device versus 700 shown in MediaMonkey. So 4 out of 1706 files are not shown on the device.
Also note that syncing 1706 files took around 12 hours. Log has been added to previous link.

Ludek

2012-05-04 09:43

developer   ~0031015

Last edited: 2012-05-04 09:45

View 2 revisions

12 hours is really pretty much, I saw the log and in your case there is almost 10 seconds per track, but it looks that that it is caused by slow auto-conversion as you are mostly converting FLAC to MP4. Could you confirm that the slowness is caused by auto-conversion?

If I sync 600 tracks without conversion (e.g. MP3) then it sync in less than 10 minutes, i.e. less than 1 second per track. Could you confirm?

lowlander

2012-05-05 01:27

developer   ~0031028

On 1487 with 600 files it took nearly 20 minutes. It wasn't supposed to convert, but it does seem it was doing it to some files (I only synced MP3 which are supported and not set to be converted) and I'm not sure why.
In good news the device does show 600 of 600 synced files. Log is available in above link.

rusty

2012-05-06 02:04

administrator   ~0031029

Also, see ticket AMX-104041 which includes logs for failed sync operations.

Ludek

2012-05-07 19:26

developer   ~0031042

Last edited: 2012-05-07 19:27

View 3 revisions

Setting as resolved as the issue was confirmed to be fixed for the most of users.

I will analyze the logs from AMX-104041 and track it separatelly in case of problems.

rusty

2012-06-06 17:55

administrator   ~0031300

Verified 1496.