View Issue Details

IDProjectCategoryView StatusLast Update
0009124AAC / Video codec pluginCodecpublic2014-03-14 05:33
Reportermichal 
PrioritynoneSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version2.0.1Fixed in Version2.0.1 
Summary0009124: Converting some specific MP4/H264 files to MP4/H264 gives corrupted image.
DescriptionThe original user video seems to be somehow corrupted (some wrong values in the header), but we should look, if we could do something with it. There is some video size inconsistency, the size in the file header is declared as 851x460, but the video, in fact, is 718x460, it may cause the problems with converting (the video does not convert to WMV/MKV/AVI at all)
Additional Informationhttp://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=15818
TagsNo tags attached.
Fixed in build15

Activities

michal

2012-02-12 10:19

developer   ~0030374

I've found out, that the size in the header is recalculated size by display aspect ratio (1.85), 1.85*460=851. So this could be ok, but there is still some problem in image processing by our H264 encoder. Xvid encoder fails to encode this file at all, so maybe really some problem with the file itself.

michal

2012-02-13 20:34

developer   ~0030394

Fixed in build 15. The problem is in video width (718px), that is not divisible by 4. This is not standard and every decoder handle it differently, I've tested fix with our FFDShow from codec pack and with DivX H264 decoder, it should work now. But e.g. new builds of full FFDshow codec pack show only black screen instead of image while playing the original video (even in WMP), hard to say, what other decoders will do. The best way is to avoid these video sizes.

peke

2014-03-14 05:33

developer   ~0039876

Verified 105 and MMW 1697