View Issue Details

IDProjectCategoryView StatusLast Update
0008678MediaMonkey (current)Tracklistpublic2011-12-16 00:21
Reporterrusty 
PriorityurgentSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0.1 
Summary0008678: Column settings fail to persist for some users
DescriptionSome users in the forums have reported that changes to column configurations don't persist:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=61730
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=61689

Link to a DB that exhibits this behavior provided below.
Additional InformationPosted MM3 DB associated with this problem to the ftp server
TagsNo tags attached.
Fixed in build1460

Relationships

related to 0008632 closedLudek Changing Sort Order of Pre-populated playlists causes all tracks to disappear --> Playlists not limited by Type 

Activities

rusty

2011-11-10 02:19

administrator   ~0028769

According to the first forum post, it seems that changing the 'View as:' setting for all of the playlists to 'Entire Library' fixes the problem. This implies 2 issues:
1) on Upgrade from MM3 to MM4, some playlists are set to 'View as:' Music, and others to 'View as:' Entire library (confirmed by upgrading from MM3 to MM4). Not sure why this is the case.
2) for some reason, in some cases, when the user switches from a node1 to a playlist with a 'View as' setting that is the same as the node1, the column settings of the playlist override those of the node1. Note however, that although I was able to replicate this in bigbwb's DB, I was unable to do so on my own DB that had been upgraded from MM3 to MM4.

Ludek

2011-11-10 14:06

developer   ~0028787

Re 1) It is about issue 0008632 where only these two playlists:
Favorites - 1 Audio CD Worth (74 minutes)
Favorites - 1 MP3 CD Worth (650 MB)
are classified as 'Music' otherwise we classify them as 'Entire Library'

Re 2) The user's DB is in a strange state, it looks like DB update 4,0,48 missed for him, we should try to obtain his MM.DB from version 3 and try to update it to version 4 to see if it is reproducable.

rusty

2011-11-10 14:12

administrator   ~0028788

1) It probably makes sense for all autoplaylists except:
'Last50 played' and 'Recently added' to be categorized as music.

Ludek

2011-11-10 16:14

developer   ~0028795

Last edited: 2011-11-10 16:15

View 3 revisions

Fixed in build 1459.

All playlists except for the 'Last 50 played' and 'Recently added' are set to 'View as: Music' (for regular playlist) or 'Search as: Music' (for auto-playlist) during MM3->MM4 update.

rusty

2011-11-10 16:18

administrator   ~0028796

Assigning to Rusty to get an MM3 DB re. Issue 2)

Ludek

2011-11-10 16:25

developer   ~0028797

Last edited: 2011-11-10 16:29

View 4 revisions

The issue 2) is fixed too, just needs to be verified with the user's DB, but there shouldn't be a problem.

Test note: need to test the MM3->MM4 DB upgrade, i.e. it doesn't affect existing MM4 playlists for obvious reasons

rusty

2011-11-10 23:31

administrator   ~0028813

Verified 1459.

petr

2011-11-23 12:52

developer   ~0029052

There's a regression when editing columns in Entire Library.

petr

2011-11-23 12:52

developer   ~0029053

Fixed in 1460

peke

2011-12-16 00:21

developer   ~0029516

Verified 1461