View Issue Details

IDProjectCategoryView StatusLast Update
0008421MediaMonkey (current)Otherpublic2011-10-26 20:07
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilityunable to reproduce
Status resolvedResolutionnot fixable 
Product Version4.0 
Target Version4.0 
Summary0008421: Crash on use of multimedia keys
DescriptionAs reported at: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=60776 (includes link to a debug log) using build 1436, using previous/next to skip tracks on an iPod --> crash.

I'm unable to replicate this.
Tagstodoc
Fixed in build

Activities

jiri

2011-09-27 07:18

administrator   ~0027953

I asked for EL, which would show more. Ludek, please review the recent code changes anyway, hopefully we could find something.

rusty

2011-09-27 20:05

administrator   ~0027970

EL has been posted to the forum report.

jiri

2011-09-27 21:22

administrator   ~0027972

Setting as not fixable.

Originally I thought that I'm able to reproduce the issue as follows: Rapid successive clicking of Play/Pause button on my Microsoft Natural Ergonomic Keyboard 4000 e.g. while Chrome was in focus caused random termination of either Chrome, Explorer or other applications.

However, then I found that it isn't related to MM at all, that I'm able to reproduce the very same issue e.g. while WinAmp or WMP is playing. It turned out that it's a bug in iType.exe application (IntelliType) that's installed with the keyboard. Once iType.exe is killed in Task Manager, the issue is gone.

peke

2011-10-11 10:34

developer   ~0028182

Can you please let me know which KB article should be updated as iType issues are known and unless user wants to Program MS keyboards and assign custom functions to keys or watch status of battery driver is not needed at all?

rusty

2011-10-26 20:07

administrator   ~0028468

I'll take care of the doc updates.