View Issue Details

IDProjectCategoryView StatusLast Update
0008411MediaMonkey (current)DB/FileMonitorpublic2017-05-12 15:04
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.1.17Fixed in Version4.1.16 
Summary0008411: iTunes Data Import doesn't work (for non-default iTunes config)
DescriptionOn scan, MM prompts whether data (ratings/play history) should be imported from iTunes.

This functionality isn't working in build 1435.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=60692
TagsNo tags attached.
Fixed in build1835

Relationships

related to 0008803 closedLudek Import Playlists from other applications 

Activities

petr

2011-09-25 19:20

developer   ~0027922

Fixed in 1437

Ludek

2011-10-03 13:57

developer   ~0028019

Last edited: 2011-10-03 13:57

View 2 revisions

The explanation is here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=60692#p313427

The user changed default location for "iTunes Music Library.xml" file that is needed for the importing.

jiri

2011-10-03 15:18

administrator   ~0028021

My guess is that location of the active iTunes library might be stored in C:\Users\<user>\AppData\Roaming\Apple Computer\iTunes\iTunesPrefs.xml

as (probably) Base64 encoded:

<key>iTunes Library Location:1</key>
<data> RAA6AFwAaQBUAHUAbgBlAHMAIAAxAA== </data>
<key>iTunes Library XML Location:1</key>
<data> RAA6AFwAaQBUAHUAbgBlAHMAIAAxAFwAaQBUAHUAbgBlAHMAIABMAGkAYgBy AGEAcgB5AC4AeABtAGwA </data>

Since it isn't that urgent, setting target to 4.1

Ludek

2011-12-12 14:27

developer   ~0029428

Fixed in build 1461.

peke

2012-01-03 23:55

developer   ~0029721

Verified 1463

lowlander

2012-02-09 22:12

developer   ~0030345

User reports this still fails on 1470: http://www.mediamonkey.com/forum/viewtopic.php?p=330795#p330795

Ludek

2012-02-13 11:15

developer   ~0030387

Fixed in build 1473.

peke

2012-02-16 03:50

developer   ~0030436

Verified 1473

peke

2012-04-05 00:58

developer   ~0030834

Supplied iTunesPrefs.xml confirms that library is located at F:\Users\id\Music\iTunes
This looks like regression.

Ludek

2012-04-05 13:51

developer   ~0030835

Fixed in 4.0.4.1480

peke

2013-12-07 21:49

developer   ~0038585

Verified 1675

Ludek

2017-03-07 17:20

developer   ~0047422

Last edited: 2017-03-07 17:23

View 2 revisions

Re-opened, the key
<key>iTunes Library Location:1</key>
is no longer presented within the iTunesPrefs.xml

Until this is fixed the workaround is to copy the 'iTunes Music Library.xml' file into
C:\Users\<user>\Music\iTunes\iTunes Music Library.xml
(i.e. the default location)

SVZ-503-41341
http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=87148&p=433680#p433055

Ludek

2017-03-08 11:29

developer   ~0047440

Last edited: 2017-03-08 11:31

View 3 revisions

Peke please do a research where iTunes stores the path to "iTunes Music Library.xml" currently and assign to me for implementation. Thx.

Ludek

2017-03-09 15:34

developer   ~0047452

Last edited: 2017-03-09 16:21

View 7 revisions

Starting from build 1831 MediaMonkey locates also 'iTunes Library.xml' and 'Library.xml' in the default location.
---------------------------------------------------

Nevertheless starting from iTunes version 12.2 the XML library is no longer auto-exported (in the default config) and needs to be manually enabled in iTunes: https://support.apple.com/ht201610

So the fix seems to be to list iTunes in the "Scan results" dialog's importers once MM detected that iTunes is installed, but if MM cannot locate the XML file then show user dialog like:

MediaMonkey cannot locate iTunes XML library file to import data from. Please enable sharing of iTunes XML library in iTunes or export it from iTunes and select the file.

[............................] [Browse]

[Help] [OK]


The help link would be redirected to KB article or https://support.apple.com/ht201610


Assigned to Rusty for wording corrections.
BTW: Do we want to include it in 4.1 version?
It would require update of localization -- so maybe including this in MM5 would be enough and for MM4 just add a KB article?

peke

2017-03-10 03:32

developer   ~0047453

To enable share on windows steps are

Open iTunes -> File -> Preferences -> Advanced Tab -> Select "Share iTunes Library XML with other applications."

rusty

2017-05-03 16:40

administrator   ~0047902

I would suggest clarifying this as follows:


MediaMonkey can't import metadata from your iTunes database. To resolve this automatically, run iTunes and enable 'Share iTunes Library XML...'. To do so manually, please export the iTunes XML library via iTunes and select it below.

[............................] [Browse]

[Help] [OK]

Note:
- As mentioned above, [Help] would link to the Apple article
- Presumably, clicking OK would trigger another attempt to read the iTunes DB (otherwise it's not obvious how to proceed). If so, is a [Cancel] button required?

Ludek

2017-05-11 15:43

developer   ~0047953

Added in 4.1.16.1835

peke

2017-05-12 15:04

developer   ~0047971

Verified 1835