View Issue Details

IDProjectCategoryView StatusLast Update
0008352MediaMonkey (current)Otherpublic2011-09-14 22:23
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0008352: Explorer integration: tracks are always added out of order (Windows 7 only)
DescriptionIn MM4, when the user right clicks on a set of tracks in Explorer > Play in Winamp/WMP --> the tracks play in the correct order in Winamp or WMP, beginning with the track that was right-clicked.

In MM 3.x, some users indicated that this also worked, though others indicated that it only worked when MM is run as Administrator.

In MM 4.x, this doesn't work at all--i.e. tracks are always added out of order.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=37793
TagsNo tags attached.
Fixed in build1432

Relationships

related to 0000420 resolvedjiri Playing Multiple Tracks from Explorer --> Incorrect Now Playing list 
parent of 0008460 closedLudek Play Next/Play Last in explorer context menu results in 'Play now' (regression) 
related to 0008785 closedLudek Play Next in OS Integration fails 

Activities

jiri

2011-09-09 19:38

administrator   ~0027530

I think that this must have worked sometimes, since we most likely sorted the source tracks by filename.

Ludek

2011-09-12 11:17

developer   ~0027598

Last edited: 2011-09-12 12:19

View 3 revisions

This works fine for me:

1. Sorted tracks as A,B,C,D in the Windows explored
2. Right-clicked track A, selected 'Play in MediaMonkey' and it was added as A,B,C,D as expected
3. Right-clicked track B, selected 'Play in MediaMonkey' and it was added as B,C,D,A as expected

So what is wrong here? Isn't this just the test error as Lowlander stated here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=37793&start=15#p310966

Tested on XP, Vista, Win7 and the behaviour is same with WMP.

rusty

2011-09-12 14:07

administrator   ~0027606

This should clarify:
http://screencast.com/t/hjFkS27PcZ

Generated by MM Portable, on Win 7, running as a user with admin rights, using build 1430.

Ludek

2011-09-12 15:16

developer   ~0027609

Last edited: 2011-09-13 21:45

View 6 revisions

You seem to be right, in Windows 7 the tracks are added out of order (Win XP works fine).

Problem is that in Win XP the files are sent at once via IDropTarget, but starting from Vista the files are sent as command line params.

Ludek

2011-09-13 16:01

developer   ~0027669

Last edited: 2011-09-13 21:44

View 2 revisions

Fixed in build 1432.

Testing note: needs OS integration

peke

2011-09-14 22:23

developer   ~0027712

Verified 1432