View Issue Details

IDProjectCategoryView StatusLast Update
0008260MediaMonkey (current)Tracklistpublic2011-11-10 15:30
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0008260: Column Sort and Grouping settings/issues
DescriptionWith the various changes that have been made, default sorts need to be improved in many cases, and a few related issues fixed:

1 Music (D):
 i) Album column is missing (it should follow 'Artist')
 ii) Default sort should be by Artist, Album, CD#, Track# (so tracks play in order)

2 Music (A&D):
 i) Currently sorted by Artist and Stacked by Album. But should be sorted by Album Artist, Album, CD#, track# (i.e. by Summary and CD#, Track #) and stacked by Album?
 ii) Unclear what sorting by Artwork does. Should it be disabled?
 iii) Sorting by Summary is in the wrong order (see attached image). Similar to 2i.

3 Music (A):
 i) Albums appear to be sorted by Artist, but they're not really--see image
 ii) Double-clicking an Album causes the tracks to play out of order. It should be by CD#, Track#.

4 Music (AB):
 i) The order of albums in the Art Browser is by Album Title. It should be by Album Artist, Album Title
 ii) The order of tracks should be CD#, Track#

5 Classical (D):
  Same as 1ii)

6 Classical (A&D)
  Same as 2

7 Classical (A)
  Same as 3

8 Classical (AB)
  Same as 4

9 Podcast (D)
  i) Similar to 1i) - 'Podcast' column should follow the 'Title' column
  ii) Sort order should be Podcast, Date (descending)

10 Podcast (A&D)
  i) Sort is currently by Artist. It should be by Podcast (grouped by Podcast -- the same podcast name shouldn't be listed 10 times), and within a podcast, by Date.

11 Podcast (A)
  i) Columns Artist, Podcast, Album Artist, Conductor, Genre, Date, Rating, Disc#, Length --> Podcast, Artist, Genre, Date, Rating, Length
  ii) Podcasts are currently not stacked by Podcast. They should be (except perhaps in the case of Video Podcasts)

12 Podcast (AB)
  i) Tracks are currently sorted by Artist (although they seem to also be sorted by Date even though there's no indicator). Shouldn't they be sorted by Date?

13 AudioBooks (D)
  Same as 1ii)

14 AudioBooks (A&D)
  Same as 2i)

15 AudioBooks (A)
  i) Audiobooks are currently not stacked by Audiobook. They should be (and double-clicking the stack should play them in order).

16 AudioBooks (AB)
  i) The order of tracks should be CD#, Track#

17 Video (D)
  i) Columns should change from: Title, Director, Producer, Date, Genre, Rating, Artist, Path, Filename, Length, Episode, Season... --> Title, Date, Director, Producer, Genre, Rating, Path, Filename, Length, Series, Season, Episode...
  ii) Default sort should be by Series, Title, Season, Episode#

18 Video (A&D)
  i) Columns should be updated to match 17i)
  ii) Currently 'Summary' column is missing
  iii) Currently sorted by Artist and stacked by Folder. It should be stacked by Series instead/in additon?, and sorted by Summary (= Series + Title), and within a Series, sorted by Season, Episode#.

19 Video (A)
  i) The width of the Series/Title column should be increased so that the text is visible (note that the column width resets each time the user re-enters the Art view.

20 Video (AB)
  i) The images are presently stacked by Folder--they should be stacked by Series instead/in addition?
  ii) Columns should be inline with 17i)
Additional InformationSorting specs: https://docs.google.com/a/mediamonkey.com/spreadsheet/ccc?key=0AkAUbk8DpJoadEE5eThhNEgzU1Jva2drVkFaRFVCVEE&hl=en_US#gid=0

http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59954
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59663
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59935
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=60006
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59636
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59924
Tagstodoc
Fixed in build1456

Relationships

related to 0006579 closedpetr UI Simplification: Remove 'Views' from Collections Options 
related to 0006777 closedpetr Collection Default settings 
related to 0008064 closedpetr Art with Details View not optimized for Videos 
related to 0007998 closedpetr Sort order is mixed up in Art view 
related to 0008131 closedpetr AA view: columns don't set/sort for video 
related to 0008065 closedpetr Art with Details view shows no grouping when sorting on Title 
parent of 0008299 closedpetr Art with Details View doesn't doesn't display in correct order for randomized playlists (regression) 
parent of 0008463 closedpetr Video/Television sort order incorrect, and changes depending on last-visited node 
related to 0008321 closedpetr Keyboard navigation fails in artview for certain sorts 
related to 0008389 closedpetr Disabling Album Column fails 
related to 0008470 closedpetr Summary Hyperlinks don't match content (regression) 

Activities

rusty

2011-08-18 05:55

administrator  

rusty

2011-08-18 05:55

administrator  

rusty

2011-09-02 21:10

administrator  

rusty

2011-09-02 21:11

administrator   ~0027444

Last edited: 2011-09-06 03:50

View 4 revisions

So, following more discussion in which we tried to come to a solution that would also deal with the fact that:
- different Summaries are required for items that are stacked, vs those that aren't
- 'ignore prefix' settings shouldn't be ignored for the summary column

The following was proposed:

Summary masks would use something like:
$if( $groupcount=1, {mask for 1 file}, {mask for >1 file})

Where $groupcount represents the number of files in an Album/Series given the current sort (i.e. it isn't the absolute number of files in an Album or Series, but rather the number of files that in an Album/Series that are adjacent to one another given the current View/Sort). This would solve the problem of the need for different masks

Additionally, masks will be automatically modified internally so that prefixes will be removed (e.g. <Artist> will be changed to $RemovePrefix(<Artist>), and for any fields to which Ignore Prefixes applies).
(raised at http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59961 ).

This isn't perfect, though, since as is visible in the attached documentation, there is still some repetition of metadata between the Summary and other metadata columns in Art & Details view (e.g. movies would appear in A&D view with a Summary that would duplicate some other columns.), however, it seems to be a decent approach for now.

The attached chart ( http://www.ventismedia.com/mantis/file_download.php?file_id=892&type=bug ) shows how this should look, however, the linked spreadsheet ( https://docs.google.com/spreadsheet/ccc?key=0AkAUbk8DpJoadEE5eThhNEgzU1Jva2drVkFaRFVCVEE&pli=1&ndplr=1#gid=0 ) doesn't have updated masks. Note also, the Audio masks can be updated as well, using the new constructs, however, it isn't critical.

Note also the following bugs:
i) Hidden sorts are often not working… (e.g. Albums not playing by Track#)
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59954
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59663
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=60006

ii) Sort on Summary isn't always working:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59935
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=59636 (AC/DC messes it up?)

iii) Album column can't be enabled in some cases for the My Computer node:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=60327

rusty

2011-09-05 22:08

administrator   ~0027459

Last edited: 2011-09-06 04:31

View 3 revisions

Tested 1427 (internal) and found the following thus far:
Note: Feedback below is based primarily on the implementation in build 1427 vs the specs at:
https://docs.google.com/spreadsheet/ccc?key=0AkAUbk8DpJoadEE5eThhNEgzU1Jva2drVkFaRFVCVEE&pli=1&ndplr=1#gid=0

1) Music/Art: Should be sorted by 'Album Artist, Album, [CD#, Track#, File] instead of Album, [CD#, Track#, File] (spec was wrong)

2) Music/Art&Details: Bug -- Album is split up when album tracks are in two different locations

3) Music/Art Browser: Should be sorted by Summary, [Album, CD#, Track#, File] instead of [Album, CD#, Track#, File]

4) Issues 1 and 3 also apply to 'Classical', ....

5) Podcast/Details: Appears to be sorted by Podcast, Date, [CD#, Track#, File], however, the Sort indicator only shows that it's sorted by Date. i.e. once the sort order changes, it's unclear how to get back to this sort.

6) Podcast/Art: AudioPodcasts aren't stacked (e.g. 1 podcast with 30 episodes shows 30 artwork images).

7) Podcast/Art&Details:
i There's no column for 'Podcast' (or Summary as a proxy for Podcast). i.e. MM displays Artwork, Title, Artist, Date, Genre, Rating, etc. instead of Artwork, Summary, Title, Artist, Date, Genre, Rating...

ii Grouping is by Podcast, and sort within the Stack is by date, however, it's really unclear how sorting works (i.e. the relationship between sorting and grouping is unclear)--once the sort order changes it's unclear how to get back to this sort/grouping.

8) Audiobook/Art Browser: Title, Artist, Date, Album, Genre... --> Title, Artist, Album, Date, Genre...

9) Audiobook/Details: same as above

10) Audiobook/Art:
i) There's no sort indicator by default (default sort should be by Album Artist, [Album, CD#, Track#, File])
ii) Tracks aren't stacked by Album

11) Video/Art&Details:
i) When videos are 16:9, there are alignment issues in the A&D view (see attached image).
ii) The default sort is by 'Artwork'--unclear what that means!
iii) There's no column for 'Series' by default!

12) Video/Details: Series column is missing

13) Video/Art:
i) Many movies are listed as Title, Title!
ii) I've not sure if this is a bug or not, but sorting seems a bit off (for the default sort of Series/Title.
 - K:\My Documents\My Pictures\2011\2011_02_10\MVI_4912.MOV, Title= MVI 4912, Series= 2011 02 10, Date= 2011 , appears near the top of a set of 3000 files
 - K:\My Documents\My Pictures\2003\2003_01_30\106_0619.AVI, Title= 106 0619, Series= 2003 01 30, Date= 2003 , appears near the bottom of the same set of 3000 files

14) Music Video/Art&Details: same issues as 11)

15) Music Video/Art:
i) The Art mask could probably be adapted for music, so that it shows Artist/Album metadata, and in the case of single tracks, also displays track metadata. e.g.:
Artist - Album
Title (mm:ss)

16) TV
i) Series expander is out of place. See attached image.
ii) Same issues as 11, 12, 13

17) Art and Details view (always): text fields are misaligned (see image).

rusty

2011-09-06 04:23

administrator  

rusty

2011-09-06 04:23

administrator  

rusty

2011-09-06 04:24

administrator  

rusty

2011-09-06 04:30

administrator  

rusty

2011-09-13 04:34

administrator   ~0027653

A few remaining issues as of build 1431.

1) Music:
a) Art&Details:
i) Add Summary column and remove Album Column? (currently no Album Artist!)
ii) Sort by Summary (or Album) instead of by Artwork (i.e. Artwork is meaningless as a sort)

b) Art View
i) Add indicated columns: Artist, [Album Artist], Album, Genre, Date, Rating,

Length
ii) Sort by Album Artist [Album, CD#, Track#, File]

2) Classical:
a) Details
Add indicated column: Title, Artist, Composer, Album, Genre, [Date], Rating, Length

b) Art&Details:
i) Add Summary column and remove Album Column?
ii) Sort by Summary (or Album) instead of by Artwork (i.e. Artwork is meaningless as a sort)

c) Art View:
Add indicated columns: Artist, Composer, [Album Artist], Album, Genre, [Date], Rating, Length

3) Audiobook:
a) Art&Details:
i) Add Summary column and remove Album Column? (currently no Album Artist!)
ii) Sort by Summary (or Album) instead of by Artwork (i.e. Artwork is meaningless as a sort)

iii) Art View:
Add indicated columns: Artist, [Album Artist], Album, Genre, Date, Rating, Length

4) Video/TV:

iii) Art View:
Add indicated columns: Series/Title, Date, Director, Producer, Genre, [Rating], [Length]


5) Misc. issue:
-Header titles get mixed if switching between Collections that are in Art View. e.g. Switch from Classical Music (Art View) to Podcast (Art View) --> Podcast column shows up as 'Series'

petr

2011-09-13 11:49

developer   ~0027657

Fixed in 1432.

rusty

2011-09-13 20:13

administrator   ~0027685

Test note: as described here, issue 5 is also particularly noticeable when switching between Tabs/Collections/Views while enabling/disabling/moving columns (and may even be the cause of the configuration corruption on upgrade that is described at 0008367.

rusty

2011-09-16 17:53

administrator   ~0027771

Issue 5 is still open. e.g.
- switch to music node, details view
- enable Album column
- switch to podcast node
- switch to music node & switch from Details to Art & Details
--> Album column header changes to 'Podcast'!!
- switch to Video node
- switch to Music node & switch from Details to Art & Details
--> Album column header changes to 'Series'!!

In other words, switching collections and views causes the Album column to adopt the Title of the previously visited collection.

petr

2011-09-17 22:47

developer   ~0027794

Fixed in 1434

peke

2011-09-27 01:47

developer   ~0027950

Verified 1436

rusty

2011-10-27 06:51

administrator   ~0028477

Issue 5 is still present in 1449. Here's one way to reproduce:
1 Clean install
2 Switch to Music node / Details view
3 Switch to Art&Details view
--> Album column is missing!
4 Switch to Now Playing node
5 Switch back to Music node/Art & Details view
--> Album column magically appears!

petr

2011-10-27 09:28

developer   ~0028479

Fixed in 1450

rusty

2011-11-07 19:47

administrator   ~0028703

Another issue:
Clicking 'New Tab' button causes column layout to get mixed up (i.e. the new tab has a different layout than the originating tab).

http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=61689

petr

2011-11-07 20:26

developer   ~0028704

Fixed in 1456

rusty

2011-11-07 21:10

administrator   ~0028705

Last edited: 2011-11-07 23:53

View 2 revisions

1) Music (A&D): No Summary Column/Sort order indicated initially. i.e.
 1 Music (details). Switch to Music (A&D) --> no sort indicator
 2 Switch to Music > Location (A&D) --> Summary Columns + Sort indicator appears
 3 Switch back to Music (A&D) --> Summary Column + Sort indicator appears! (even though it was missing at step 1)

The way that this should work is specced at 0008389 . For example, the user could have 'Album' enabled in details view, and 'Summary' in A&D view. i.e. it's up to the user to choose which of Summary/Album to display in A&D view. I think that for music, 'Summary' is probably prefered to 'Album'.

2) Video: Tracklists show 'Artist' instead of 'Actor'

3) Missing / Incorrect default sort orders (note: this is from a quick review--I haven't verified vs the spec)

Music > Artist&Album Artist (ArtBrowser) -- No Sort indicator
Music > Artist&Album Composer (ArtBrowser) -- No Sort indicator
Music > Artist&Album Album (ArtBrowser) -- No Sort indicator
Music > Artist&Album Publisher (ArtBrowser) -- No Sort indicator

Music > Album (ArtView) -- No sort indicator


Classical > Composer (details): should be sorted by Composer instead of Title

Classical > Composer (ArtView): should be sorted by Composer instead of Summary (Description)

Classical > Composer (Art&Details): should be sorted by Composer in addition to Summary

Classical > Album (ArtView): No sort indicator

Classical > Album (Art&Details): Is sorted by Artwork instead of Album / Summary

Classical (Art&Details): No sort indicator

---

Sort order of Podcast node is unclear (i.e. what is the order of podcasts that have the same date ?)

Sort order of podcasts within a <Podcast> node isn't indicated

---

Audiobook > Album (A&D): Sorted by Artwork instead of by Album / Summary

Audiobook > Album (ArtView): No sort indicator for Album

---

Video (Art View): No sort indicator

Video > Series (Art View): No sort indicator

Video (Details): Sorted by Episode??!!

Video > Director(Details): Sorted by Year/Title instead of Director / Title

Video > Producer(Details): Sorted by Director/Title instead of Producer/Title

Video > Series (Details): Sorted by Year instead of Series/Episode

rusty

2011-11-08 02:23

administrator   ~0028708

fixed 1456.

peke

2011-11-10 15:30

developer   ~0028792

Verified 1458