View Issue Details

IDProjectCategoryView StatusLast Update
0008036MediaMonkey (current)Main Panelpublic2011-09-19 20:29
Reporterjiri 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOS7OS Version-
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0008036: Unsynchronized tracks show incorrect columns
DescriptionOn a clean install, Music\Unsynchronized Tags node shows incorrect columns, like 'Actor(s)', etc. There are other problems as well, e.g. that 'Choose Columns' header menu item shows 'Actor(s)' as unchecked, but in the right-click pop-up menu Actor(s) are checked.
TagsNo tags attached.
Fixed in build1398

Relationships

related to 0005727 closedLudek Files to Edit > Unsynchronized tracks doesn't report some unsynced tracks (for non ID3v1 fields) 

Activities

petr

2011-06-28 15:16

developer   ~0026417

Fixed in 1398

Ludek

2011-06-28 15:46

developer   ~0026419

Last edited: 2011-06-28 15:51

View 3 revisions

Re-opened since you have just removed code that I added so that 'Unsynchronized tags' node shows all columns that can be stored into file tag.
i.e. it should not depend on view settings of particular collection so that all unsynced fields are visible.

jiri

2011-06-28 17:55

administrator   ~0026421

This was discussed offline and it was decided that it's better to show just columns of the Collection, not all columns.

rusty

2011-06-28 17:58

administrator   ~0026422

Last edited: 2011-06-28 17:59

View 2 revisions

I would have expected that all nodes sub to a Collection should adopt the collection's settings as far as which columns are displayed.

It's kind of strange to display columns that are irrelevant to a collection (e.g. displaying Actors in the Music Collection.

The remaining issue is that some tracks may appear unsynched, but there won't be an indication of what field is unsynched (since not all fields are displayed).

peke

2011-09-19 20:29

developer   ~0027844

Verified 1433