View Issue Details

IDProjectCategoryView StatusLast Update
0007985MediaMonkey (current)DB/FileMonitorpublic2011-09-21 21:52
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Fixed in Version4.0 
Summary0007985: Performance: Location node and Find more from same are less responsive than MM3
DescriptionThere are 2 remaining areas of performance regressions that are affecting serious collectors:
1) Performance of the Locations node tree. Expanding any node takes ~2s, making navigation of the hierarchy a frustrating experience. In contrast, with MM3, this is instantaneous.

2) Performance of Find more from same. In MM4, this can take several seconds (according to users even longer, but I've only seen several seconds), whereas in MM3 this is near instantaneous.

Both of these can be observed by testing with a very large DB (e.g. 150k tracks).
Tagstodoc
Fixed in build1396

Relationships

related to 0006498 closedLudek Loading large auto-playlist sometimes take abnormally long (can interfere with playback?) 
related to 0007843 closedjiri Performance: loading track list takes 20% longer than MM3 
parent of 0008377 closedLudek Expansion of some tree nodes triggers 1-minute freeze 
parent of 0008688 closedLudek TV > Series node slow to expand for custom TV collections (regression) 
related to 0007992 closedpetr ANALYZE DB after major changes 

Activities

jiri

2011-06-22 07:59

administrator   ~0026275

1) It actually is about testing methodology - in suppose that you tested Entire Library in MM 3, but filters in MM 4. If you test the same in both cases, the results are:
Entire Library - nearly instantaneous in both cases
Filtered Collections - is significantly faster in MM 4.

I understand that we need to compare the default settings of MM 3 vs 4, but we are really close to limits in MM 4 and so we can only try to explain these things to users. I don't think it's anything serious though, because we are only talking about DBs >100k tracks on slower machines. On my PC (not the very latest and fastest) 150k DB is very well usable.

Last note - we can try to improve things further, but that means pretty complex algorithms and changes, i.e. something for 4.1.

2) Since it involves node expansions, it's actually the same as 1).

Ludek

2011-06-22 08:31

developer   ~0026276

Last edited: 2011-06-22 08:33

View 2 revisions

Rusty, in my case MM4 is much faster than MM3 in expanding of Location subnodes.

Tested with a large DB (180k tracks):
1. Upgraded the DB from MM3 to MM4 format
2. Tested MM3: expansion of filter 'General Music' -> 'Location' subnodes took several seconds
3. Tested MM4 (1393): expansion of collection 'Music' -> 'Location' subnodes took less than a second

I guess you tested non-filtered MM3 which would explain why MM3 is faster for you?

EDIT: I overlooked Jiri's note

rusty

2011-06-22 13:20

administrator   ~0026278

Last edited: 2011-06-22 13:26

View 3 revisions

Yes--I was testing the default configuration in both cases (Entire Library in MM3, 'Music' Collection in MM4).

Unfortunately, on my machine, with a large library, navigating the Locations tree is not usable--waiting 2s for each node in a tree to expand is too frustrating.

Re-opening (for 4.1?)

jiri

2011-06-22 14:33

administrator   ~0026279

Fixed in build 1395.
 - I found a way how to make some significant improvements of Locations, Artist and Album nodes.

rusty

2011-06-23 04:42

administrator   ~0026307

This results in major performance improvements in the locations node. Two remaining issues:
1) Expanding the root Locations node can take 15s the first time, and ~3-5 seconds each time thereafter, even if there's only a single subnode.
2) The 'All' nodes still take several seconds (though I'm not sure that there's much that can be done about that).

jiri

2011-06-23 08:45

administrator   ~0026315

Fixed in build 1396.
 1) Significantly improved.
 2) Due to complexity of the query, it doesn't seem to be possible to improve. It's the same as MM3 though.

jiri

2011-06-23 14:53

administrator   ~0026321

Also fixed in build 1396 a regression reported here: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=58784

lowlander

2011-07-05 15:40

developer   ~0026538

Testing on 1400 the Entire Library > Location works fast, but Collection > Location works slow when many subfolders need to be opened.

jiri

2011-07-07 12:25

administrator   ~0026604

1. As for the Location node - I can't access the log. Anyway, decreasing priority, since it seems that we can't make it much better. Will review later though...

2. As for AutoPlaylist with Path criteria, I have entered 0008094.

lowlander

2011-09-15 14:45

developer   ~0027748

1) On 1432 the Location node works fast enough.

jiri

2011-09-16 06:17

administrator   ~0027761

Setting as resolved.

lowlander

2011-09-16 15:30

developer   ~0027766

Verified on 1432.

rusty

2011-09-19 18:17

administrator   ~0027839

Build 1433 has a regression in this area. e.g. select Video > Location node and then expand sucessive nodes
--> It can take a minute or so for nodes to expand.

jiri

2011-09-20 10:22

administrator   ~0027856

I don't see any such a problem and there also doesn't seem to be any reason for a regression in this area. Can you reproduce it? Please create a debug log then...

rusty

2011-09-21 21:52

administrator   ~0027888

Cannot reproduce any issues in build 1434.