View Issue Details

IDProjectCategoryView StatusLast Update
0007920MediaMonkey (current)Otherpublic2011-11-16 01:07
Reporterjiri Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOS7OS Version-
Product Version3.2.5 
Target Version4.0Fixed in Version4.0 
Summary0007920: COM Events don't work external applications
DescriptionAlthough COM events have worked well for scripting for quite some time, they haven't ever worked well for external applications.
Additional Informationsee e.g. http://www.mediamonkey.com/forum/viewtopic.php?f=19&t=29201
TagsNo tags attached.
Fixed in build1384

Activities

jiri

2011-06-03 09:36

administrator   ~0025892

Fixed in build 1384.

Ludek

2011-06-07 10:14

developer   ~0025968

Reminder sent to: jiri

There seems to be a regression most probably related to this change:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=58409

jiri

2011-06-07 14:23

administrator   ~0025971

As discussed over IM, this isn't related to this issue, but is a new one - 0007934.

peke

2011-11-13 01:21

developer   ~0028860

I created Small Test app and it seams that OnPlay Event is not triggered. Maybe I'm Missing something.

Sources are uploaded to FTP. Test App I used is Project1.DPR/DPROJ

jiri

2011-11-14 09:25

administrator   ~0028872

There seem to be problems in the sample application, in the way how it initializes the server. For example, I didn't get the event, but after adding the line:

ShowMessage( inttostr( SDB.VersionHi));

to initialization code, it started to work fine.

peke

2011-11-16 01:07

developer   ~0028898

Confirming your findings Jiri. Closing for now.