View Issue Details

IDProjectCategoryView StatusLast Update
0006995MediaMonkey (current)Synchronizationpublic2010-12-24 18:04
Reporterjiri 
PriorityimmediateSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006995: Add detailed USB ID to Device Profile
DescriptionCurrently we save Device ID to Device Profile, but it doesn't always contain all the useful information.
TagsNo tags attached.
Fixed in build1341

Activities

jiri

2010-12-15 15:57

administrator   ~0021845

I added dstUSBIDDetails string parameter to device plug-ins (currently implemented in d_WMDM only, which should be enough).
Ludek, please:
1. Save this field to a new column in Devices DB table.
2. Save this field to the XML Device Profile.

jiri

2010-12-15 15:59

administrator   ~0021846

Testing note: This doesn't add any functionality to MM, it's just an internal issue that should help us in the future.

Ludek

2010-12-20 20:34

developer   ~0021969

Last edited: 2010-12-20 21:10

View 2 revisions

Fixed in build 1338

rusty

2010-12-22 22:20

administrator   ~0022051

Tested build 1338--the USB ID wasn't included in an MMDC file for an MTP device.

rusty

2010-12-22 22:21

administrator   ~0022052

Set to immediate because it's required for populating the device db.

jiri

2010-12-22 22:25

administrator   ~0022053

The clarify, all exported XML contain:

<DeviceID></DeviceID>
<DetailedUSBID></DetailedUSBID>

instead of correct strings.

Ludek

2010-12-23 16:59

developer   ~0022103

Fixed in 1341

rusty

2010-12-24 18:04

administrator   ~0022129

Verified 1341.